summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2016-07-29 17:08:05 +0200
committerLars Wendler <polynomial-c@gentoo.org>2016-07-29 17:08:32 +0200
commit9daa908a1adb55e4d56226ac262277535f757af0 (patch)
tree18bcede0700d0c7b2268c8f6972cc6733b178aa5 /sys-libs
parentnet-p2p/syncthing: add missed einstalldocs call (diff)
downloadgentoo-9daa908a1adb55e4d56226ac262277535f757af0.tar.gz
gentoo-9daa908a1adb55e4d56226ac262277535f757af0.tar.bz2
gentoo-9daa908a1adb55e4d56226ac262277535f757af0.zip
sys-libs/libcap-ng: Bump to version 0.7.8
Package-Manager: portage-2.3.0 Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
Diffstat (limited to 'sys-libs')
-rw-r--r--sys-libs/libcap-ng/Manifest1
-rw-r--r--sys-libs/libcap-ng/libcap-ng-0.7.8.ebuild100
2 files changed, 101 insertions, 0 deletions
diff --git a/sys-libs/libcap-ng/Manifest b/sys-libs/libcap-ng/Manifest
index 1f99af65e2f3..0f66f7e3a1c8 100644
--- a/sys-libs/libcap-ng/Manifest
+++ b/sys-libs/libcap-ng/Manifest
@@ -1 +1,2 @@
DIST libcap-ng-0.7.7.tar.gz 420178 SHA256 615549ce39b333f6b78baee0c0b4ef18bc726c6bf1cca123dfd89dd963f6d06b SHA512 eb049b29fdd31aa31c6c14ca023df62c2910504c1edd1242dba13579d0befae5b98249c22c145517bd5451969a0b186390dc11b2269e58001336e10c855e920c WHIRLPOOL 5d376b8d12ed8c19ca649095297e6016e86e5ad6112fd12685929bdd5f3c34bbcdf9c1c61cad44f44d3784192ca37df1a77c478e5fc15dacb20a2561ee945652
+DIST libcap-ng-0.7.8.tar.gz 447946 SHA256 c21af997445cd4107a55d386f955c5ea6f6e96ead693e9151277c0ab5f97d05f SHA512 c32a4c5780c183b13611615abe9061221fd8987188b08828d1617cdaee338ad8de67b3430aa83bde60128efc76449a688546bfbf697f0847b6a835cb1a868756 WHIRLPOOL a56ee901f301c4c2e0353e2b9e38938fcd6efbb9394d60af6c7045967e6a310fd19b658617b362f14489a75da64a69e82a3afcada97f898c2ab25fad6fb6603d
diff --git a/sys-libs/libcap-ng/libcap-ng-0.7.8.ebuild b/sys-libs/libcap-ng/libcap-ng-0.7.8.ebuild
new file mode 100644
index 000000000000..ca213a6f3090
--- /dev/null
+++ b/sys-libs/libcap-ng/libcap-ng-0.7.8.ebuild
@@ -0,0 +1,100 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+AUTOTOOLS_AUTORECONF=1
+AUTOTOOLS_PRUNE_LIBTOOL_FILES=all
+PYTHON_COMPAT=( python{2_7,3_3,3_4,3_5} )
+
+inherit autotools-utils flag-o-matic python-r1
+
+DESCRIPTION="POSIX 1003.1e capabilities"
+HOMEPAGE="https://people.redhat.com/sgrubb/libcap-ng/"
+SRC_URI="https://people.redhat.com/sgrubb/${PN}/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~arm-linux ~x86-linux"
+IUSE="python static-libs"
+
+RDEPEND="python? ( ${PYTHON_DEPS} )"
+DEPEND="${RDEPEND}
+ sys-kernel/linux-headers
+ python? ( >=dev-lang/swig-2 )"
+
+RESTRICT="test"
+
+src_prepare() {
+ sed -i -e 's:AM_CONFIG_HEADER:AC_CONFIG_HEADERS:' configure.ac || die
+
+ autotools-utils_src_prepare
+
+ use sparc && replace-flags -O? -O0
+}
+
+src_configure() {
+ # set up the library build
+ local myeconfargs=( --without-python --without-python3 )
+ autotools-utils_src_configure
+
+ # set up python bindings build(s)
+ if use python ; then
+ setup_python_flags_configure() {
+ if [[ ${EPYTHON} == python2* ]] ; then
+ myeconfargs=( --with-python --without-python3 )
+ else
+ myeconfargs=( --with-python --with-python3 )
+ fi
+ autotools-utils_src_configure
+ }
+
+ python_foreach_impl setup_python_flags_configure
+ fi
+}
+
+src_compile() {
+ autotools-utils_src_compile
+
+ if use python; then
+ python_compile() {
+ local CFLAGS=${CFLAGS}
+
+ python_is_python3 || CFLAGS+=" -fno-strict-aliasing"
+
+ emake "${@}" \
+ -C "${BUILD_DIR}"/bindings/python
+ }
+
+ # help build system find the right objects
+ python_foreach_impl python_compile \
+ VPATH="${BUILD_DIR}"/bindings/python \
+ LIBS="${BUILD_DIR}"/src/libcap-ng.la
+ fi
+}
+
+src_test() {
+ if [[ "${EUID}" -eq 0 ]]; then
+ ewarn "Skipping tests due to root permissions."
+ return
+ fi
+
+ autotools-utils_src_test
+
+ if use python; then
+ python_foreach_impl \
+ autotools-utils_src_compile -C bindings/python check \
+ VPATH="${BUILD_DIR}"/bindings/python:"${S}"/bindings/python/test
+ fi
+}
+
+src_install() {
+ autotools-utils_src_install
+
+ if use python; then
+ python_foreach_impl \
+ autotools-utils_src_install -C bindings/python \
+ VPATH="${BUILD_DIR}"/bindings/python
+ fi
+}