summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrian Evans <grknight@gentoo.org>2022-06-21 08:55:05 -0400
committerBrian Evans <grknight@gentoo.org>2022-06-21 08:55:05 -0400
commita3db635a835144c5698141571dc31a65edb452c0 (patch)
treeba12b933caad3648b3dca18697de8eed16cc6556 /sys-power
parentsci-libs/dcmtk: add missing doc building dependency (diff)
downloadgentoo-a3db635a835144c5698141571dc31a65edb452c0.tar.gz
gentoo-a3db635a835144c5698141571dc31a65edb452c0.tar.bz2
gentoo-a3db635a835144c5698141571dc31a65edb452c0.zip
sys-power/acpilight: Fix QA warning and drop old revision
Closes: https://bugs.gentoo.org/852281 Signed-off-by: Brian Evans <grknight@gentoo.org>
Diffstat (limited to 'sys-power')
-rw-r--r--sys-power/acpilight/acpilight-1.2-r3.ebuild57
-rw-r--r--sys-power/acpilight/acpilight-1.2-r4.ebuild5
2 files changed, 5 insertions, 57 deletions
diff --git a/sys-power/acpilight/acpilight-1.2-r3.ebuild b/sys-power/acpilight/acpilight-1.2-r3.ebuild
deleted file mode 100644
index c54de4cb4446..000000000000
--- a/sys-power/acpilight/acpilight-1.2-r3.ebuild
+++ /dev/null
@@ -1,57 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_7 python3_8 python3_9 )
-
-inherit python-single-r1 udev
-
-MY_P="${PN}-v${PV}"
-
-DESCRIPTION="Replacement for xbacklight that uses the ACPI interface to set brightness"
-HOMEPAGE="https://gitlab.com/wavexx/acpilight/"
-SRC_URI="https://gitlab.com/wavexx/acpilight/-/archive/v${PV}/${MY_P}.tar.gz"
-LICENSE="GPL-3+"
-SLOT="0"
-KEYWORDS="amd64 x86"
-IUSE=""
-
-S="${WORKDIR}/${MY_P}"
-
-RDEPEND="virtual/udev
- acct-group/video
- !dev-libs/light
- ${PYTHON_DEPS}
- !x11-apps/xbacklight"
-REQUIRED_USE="${PYTHON_REQUIRED_USE}"
-DOCS=( README.rst NEWS.rst )
-
-PATCHES=( "${FILESDIR}/acpilight-1.2-fix-log10-of-zero.patch" )
-
-# Disable Makefile that installs by default
-src_compile() { :; }
-
-src_install() {
- python_doscript xbacklight
- udev_dorules "${S}"/90-backlight.rules
- doman xbacklight.1
- einstalldocs
- newinitd "${FILESDIR}"/acpilight.initd acpilight
- newconfd "${FILESDIR}"/acpilight.confd acpilight
-}
-
-pkg_postinst() {
- udev_reload
- einfo
- elog "To use the xbacklight binary as a regular user, you must be a part of the video group"
- einfo
- elog "If this utility does not find any backlights to manipulate,"
- elog "verify you have kernel support on the device and display driver enabled."
- einfo
- elog "To take advantage of the OpenRC init script, and automate the process of"
- elog "saving and restoring the brightness level you should add acpilight"
- elog "to the boot runlevel. You can do this as root like so:"
- elog "# rc-update add acpilight boot"
- einfo
-}
diff --git a/sys-power/acpilight/acpilight-1.2-r4.ebuild b/sys-power/acpilight/acpilight-1.2-r4.ebuild
index d8d22ccaa34a..16457c2bda89 100644
--- a/sys-power/acpilight/acpilight-1.2-r4.ebuild
+++ b/sys-power/acpilight/acpilight-1.2-r4.ebuild
@@ -55,3 +55,8 @@ pkg_postinst() {
elog "# rc-update add acpilight boot"
einfo
}
+
+pkg_postrm() {
+ # Triggers a QA warning if missing
+ udev_reload
+}