summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristoph Junghans <junghans@gentoo.org>2017-07-06 09:52:41 -0600
committerChristoph Junghans <junghans@gentoo.org>2017-07-06 09:53:14 -0600
commitefd2ddc8c87dc36f34aed8fa62ea06fe2dc44c5f (patch)
treeb6f70134e1c14a9fb39b22dece73abfd9b19e887 /sys-power
parentnet-libs/webkit-gtk: keyword ~arm64 (diff)
downloadgentoo-efd2ddc8c87dc36f34aed8fa62ea06fe2dc44c5f.tar.gz
gentoo-efd2ddc8c87dc36f34aed8fa62ea06fe2dc44c5f.tar.bz2
gentoo-efd2ddc8c87dc36f34aed8fa62ea06fe2dc44c5f.zip
sys-power/acpi_call: add patch for linux-4.12 (bug #623740)
Package-Manager: Portage-2.3.6, Repoman-2.3.1
Diffstat (limited to 'sys-power')
-rw-r--r--sys-power/acpi_call/acpi_call-1.1.0-r2.ebuild37
-rw-r--r--sys-power/acpi_call/files/acpi_call-1.1.0-linux-4.12.patch10
-rw-r--r--sys-power/acpi_call/metadata.xml4
3 files changed, 47 insertions, 4 deletions
diff --git a/sys-power/acpi_call/acpi_call-1.1.0-r2.ebuild b/sys-power/acpi_call/acpi_call-1.1.0-r2.ebuild
new file mode 100644
index 000000000000..0bbb196395e7
--- /dev/null
+++ b/sys-power/acpi_call/acpi_call-1.1.0-r2.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit linux-info linux-mod
+
+if [ "${PV}" = "9999" ]; then
+ inherit git-2
+ EGIT_REPO_URI="git://github.com/mkottman/acpi_call.git"
+ KEYWORDS=""
+else
+ inherit vcs-snapshot
+ SRC_URI="https://github.com/mkottman/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64"
+fi
+
+DESCRIPTION="A kernel module that enables you to call ACPI methods"
+HOMEPAGE="https://github.com/mkottman/acpi_call"
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE=""
+
+CONFIG_CHECK="ACPI"
+MODULE_NAMES="acpi_call(misc:${S})"
+BUILD_TARGETS="default"
+
+PATCHES=(
+ "${FILESDIR}/${P}-linux-3.17.patch"
+ "${FILESDIR}/${P}-linux-4.12.patch"
+)
+
+src_compile(){
+ BUILD_PARAMS="KDIR=${KV_OUT_DIR} M=${S}"
+ linux-mod_src_compile
+}
diff --git a/sys-power/acpi_call/files/acpi_call-1.1.0-linux-4.12.patch b/sys-power/acpi_call/files/acpi_call-1.1.0-linux-4.12.patch
new file mode 100644
index 000000000000..ef9fde9f2958
--- /dev/null
+++ b/sys-power/acpi_call/files/acpi_call-1.1.0-linux-4.12.patch
@@ -0,0 +1,10 @@
+--- acpi_call-1.1.0.orig/acpi_call.c 2017-07-03 22:44:38.111270788 +0200
++++ acpi_call-1.1.0/acpi_call.c 2017-07-03 22:44:31.010270815 +0200
+@@ -6,6 +6,7 @@
+ #include <linux/proc_fs.h>
+ #include <linux/slab.h>
+ #include <asm/uaccess.h>
++#include <linux/uaccess.h>
+ #include <linux/acpi.h>
+
+ MODULE_LICENSE("GPL");
diff --git a/sys-power/acpi_call/metadata.xml b/sys-power/acpi_call/metadata.xml
index 4b39ce4f91fb..3e6c789e7835 100644
--- a/sys-power/acpi_call/metadata.xml
+++ b/sys-power/acpi_call/metadata.xml
@@ -4,10 +4,6 @@
<maintainer type="person">
<email>maksbotan@gentoo.org</email>
</maintainer>
- <maintainer type="person">
- <email>junghans@gentoo.org</email>
- <name>Christoph Junghans</name>
- </maintainer>
<upstream>
<remote-id type="github">mkottman/acpi_call</remote-id>
</upstream>