summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /sys-process/fuser-bsd
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'sys-process/fuser-bsd')
-rw-r--r--sys-process/fuser-bsd/Manifest2
-rw-r--r--sys-process/fuser-bsd/fuser-bsd-1142334561.ebuild40
-rw-r--r--sys-process/fuser-bsd/metadata.xml5
3 files changed, 47 insertions, 0 deletions
diff --git a/sys-process/fuser-bsd/Manifest b/sys-process/fuser-bsd/Manifest
new file mode 100644
index 000000000000..82af52aba447
--- /dev/null
+++ b/sys-process/fuser-bsd/Manifest
@@ -0,0 +1,2 @@
+DIST fuser-1142334561.tar.bz2 11008 RMD160 55385162a218460993d44a6e5fa001f46d660b25 SHA1 d274a093fea5d3d6c85a3a77bd6eda13010baf1a SHA256 2edf0d189a77a55c84d58545de2cd446401ed42d2f06dd043db3c61f2087e5a2
+DIST fuser-bsd-patches-1.tar.bz2 1694 RMD160 280bdbb35eabe547e5bee4099a5db67fea165420 SHA1 4864a03a0ca264f4cf1df043497a2569cda3de2d SHA256 8386839d7af010eab8f550f1121dca256c46ecb57d931ca18072221f125e992e
diff --git a/sys-process/fuser-bsd/fuser-bsd-1142334561.ebuild b/sys-process/fuser-bsd/fuser-bsd-1142334561.ebuild
new file mode 100644
index 000000000000..736cf718bb0b
--- /dev/null
+++ b/sys-process/fuser-bsd/fuser-bsd-1142334561.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=2
+
+inherit base bsdmk eutils
+
+MY_P="${PN/-bsd/}-${PV}"
+
+PATCHLEVEL=1
+DESCRIPTION="fuser(1) utility for *BSD"
+HOMEPAGE="http://mbsd.msk.ru/stas/fuser.html"
+SRC_URI="http://mbsd.msk.ru/dist/${MY_P}.tar.bz2
+ mirror://gentoo/${PN}-patches-${PATCHLEVEL}.tar.bz2"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~sparc-fbsd ~x86-fbsd"
+IUSE=""
+
+DEPEND="sys-freebsd/freebsd-mk-defs"
+# virtual/libc needed here for has_version to work.
+RDEPEND="virtual/libc
+ !sys-process/psmisc"
+
+S="${WORKDIR}/${PN/-bsd/}"
+
+src_prepare() {
+ if has_version '>=sys-freebsd/freebsd-lib-8' ; then # any better way to check it?
+ EPATCH_SUFFIX="patch" epatch "${WORKDIR}/patches"
+ fi
+}
+
+src_install() {
+ into /
+ dosbin fuser
+
+ doman fuser.1
+}
diff --git a/sys-process/fuser-bsd/metadata.xml b/sys-process/fuser-bsd/metadata.xml
new file mode 100644
index 000000000000..ecedda4aa2cc
--- /dev/null
+++ b/sys-process/fuser-bsd/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>bsd</herd>
+</pkgmetadata>