summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGuillermo Joandet <gjoandet@gmail.com>2023-09-17 19:38:10 -0300
committerMatt Turner <mattst88@gentoo.org>2023-09-17 20:32:44 -0400
commita309a0a9a738a42975663cbf48f7b396601aa281 (patch)
treee39f0fc727a223133d49bd904cdee7a04bbf43fd /sys-process/gnome-usage
parentdev-lang/dafny-bin: Stabilize 3.12.0 amd64, #914366 (diff)
downloadgentoo-a309a0a9a738a42975663cbf48f7b396601aa281.tar.gz
gentoo-a309a0a9a738a42975663cbf48f7b396601aa281.tar.bz2
gentoo-a309a0a9a738a42975663cbf48f7b396601aa281.zip
sys-process/gnome-usage: Version bump to 45.0
Signed-off-by: Guillermo Joandet <gjoandet@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/32891 Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'sys-process/gnome-usage')
-rw-r--r--sys-process/gnome-usage/Manifest1
-rw-r--r--sys-process/gnome-usage/gnome-usage-45.0.ebuild42
2 files changed, 43 insertions, 0 deletions
diff --git a/sys-process/gnome-usage/Manifest b/sys-process/gnome-usage/Manifest
index 69b1982b79c1..78339cb45890 100644
--- a/sys-process/gnome-usage/Manifest
+++ b/sys-process/gnome-usage/Manifest
@@ -1 +1,2 @@
DIST gnome-usage-3.38.1.tar.xz 362368 BLAKE2B 988c5157efdbbb3a680b2360d817fa2fe0587accd647a69cc482da38ec040afefb06d9c3d41a2b8fd2e630802967301837a39ac721ff9717b778b70518abb39d SHA512 8c4621d0340e2fc893ffcc3dc54f2088971c764fbb80302eb171e9f066f62424e532319f9d89c1157945a4721c40eef5253ea4e6ff6f702f5953e61f99d36f07
+DIST gnome-usage-45.0.tar.xz 228160 BLAKE2B 045ba456f0cda1426fc3caa580c8d5ffaf6c0d832a77a61f4709549119fb95afaa833e76a55565b4bec29b575b88f8994550c66580624400b954f2ee0a0fd1a4 SHA512 bdc70394909a4edb7a01554aa7ba40c7c418511e7419a0ed1a32318e1b0fef4ad7d004a03debc8bd6123785a6d38e1ae89a012eece9134716ba3e6a932bcf5b5
diff --git a/sys-process/gnome-usage/gnome-usage-45.0.ebuild b/sys-process/gnome-usage/gnome-usage-45.0.ebuild
new file mode 100644
index 000000000000..a7ae47a009a8
--- /dev/null
+++ b/sys-process/gnome-usage/gnome-usage-45.0.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit gnome.org gnome2-utils meson vala xdg
+
+DESCRIPTION="A nice way to view information about use of system resources"
+HOMEPAGE="https://wiki.gnome.org/Apps/Usage"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ >=dev-libs/libgee-0.8:0.8=
+ >=dev-libs/glib-2.44:2
+ >=gui-libs/gtk-4.11.3:4
+ >=gnome-base/libgtop-2.34.0:2=
+ >=gui-libs/libadwaita-1.4:1
+ >=app-misc/tracker-3.0.3:3[vala(+)]
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ $(vala_depend)
+ >=sys-devel/gettext-0.19.8
+"
+
+src_configure() {
+ vala_setup
+ meson_src_configure
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ gnome2_schemas_update
+}
+
+pkg_postrm() {
+ xdg_pkg_postrm
+ gnome2_schemas_update
+}