summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /sys-process/minit
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'sys-process/minit')
-rw-r--r--sys-process/minit/Manifest2
-rw-r--r--sys-process/minit/files/0.9.1-destdir.patch16
-rw-r--r--sys-process/minit/files/minit-0.10-fixes.diff62
-rw-r--r--sys-process/minit/metadata.xml30
-rw-r--r--sys-process/minit/minit-0.10.ebuild42
-rw-r--r--sys-process/minit/minit-0.9.1.ebuild31
6 files changed, 183 insertions, 0 deletions
diff --git a/sys-process/minit/Manifest b/sys-process/minit/Manifest
new file mode 100644
index 000000000000..04f03ab46d4a
--- /dev/null
+++ b/sys-process/minit/Manifest
@@ -0,0 +1,2 @@
+DIST minit-0.10.tar.bz2 26119 SHA256 e976926342da1828d7e6b10fe489366e7690acdd0c81c0fdfa04c57182ddfacd
+DIST minit-0.9.1.tar.bz2 21894 SHA256 8128b6b96dbe31072005acb63005d77f052a98393c455a725c2ac5054d561d22
diff --git a/sys-process/minit/files/0.9.1-destdir.patch b/sys-process/minit/files/0.9.1-destdir.patch
new file mode 100644
index 000000000000..7a36d3cdfde7
--- /dev/null
+++ b/sys-process/minit/files/0.9.1-destdir.patch
@@ -0,0 +1,16 @@
+--- Makefile.orig 2004-03-04 03:08:18.967017104 -0500
++++ Makefile 2004-03-04 03:10:11.445917712 -0500
+@@ -36,10 +36,12 @@
+ $(DIET) $(CROSS)$(CC) $(CFLAGS) -o $@ $^
+
+ install-files:
++ test -d $(DESTDIR)/sbin || mkdir -p $(DESTDIR)/sbin
+ install minit pidfilehack $(DESTDIR)/sbin
+ install write_proc hard-reboot $(DESTDIR)/sbin
++ test -d $(DESTDIR)/bin || mkdir -p $(DESTDIR)/bin
+ install msvc $(DESTDIR)/bin
+- test -d $(DESTDIR)/etc/minit || mkdir $(DESTDIR)/etc/minit
++ test -d $(DESTDIR)/etc/minit || mkdir -p $(DESTDIR)/etc/minit
+
+ install-fifos:
+ -mkfifo -m 600 $(DESTDIR)/etc/minit/in $(DESTDIR)/etc/minit/out
diff --git a/sys-process/minit/files/minit-0.10-fixes.diff b/sys-process/minit/files/minit-0.10-fixes.diff
new file mode 100644
index 000000000000..5c80091f84f3
--- /dev/null
+++ b/sys-process/minit/files/minit-0.10-fixes.diff
@@ -0,0 +1,62 @@
+diff -ru minit-0.10.orig/Makefile minit-0.10/Makefile
+--- minit-0.10.orig/Makefile 2005-04-08 19:24:04.000000000 +0200
++++ minit-0.10/Makefile 2008-11-27 23:05:57.000000000 +0100
+@@ -7,7 +7,7 @@
+ CROSS=
+ #CROSS=arm-linux-
+ LDFLAGS=-s
+-MANDIR=/usr/man
++MANDIR=/usr/share/man
+
+ path = $(subst :, ,$(PATH))
+ diet_path = $(foreach dir,$(path),$(wildcard $(dir)/diet))
+@@ -44,9 +44,11 @@
+ msvc: msvc.o
+ minit-update: minit-update.o split.o openreadclose.o
+ serdo: serdo.o
+-
+ shutdown: shutdown.o split.o openreadclose.o opendevconsole.o
+- $(DIET) $(CROSS)$(CC) $(LDFLAGS) -o shutdown $^
++pidfilehack: pidfilehack.o
++hard-reboot: hard-reboot.o
++write_proc: write_proc.o
++killall5: killall5.o
+
+ %.o: %.c
+ $(DIET) $(CROSS)$(CC) $(CFLAGS) -c $<
+@@ -61,22 +63,11 @@
+ test: test.c
+ gcc -nostdlib -o $@ $^ -I../dietlibc/include ../dietlibc/start.o ../dietlibc/dietlibc.a
+
+-pidfilehack: pidfilehack.c
+- $(DIET) $(CROSS)$(CC) $(CFLAGS) -o $@ $^
+-
+-hard-reboot: hard-reboot.c
+- $(DIET) $(CROSS)$(CC) $(CFLAGS) -o $@ $^
+-
+-write_proc: write_proc.c
+- $(DIET) $(CROSS)$(CC) $(CFLAGS) -o $@ $^
+-
+-killall5: killall5.c
+- $(DIET) $(CROSS)$(CC) $(CFLAGS) -o $@ $^
+-
+ install-files:
+ install -d $(DESTDIR)/etc/minit $(DESTDIR)/sbin $(DESTDIR)/bin $(DESTDIR)$(MANDIR)/man8
+- install minit pidfilehack $(DESTDIR)/sbin
++ install minit killall5 pidfilehack $(DESTDIR)/sbin
+ install write_proc hard-reboot minit-update $(DESTDIR)/sbin
++ install listpids $(DESTDIR)/sbin/minit-list
+ install msvc serdo $(DESTDIR)/bin
+ install -m 4750 shutdown $(DESTDIR)/sbin
+ test -f $(DESTDIR)/sbin/init || ln $(DESTDIR)/sbin/minit $(DESTDIR)/sbin/init
+diff -ru minit-0.10.orig/serdo.c minit-0.10/serdo.c
+--- minit-0.10.orig/serdo.c 2005-02-26 18:00:22.000000000 +0100
++++ minit-0.10/serdo.c 2008-11-27 23:02:57.000000000 +0100
+@@ -10,6 +10,7 @@
+ #define MAXENV 256
+ char* envp[MAXENV+2];
+ int envc;
++extern char **environ;
+
+ int continueonerror;
+
diff --git a/sys-process/minit/metadata.xml b/sys-process/minit/metadata.xml
new file mode 100644
index 000000000000..e6921be3b87b
--- /dev/null
+++ b/sys-process/minit/metadata.xml
@@ -0,0 +1,30 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>proxy-maintainers</herd>
+ <maintainer>
+ <email>vostorga@gentoo.org</email>
+ <name>Víctor Ostorga</name>
+ </maintainer>
+ <maintainer>
+ <email>aw-gentoo@instandbesetzt.net</email>
+ <name>Andreas Wiese</name>
+ </maintainer>
+<longdescription>
+minit - a small yet feature-complete init
+
+What works so far
+ * It can start services and take dependencies into account.
+ * It can restart services
+ * It can start services in sync mode (i.e. wait until they
+terminate, to get around race conditions for static initializations)
+ * There is a companion utility "msvc" that can be used much in the
+same way as the svc from daemontools. Communication works over two
+fifos, /etc/minit/in and /etc/minit/out. Those have to exist before
+minit is started and they should be owned by root and have mode 600.
+ * There is a companion utility "pidfilehack" that can be used to do
+stuff like run ssh, wait a while, read the PID off /var/run/sshd.pid and
+tell minit this PID so it will know when sshd exits and can restart it.
+ * It can pipe stdout to a dedicated log process.
+</longdescription>
+</pkgmetadata>
diff --git a/sys-process/minit/minit-0.10.ebuild b/sys-process/minit/minit-0.10.ebuild
new file mode 100644
index 000000000000..7deb89d95aaf
--- /dev/null
+++ b/sys-process/minit/minit-0.10.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+inherit eutils
+
+DESCRIPTION="a small yet feature-complete init"
+HOMEPAGE="http://www.fefe.de/minit/"
+SRC_URI="http://dl.fefe.de/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE=""
+
+DEPEND=">=dev-libs/libowfat-0.28-r1
+ dev-libs/dietlibc"
+RDEPEND="${DEPEND}"
+
+src_unpack() {
+ unpack ${A}
+
+ epatch "${FILESDIR}"/minit-0.10-fixes.diff
+}
+
+src_compile() {
+ emake CFLAGS="${CFLAGS} -I/usr/include/libowfat" \
+ LDFLAGS="${LDFLAGS}" DIET="diet" CC="$(tc-getCC)" || die
+}
+
+src_install() {
+ emake install-files DESTDIR="${D}" || die
+ mv "${D}"/sbin/shutdown "${D}"/sbin/minit-shutdown || die
+ mv "${D}"/sbin/killall5 "${D}"/sbin/minit-killall5 || die
+ rm "${D}"/sbin/init || die
+ dodoc CHANGES README TODO
+}
+
+pkg_postinst() {
+ [ -e /etc/minit/in ] || mkfifo "${ROOT}"/etc/minit/in
+ [ -e /etc/minit/out ] || mkfifo "${ROOT}"/etc/minit/out
+}
diff --git a/sys-process/minit/minit-0.9.1.ebuild b/sys-process/minit/minit-0.9.1.ebuild
new file mode 100644
index 000000000000..b895ccee65f3
--- /dev/null
+++ b/sys-process/minit/minit-0.9.1.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+inherit eutils
+
+DESCRIPTION="a small yet feature-complete init"
+HOMEPAGE="http://www.fefe.de/minit/"
+SRC_URI="http://www.fefe.de/minit/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="x86"
+IUSE=""
+
+DEPEND=""
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${PV}-destdir.patch
+}
+
+src_compile() {
+ emake CFLAGS="${CFLAGS}" LDFLAGS="${LDFLAGS}" DIET="" || die
+}
+
+src_install() {
+ make install DESTDIR="${D}" || die
+ dodoc CHANGES README TODO
+}