summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCraig Andrews <candrews@gentoo.org>2023-04-12 08:29:18 -0400
committerCraig Andrews <candrews@gentoo.org>2023-04-12 08:29:41 -0400
commitaaaf019b7f7217506059afd8bfef70c4bb64571c (patch)
treef8b838fa047b6d11acb5e5ca6d4d632f0708638f /www-apache
parentsci-geosciences/gpxsee: remove old version (diff)
downloadgentoo-aaaf019b7f7217506059afd8bfef70c4bb64571c.tar.gz
gentoo-aaaf019b7f7217506059afd8bfef70c4bb64571c.tar.bz2
gentoo-aaaf019b7f7217506059afd8bfef70c4bb64571c.zip
www-apache/mod_h2: add 2.0.14
Signed-off-by: Craig Andrews <candrews@gentoo.org>
Diffstat (limited to 'www-apache')
-rw-r--r--www-apache/mod_h2/Manifest1
-rw-r--r--www-apache/mod_h2/mod_h2-2.0.14.ebuild49
2 files changed, 50 insertions, 0 deletions
diff --git a/www-apache/mod_h2/Manifest b/www-apache/mod_h2/Manifest
index 0ca847e49535..593b3050315c 100644
--- a/www-apache/mod_h2/Manifest
+++ b/www-apache/mod_h2/Manifest
@@ -1 +1,2 @@
DIST mod_h2-2.0.13.tar.gz 791279 BLAKE2B fe1b13e60ea064f3c190ecb30d28fc34e594a35f71d86280e573009aa49638ee12ea2fcafbc25b2fe53a25ada4d98a586ede4c89cd296844a763c80284a3239d SHA512 69ffc4910c89be393406161fa75dce27e17e7bd7d8e1658b7eaae68eb877324f2e30d47a268d41995bb4837c6b4aea4bb8e840191e3291b1fafee3d4f1d55baa
+DIST mod_h2-2.0.14.tar.gz 791822 BLAKE2B 1bfa052181a8955db85515320e54039ae4ae0ac6d4a59b6352bce2585eed1d7b7db7fdcffc9a3274f7f8df380ffaea4b6bb02f28b7bf93d570d753de38acc4b4 SHA512 764e52c62016315c61a5c6369ad448ca0198e8de7edde9a81c94f75194813e4c4c484ca74ee51e89445b11a74ddef939bae2b6472878e72df36279111dbbc20d
diff --git a/www-apache/mod_h2/mod_h2-2.0.14.ebuild b/www-apache/mod_h2/mod_h2-2.0.14.ebuild
new file mode 100644
index 000000000000..5ba43634b8e0
--- /dev/null
+++ b/www-apache/mod_h2/mod_h2-2.0.14.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit apache-module autotools
+
+MY_P="${PN/h2/http2}-${PV}"
+
+if [[ ${PV} == 9999 ]] ; then
+ EGIT_REPO_URI="https://github.com/icing/mod_h2.git"
+ inherit git-r3
+else
+ MY_PV="${PV/_rc/-rc}"
+ MY_P="${PN}-${MY_PV}"
+ S="${WORKDIR}/${MY_P}"
+ SRC_URI="https://github.com/icing/mod_h2/archive/v${MY_PV}.tar.gz -> ${MY_P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+DESCRIPTION="HTTP/2 module for Apache"
+HOMEPAGE="https://github.com/icing/mod_h2"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+IUSE="ssl"
+
+RDEPEND=">=net-libs/nghttp2-1.0
+ >=www-servers/apache-2.4.48[-apache2_modules_http2,ssl?]"
+DEPEND="${RDEPEND}"
+
+need_apache2_4
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_compile() {
+ default
+}
+
+src_install() {
+ default
+
+ APACHE2_MOD_DEFINE="HTTP2"
+ insinto "${APACHE_MODULES_CONFDIR}"
+ newins "${FILESDIR}/mod_http2.conf" "41_mod_http2.conf"
+}