summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /www-apps/dragonflycms
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'www-apps/dragonflycms')
-rw-r--r--www-apps/dragonflycms/Manifest1
-rw-r--r--www-apps/dragonflycms/dragonflycms-9.3.3.1.ebuild53
-rw-r--r--www-apps/dragonflycms/files/postinstall-en.txt24
-rw-r--r--www-apps/dragonflycms/metadata.xml13
4 files changed, 91 insertions, 0 deletions
diff --git a/www-apps/dragonflycms/Manifest b/www-apps/dragonflycms/Manifest
new file mode 100644
index 000000000000..fa96e486cf01
--- /dev/null
+++ b/www-apps/dragonflycms/Manifest
@@ -0,0 +1 @@
+DIST Dragonfly9.3.3.1.zip 2470386 RMD160 4b0523711016004fb3d6bbb21a5ba3e102c19a6c SHA1 052faab5e0d69654f5261cf7636bc054bd7a4dd1 SHA256 3d88a5c0f983a7ce1f11045a4f8f89cb883b8914f5ec6fe13a1c87dd3b451393
diff --git a/www-apps/dragonflycms/dragonflycms-9.3.3.1.ebuild b/www-apps/dragonflycms/dragonflycms-9.3.3.1.ebuild
new file mode 100644
index 000000000000..97ee2a78d134
--- /dev/null
+++ b/www-apps/dragonflycms/dragonflycms-9.3.3.1.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+inherit webapp
+
+MY_P=Dragonfly${PV}
+
+DESCRIPTION="A feature-rich open source content management system based off of PHP-Nuke 6.5"
+HOMEPAGE="http://dragonflycms.org"
+SRC_URI="mirror://gentoo/${MY_P}.zip"
+
+RESTRICT="fetch"
+
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~x86"
+IUSE=""
+
+DEPEND="app-arch/unzip"
+RDEPEND="virtual/httpd-php"
+
+need_httpd_cgi
+
+S="${WORKDIR}"
+
+pkg_nofetch() {
+ elog "Please download ${MY_P}.tar.bz2 from:"
+ elog "http://dragonflycms.org/Downloads/get=130.html"
+ elog "and move it to ${DISTDIR}"
+}
+
+src_install() {
+ webapp_src_preinst
+
+ dodoc documentation/{BACKUP,IMPORTANT_NOTES,INSTALL,README,UPGRADE}.txt
+
+ insinto "${MY_HTDOCSDIR}"
+ doins -r public_html/*
+ doins public_html/.htaccess
+
+ webapp_configfile "${MY_HTDOCSDIR}"/install/config.php
+
+ for x in cpg_error.log includes cache modules/coppermine/albums \
+ modules/coppermine/albums/userpics uploads/avatars \
+ uploads/forums; do
+ webapp_serverowned "${MY_HTDOCSDIR}"/${x}
+ done
+
+ webapp_postinst_txt en "${FILESDIR}"/postinstall-en.txt
+ webapp_src_install
+}
diff --git a/www-apps/dragonflycms/files/postinstall-en.txt b/www-apps/dragonflycms/files/postinstall-en.txt
new file mode 100644
index 000000000000..34b47080868a
--- /dev/null
+++ b/www-apps/dragonflycms/files/postinstall-en.txt
@@ -0,0 +1,24 @@
+You will need to provide a database for your ${PN} installation.
+
+This assumes you have some knowledge of MySQL, and already have it
+installed and configured. If not, please refer to the Gentoo MySQL
+guide at the following URL:
+
+http://www.gentoo.org/doc/en/mysql-howto.xml
+
+Once you have a database ready all you need to do is to go to this
+location
+
+http://${VHOST_HOSTNAME}/${VHOST_APPDIR}/install.php
+
+and provide the credentials required for the database access.
+
+Note the credentials of the administration user you will generate
+during the installation procedure.
+
+For your own security you will need to remove the installation tools
+by running
+
+rm -rf ${MY_INSTALLDIR}/install*
+
+Enjoy ${PN}!
diff --git a/www-apps/dragonflycms/metadata.xml b/www-apps/dragonflycms/metadata.xml
new file mode 100644
index 000000000000..fea7d5fbc77d
--- /dev/null
+++ b/www-apps/dragonflycms/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>web-apps</herd>
+ <longdescription lang="en">
+ CPG Dragonfly CMS is a feature-rich open source content management system
+ based off of PHP-Nuke 6.5
+ </longdescription>
+ <longdescription lang="nl">
+ CPG Dragonfly CMS is een open source content management system met enorm
+ veel mogelijkheden. Dragonfly is gebaseerd op PHP-Nuke 6.5
+ </longdescription>
+</pkgmetadata>