summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFelix Neumärker <xdch47@posteo.de>2019-08-02 12:28:30 +0200
committerJoonas Niilola <juippis@gentoo.org>2019-11-07 07:42:29 +0200
commit0632e600cea736adec48417e0885d3860dcd1270 (patch)
treebc94e6a8db1ae8182f2005457c796376746f1c25 /www-apps/gitea/files
parentmail-client/alpine: make PAM optional (diff)
downloadgentoo-0632e600cea736adec48417e0885d3860dcd1270.tar.gz
gentoo-0632e600cea736adec48417e0885d3860dcd1270.tar.bz2
gentoo-0632e600cea736adec48417e0885d3860dcd1270.zip
www-apps/gitea: bump to 1.9.5
Closes: https://bugs.gentoo.org/687148 Closes: https://bugs.gentoo.org/690838 Closes: https://bugs.gentoo.org/693536 Package-Manager: Portage-2.3.69, Repoman-2.3.16 Signed-off-by: Felix Neumärker <xdch47@posteo.de> Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'www-apps/gitea/files')
-rw-r--r--www-apps/gitea/files/gitea-logflags.patch13
-rw-r--r--www-apps/gitea/files/gitea-mod-vendor.patch46
2 files changed, 59 insertions, 0 deletions
diff --git a/www-apps/gitea/files/gitea-logflags.patch b/www-apps/gitea/files/gitea-logflags.patch
new file mode 100644
index 000000000000..331bd3d046b1
--- /dev/null
+++ b/www-apps/gitea/files/gitea-logflags.patch
@@ -0,0 +1,13 @@
+diff --git a/modules/log/flags.go b/modules/log/flags.go
+index 992fc62..5578a1b 100644
+--- a/modules/log/flags.go
++++ b/modules/log/flags.go
+@@ -31,7 +31,7 @@ const (
+ Lmedfile = Lshortfile | Llongfile
+
+ // LstdFlags is the initial value for the standard logger
+- LstdFlags = Ldate | Ltime | Lmedfile | Lshortfuncname | Llevelinitial
++ LstdFlags = Ldate | Ltime | Llevelinitial
+ )
+
+ var flagFromString = map[string]int{
diff --git a/www-apps/gitea/files/gitea-mod-vendor.patch b/www-apps/gitea/files/gitea-mod-vendor.patch
new file mode 100644
index 000000000000..c501e20adb94
--- /dev/null
+++ b/www-apps/gitea/files/gitea-mod-vendor.patch
@@ -0,0 +1,46 @@
+diff --git a/Makefile b/Makefile
+index 796a0e3..2c6a6ef 100644
+--- a/Makefile
++++ b/Makefile
+@@ -97,7 +97,7 @@ vet:
+
+ .PHONY: generate
+ generate:
+- GO111MODULE=on $(GO) generate $(PACKAGES)
++ GO111MODULE=on $(GO) generate -mod=vendor $(PACKAGES)
+
+ .PHONY: generate-swagger
+ generate-swagger:
+diff --git a/modules/options/options.go b/modules/options/options.go
+index 723dd54..62e8c04 100644
+--- a/modules/options/options.go
++++ b/modules/options/options.go
+@@ -5,7 +5,6 @@
+ package options
+
+ //go:generate go run -mod=vendor main.go
+-//go:generate go fmt bindata.go
+
+ type directorySet map[string][]string
+
+diff --git a/modules/public/public.go b/modules/public/public.go
+index 8362b42..df70275 100644
+--- a/modules/public/public.go
++++ b/modules/public/public.go
+@@ -18,7 +18,6 @@ import (
+ )
+
+ //go:generate go run -mod=vendor main.go
+-//go:generate go fmt bindata.go
+
+ // Options represents the available options to configure the macaron handler.
+ type Options struct {
+diff --git a/modules/templates/templates.go b/modules/templates/templates.go
+index e7fe3b2..af6bf01 100644
+--- a/modules/templates/templates.go
++++ b/modules/templates/templates.go
+@@ -5,4 +5,3 @@
+ package templates
+
+ //go:generate go run -mod=vendor main.go
+-//go:generate go fmt bindata.go