summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLouis Sautier <sautier.louis@gmail.com>2018-05-26 22:50:51 +0200
committerAaron Bauman <bman@gentoo.org>2018-05-26 17:46:35 -0400
commit10d8c1f67b3bd910fd7f9d1beb52da9d8322e76a (patch)
tree80b1bbc8699d379df931940b6ed6eca0402d7a31 /www-apps/icingaweb2-module-graphite/icingaweb2-module-graphite-1.0.1-r1.ebuild
parentmedia-libs/libdvbpsi: Drop 1.3.0-r1 (diff)
downloadgentoo-10d8c1f67b3bd910fd7f9d1beb52da9d8322e76a.tar.gz
gentoo-10d8c1f67b3bd910fd7f9d1beb52da9d8322e76a.tar.bz2
gentoo-10d8c1f67b3bd910fd7f9d1beb52da9d8322e76a.zip
www-apps/icingaweb2-module-graphite: fix SRC_URI for 1.0.1, EAPI=7
Also update HOMEPAGE and fix DESCRIPTION, remove deprecated patch from live ebuild and add upstream info to metadata.xml. Package-Manager: Portage-2.3.38, Repoman-2.3.9 Closes: https://github.com/gentoo/gentoo/pull/8601
Diffstat (limited to 'www-apps/icingaweb2-module-graphite/icingaweb2-module-graphite-1.0.1-r1.ebuild')
-rw-r--r--www-apps/icingaweb2-module-graphite/icingaweb2-module-graphite-1.0.1-r1.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/www-apps/icingaweb2-module-graphite/icingaweb2-module-graphite-1.0.1-r1.ebuild b/www-apps/icingaweb2-module-graphite/icingaweb2-module-graphite-1.0.1-r1.ebuild
new file mode 100644
index 000000000000..312bc419e294
--- /dev/null
+++ b/www-apps/icingaweb2-module-graphite/icingaweb2-module-graphite-1.0.1-r1.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="Icinga Web 2 plugin for Graphite"
+HOMEPAGE="https://www.icinga.com/docs/graphite/latest/"
+if [[ "${PV}" == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/Icinga/icingaweb2-module-graphite.git"
+else
+ KEYWORDS="~amd64 ~x86"
+ SRC_URI="https://github.com/Icinga/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+fi
+
+LICENSE="GPL-2"
+SLOT="0"
+
+DEPEND=">=net-analyzer/icinga2-2.4.0
+ >=www-apps/icingaweb2-2.5.0"
+RDEPEND="${DEPEND}"
+
+src_install() {
+ insinto "/usr/share/icingaweb2/modules/graphite/"
+ doins -r "${S}"/*
+}