summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBernard Cafarelli <voyageur@gentoo.org>2024-01-31 21:39:40 +0100
committerBernard Cafarelli <voyageur@gentoo.org>2024-01-31 21:40:48 +0100
commit514d19c0666aadd791978485820a2c5bba229791 (patch)
tree3bcac91ebe2778aba850298baeff3d90acfe2be8 /www-apps/piwigo
parentdev-build/cmake: add 3.28.2 (diff)
downloadgentoo-514d19c0666aadd791978485820a2c5bba229791.tar.gz
gentoo-514d19c0666aadd791978485820a2c5bba229791.tar.bz2
gentoo-514d19c0666aadd791978485820a2c5bba229791.zip
www-apps/piwigo: add 14.2.0
Signed-off-by: Bernard Cafarelli <voyageur@gentoo.org>
Diffstat (limited to 'www-apps/piwigo')
-rw-r--r--www-apps/piwigo/Manifest1
-rw-r--r--www-apps/piwigo/piwigo-14.2.0.ebuild44
2 files changed, 45 insertions, 0 deletions
diff --git a/www-apps/piwigo/Manifest b/www-apps/piwigo/Manifest
index 7ecc12988789..4472cfaecb1e 100644
--- a/www-apps/piwigo/Manifest
+++ b/www-apps/piwigo/Manifest
@@ -1,2 +1,3 @@
DIST piwigo-14.0.0.zip 18442805 BLAKE2B 22c714f68c6f68d7fe9a1bd8303a7ef63ac30dd6862d3dfd32f1bd3754a1805b8cfd321e3b734fe6eba3485374452befa7f2e0bfe0795a34e6ea25d1d1bada5a SHA512 cb679faeec7b188ece561ea5f1bf3fbf4acd513205f0492c5932921aae2676489089241f57fad3b1623e019772e39821121765bc0648d95da8f06d5a644e5a96
DIST piwigo-14.1.0.zip 18448411 BLAKE2B e4b7c172adae16a1b90c104c4018ec0324773382a348cc9f57d1b7065d011c9fa90b2062322f31c1b2a0a17230d08b07041abebadd9f08054f198f5ab65329c6 SHA512 3dbe34a70840139264088bc2bbaba12eebe7d0ae1b340586b6299f04a584b34a1d827e1a7f7afe4f929373be496f72af5cd35b9a9f12d4a3907249b8718f6d47
+DIST piwigo-14.2.0.zip 18489636 BLAKE2B 08435f8582f7c7c72227567671d5bfed437bad11f5cf643b744c59f7e469df9d0ec5d863907c42533df936ced1ccded13897aa9f79e95cfe93aedcebe5c39de3 SHA512 667b32ac892bca97a993ad7aa87e71b5003bf79774e12f6bc7e252036bef68cd94bbee941089c90c1fec82101eb74d4559a1d8e0ac1f6ddefafa5f3e7aad8a9e
diff --git a/www-apps/piwigo/piwigo-14.2.0.ebuild b/www-apps/piwigo/piwigo-14.2.0.ebuild
new file mode 100644
index 000000000000..6b766f9c42fd
--- /dev/null
+++ b/www-apps/piwigo/piwigo-14.2.0.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+inherit webapp
+
+DESCRIPTION="a photo gallery software for the web"
+HOMEPAGE="http://piwigo.org/"
+SRC_URI="http://piwigo.org/download/dlcounter.php?code=${PV} -> ${P}.zip"
+
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~x86"
+IUSE="+exif +gd imagemagick"
+
+DEPEND=""
+RDEPEND="
+ imagemagick? ( virtual/imagemagick-tools )
+ dev-lang/php[ctype,exif?,gd?,filter,iconv,json(+),mysqli]
+ >=virtual/mysql-5.0
+ virtual/httpd-php"
+BDEPEND="app-arch/unzip"
+
+REQUIRED_USE="|| ( gd imagemagick )"
+
+S=${WORKDIR}/${PN}
+
+src_install() {
+ webapp_src_preinst
+
+ insinto "${MY_HTDOCSDIR}"
+ doins -r .
+
+ # Local configuration, and parts that can be updated
+ webapp_serverowned "${MY_HTDOCSDIR}"/_data
+ webapp_serverowned -R "${MY_HTDOCSDIR}"/galleries
+ webapp_serverowned -R "${MY_HTDOCSDIR}"/language
+ webapp_serverowned -R "${MY_HTDOCSDIR}"/local
+ webapp_serverowned -R "${MY_HTDOCSDIR}"/plugins
+ webapp_serverowned -R "${MY_HTDOCSDIR}"/template-extension
+ webapp_serverowned -R "${MY_HTDOCSDIR}"/themes
+ webapp_serverowned "${MY_HTDOCSDIR}"/upload
+
+ webapp_src_install
+}