summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPiotr Kubaj <pkubaj@anongoth.pl>2024-08-08 17:48:35 +0200
committerJoonas Niilola <juippis@gentoo.org>2024-08-09 19:45:14 +0300
commit3ff20f417925eab7b63f722cee10a7758d64b2f1 (patch)
tree9cd3335ec4846535cdbb654de2115590c3bdb128 /www-client/firefox
parentsci-libs/caffe2: update SRC_URI (diff)
downloadgentoo-3ff20f417925eab7b63f722cee10a7758d64b2f1.tar.gz
gentoo-3ff20f417925eab7b63f722cee10a7758d64b2f1.tar.bz2
gentoo-3ff20f417925eab7b63f722cee10a7758d64b2f1.zip
www-client/firefox: add support for ppc64le on musl
It still does not add support for ppc64 (big-endian) because the USE flag "ppc64" is shared between ppc64 and ppc64le. Fixing it on ppc64 would probably require adding a big-endian USE and there are some big-endian specific patches necessary. Since I don't have yet a big-endian Gentoo, this patch does not fix ppc64 on musl, but it currently does not work anyway. Signed-off-by: Piotr Kubaj <pkubaj@anongoth.pl> Closes: https://github.com/gentoo/gentoo/pull/38018 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'www-client/firefox')
-rw-r--r--www-client/firefox/firefox-128.1.0.ebuild2
-rw-r--r--www-client/firefox/firefox-129.0.ebuild2
2 files changed, 4 insertions, 0 deletions
diff --git a/www-client/firefox/firefox-128.1.0.ebuild b/www-client/firefox/firefox-128.1.0.ebuild
index 8ca5d7c119b7..1d88b262baa5 100644
--- a/www-client/firefox/firefox-128.1.0.ebuild
+++ b/www-client/firefox/firefox-128.1.0.ebuild
@@ -637,6 +637,8 @@ src_prepare() {
export RUST_TARGET="i686-unknown-linux-musl"
elif use arm64 ; then
export RUST_TARGET="aarch64-unknown-linux-musl"
+ elif use ppc64 ; then
+ export RUST_TARGET="powerpc64le-unknown-linux-musl"
else
die "Unknown musl chost, please post your rustc -vV along with emerge --info on Gentoo's bug #915651"
fi
diff --git a/www-client/firefox/firefox-129.0.ebuild b/www-client/firefox/firefox-129.0.ebuild
index 8e9069b7db01..57a2736fb5c1 100644
--- a/www-client/firefox/firefox-129.0.ebuild
+++ b/www-client/firefox/firefox-129.0.ebuild
@@ -630,6 +630,8 @@ src_prepare() {
export RUST_TARGET="i686-unknown-linux-musl"
elif use arm64 ; then
export RUST_TARGET="aarch64-unknown-linux-musl"
+ elif use ppc64 ; then
+ export RUST_TARGET="powerpc64le-unknown-linux-musl"
else
die "Unknown musl chost, please post your rustc -vV along with emerge --info on Gentoo's bug #915651"
fi