summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastian Pipping <sping@gentoo.org>2024-01-27 15:40:34 +0100
committerSebastian Pipping <sping@gentoo.org>2024-01-27 15:44:41 +0100
commit099c35a85c20cd77e9ca97a3a77b60f8f2e402d7 (patch)
treecf8e9089ef1a1a995bc72f292eb7cbd772c69a64 /www-client/httrack
parentwww-client/httrack: 3.49.5 + ReferenceInMetadataVar (diff)
downloadgentoo-099c35a85c20cd77e9ca97a3a77b60f8f2e402d7.tar.gz
gentoo-099c35a85c20cd77e9ca97a3a77b60f8f2e402d7.tar.bz2
gentoo-099c35a85c20cd77e9ca97a3a77b60f8f2e402d7.zip
www-client/httrack: Drop myself as maintainer + drop old
Signed-off-by: Sebastian Pipping <sping@gentoo.org>
Diffstat (limited to 'www-client/httrack')
-rw-r--r--www-client/httrack/httrack-3.49.2-r3.ebuild70
-rw-r--r--www-client/httrack/httrack-3.49.4.ebuild77
-rw-r--r--www-client/httrack/metadata.xml4
3 files changed, 1 insertions, 150 deletions
diff --git a/www-client/httrack/httrack-3.49.2-r3.ebuild b/www-client/httrack/httrack-3.49.2-r3.ebuild
deleted file mode 100644
index b306e0d666ba..000000000000
--- a/www-client/httrack/httrack-3.49.2-r3.ebuild
+++ /dev/null
@@ -1,70 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI="8"
-
-inherit autotools xdg-utils
-
-DESCRIPTION="HTTrack Website Copier, Open Source Offline Browser"
-HOMEPAGE="https://www.httrack.com/"
-SRC_URI="https://mirror.httrack.com/historical/${P}.tar.gz"
-
-LICENSE="GPL-3"
-SLOT="0"
-KEYWORDS="~amd64 ~ppc ~x86 ~amd64-linux ~x86-linux"
-IUSE="static-libs"
-
-RDEPEND=">=sys-libs/zlib-1.2.5.1-r1
- >=dev-libs/openssl-1.1.0:=
- "
-DEPEND="${RDEPEND}"
-
-DOCS=( AUTHORS README greetings.txt history.txt )
-
-PATCHES=(
- "${FILESDIR}"/${PN}-3.48.13-minizip.patch
-)
-
-src_prepare() {
- default
-
- # We need to patch use of /usr/lib because it is a problem with
- # linker lld with profile 17.1 on amd64 (see https://bugs.gentoo.org/732272).
- # The grep sandwich acts as a regression test so that a future
- # version bump cannot break patching without noticing.
- if [[ "$(get_libdir)" != lib ]]; then
- grep -wq '{ZLIB_HOME}/lib' m4/check_zlib.m4 || die
- sed "s,{ZLIB_HOME}/lib,{ZLIB_HOME}/$(get_libdir)," -i m4/check_zlib.m4 || die
- grep -w '{ZLIB_HOME}/lib' m4/check_zlib.m4 && die
- fi
-
- eautoreconf
-}
-
-src_configure() {
- econf $(use_enable static-libs static)
-}
-
-src_install() {
- default
-
- # Make webhttrack work despite FEATURES=nodoc cutting
- # all of /usr/share/doc/ away (bug #493376)
- if has nodoc ${FEATURES} ; then
- dodir /usr/share/${PF}/
- mv "${D}"/usr/share/{doc/,}${PF}/html || die
-
- rm "${D}"/usr/share/${PN}/html || die
- dosym ../../${PF}/html /usr/share/${PN}/html
- fi
-
- find "${D}" -name '*.la' -type f -delete || die
-}
-
-pkg_postinst() {
- xdg_icon_cache_update
-}
-
-pkg_postrm() {
- xdg_icon_cache_update
-}
diff --git a/www-client/httrack/httrack-3.49.4.ebuild b/www-client/httrack/httrack-3.49.4.ebuild
deleted file mode 100644
index 2f90be8e6eb5..000000000000
--- a/www-client/httrack/httrack-3.49.4.ebuild
+++ /dev/null
@@ -1,77 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI="8"
-
-inherit autotools xdg-utils
-
-# TODO unbundle coucal, upstream ticket https://github.com/xroche/httrack/issues/247
-COUCAL_COMMIT=73ada075553b7607d083037a87cb9c73b3683bfc
-DESCRIPTION="HTTrack Website Copier, Open Source Offline Browser"
-HOMEPAGE="https://www.httrack.com/"
-SRC_URI="https://github.com/xroche/httrack/archive/refs/tags/${PV}.tar.gz -> ${P}.gh.tar.gz
- https://github.com/xroche/coucal/archive/${COUCAL_COMMIT}.tar.gz -> coucal-${COUCAL_COMMIT}.gh.tar.gz"
-
-COUCAL_LICENSE="BSD public-domain"
-LICENSE="GPL-3 ${COUCAL_LICENSE}"
-SLOT="0"
-KEYWORDS="~amd64 ~ppc ~x86 ~amd64-linux ~x86-linux"
-IUSE="static-libs"
-
-RDEPEND=">=sys-libs/zlib-1.2.5.1-r1
- >=dev-libs/openssl-1.1.0:=
- "
-DEPEND="${RDEPEND}"
-
-DOCS=( AUTHORS README greetings.txt history.txt )
-
-PATCHES=(
- "${FILESDIR}"/${PN}-3.48.13-minizip.patch
-)
-
-src_prepare() {
- rmdir "${S}"/src/coucal || die
- mv "${WORKDIR}"/coucal-${COUCAL_COMMIT} "${S}"/src/coucal || die
-
- default
-
- # We need to patch use of /usr/lib because it is a problem with
- # linker lld with profile 17.1 on amd64 (see https://bugs.gentoo.org/732272).
- # The grep sandwich acts as a regression test so that a future
- # version bump cannot break patching without noticing.
- if [[ "$(get_libdir)" != lib ]]; then
- grep -wq '{ZLIB_HOME}/lib' m4/check_zlib.m4 || die
- sed "s,{ZLIB_HOME}/lib,{ZLIB_HOME}/$(get_libdir)," -i m4/check_zlib.m4 || die
- grep -w '{ZLIB_HOME}/lib' m4/check_zlib.m4 && die
- fi
-
- eautoreconf
-}
-
-src_configure() {
- econf $(use_enable static-libs static)
-}
-
-src_install() {
- default
-
- # Make webhttrack work despite FEATURES=nodoc cutting
- # all of /usr/share/doc/ away (bug #493376)
- if has nodoc ${FEATURES} ; then
- dodir /usr/share/${PF}/
- mv "${D}"/usr/share/{doc/,}${PF}/html || die
-
- rm "${D}"/usr/share/${PN}/html || die
- dosym ../../${PF}/html /usr/share/${PN}/html
- fi
-
- find "${D}" -name '*.la' -type f -delete || die
-}
-
-pkg_postinst() {
- xdg_icon_cache_update
-}
-
-pkg_postrm() {
- xdg_icon_cache_update
-}
diff --git a/www-client/httrack/metadata.xml b/www-client/httrack/metadata.xml
index 13c8a9403797..9fd4a9d0ac53 100644
--- a/www-client/httrack/metadata.xml
+++ b/www-client/httrack/metadata.xml
@@ -1,9 +1,7 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
-<maintainer type="person">
- <email>sping@gentoo.org</email>
-</maintainer>
+<!-- maintainer-needed -->
<upstream>
<remote-id type="github">xroche/httrack</remote-id>
</upstream>