summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNickolas Raymond Kaczynski <nrk@disroot.org>2022-04-29 14:27:07 +0600
committerSam James <sam@gentoo.org>2022-05-14 00:41:45 +0000
commit66b191f26b1646bb6d8b8ae619f6bd5022ef5cfc (patch)
tree1c44f846c27505c0e144f27b48c7aad9010383e1 /www-client/w3m
parentmedia-libs/lcms: keyword 2.13.1 for ~loong (diff)
downloadgentoo-66b191f26b1646bb6d8b8ae619f6bd5022ef5cfc.tar.gz
gentoo-66b191f26b1646bb6d8b8ae619f6bd5022ef5cfc.tar.bz2
gentoo-66b191f26b1646bb6d8b8ae619f6bd5022ef5cfc.zip
www-client/w3m: bump to latest release (20220429)
Also bump EAPI to 8 and add myself as proxy maintainer. Signed-off-by: Nickolas Raymond Kaczynski <nrk@disroot.org> Closes: https://github.com/gentoo/gentoo/pull/25249 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'www-client/w3m')
-rw-r--r--www-client/w3m/Manifest1
-rw-r--r--www-client/w3m/metadata.xml8
-rw-r--r--www-client/w3m/w3m-0.5.3_p20220429.ebuild133
3 files changed, 141 insertions, 1 deletions
diff --git a/www-client/w3m/Manifest b/www-client/w3m/Manifest
index 349c85c41371..dd9dd06a0a31 100644
--- a/www-client/w3m/Manifest
+++ b/www-client/w3m/Manifest
@@ -1,2 +1,3 @@
DIST w3m-0.5.3+git20210102.tar.gz 2189272 BLAKE2B f82c13c26b1c83cda90655abdcf30422e257a5c2e48c32d5636a70f895078d11a95fc6ce623fa94624bb2a1125b71e7654d872dfb91fd86c4290278de3cf88f8 SHA512 357eeecf0f63bfd5174c9670533882323879657bdecefd0758d853ca645e368331bfdf91e99c0917f19829e184ce892ecdc99bd865851707d93baccfb4b97632
+DIST w3m-0.5.3+git20220429.tar.gz 2312378 BLAKE2B 1cf73c447c2e43491d206ece63bea5f678bd12019be6722e2965bebf9902a56dba5d010b6191553f1acff990a613c2b6d5099cb98b6aa1a84e54e2947570c094 SHA512 0f29d6a1f311c3f417ca041fe3788c94946d238b618eca923cd62a6e5e598aefd898fb8a54999876179011bf37d492a989872e38375ea96ac59914b244f1517e
DIST w3m-0.5.3_p20220216.tar.gz 2306347 BLAKE2B d312aee587d76d077ddae27c97a20957083785a269080ec2a4896f2bd9b4c90cc356a3b6d6c9a435458cf4c16b749d0b1e1c403f7bc5028a0b463c352f75ad2a SHA512 2b661eca0f1e2ff0d7646ce062cc736a30950b41e3e056061d0d65feb869fbea8f6668255c403b460d6b2786a4fd24be6e98d9eb99b8948b3113f7d4ec866a12
diff --git a/www-client/w3m/metadata.xml b/www-client/w3m/metadata.xml
index db06b4f7b6c8..0bfbe2396368 100644
--- a/www-client/w3m/metadata.xml
+++ b/www-client/w3m/metadata.xml
@@ -1,7 +1,13 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
-<!-- maintainer-needed -->
+ <maintainer type="person" proxied="yes">
+ <email>nrk@disroot.org</email>
+ </maintainer>
+ <maintainer type="project" proxied="proxy">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
<use>
<flag name="gdk-pixbuf">Enable support for <pkg>x11-libs/gdk-pixbuf</pkg></flag>
<flag name="lynxkeymap">If you prefer Lynx-like key binding</flag>
diff --git a/www-client/w3m/w3m-0.5.3_p20220429.ebuild b/www-client/w3m/w3m-0.5.3_p20220429.ebuild
new file mode 100644
index 000000000000..c1c3e63734a0
--- /dev/null
+++ b/www-client/w3m/w3m-0.5.3_p20220429.ebuild
@@ -0,0 +1,133 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools prefix toolchain-funcs
+
+MY_P="${P/_p/+git}"
+MY_PV="${PV/_p/+git}"
+
+DESCRIPTION="Text based WWW browser, supports tables and frames"
+HOMEPAGE="https://github.com/tats/w3m"
+SRC_URI="https://github.com/tats/w3m/archive/v${MY_PV}.tar.gz -> ${MY_P}.tar.gz"
+S="${WORKDIR}/${P/_p/-git}"
+
+LICENSE="w3m"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~loong ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="fbcon gdk-pixbuf gpm imlib l10n_ja lynxkeymap nls nntp ssl unicode X xface"
+
+REQUIRED_USE="
+ fbcon? ( ?? ( gdk-pixbuf imlib ) )
+ X? ( ?? ( gdk-pixbuf imlib ) )
+"
+
+RDEPEND="
+ dev-libs/boehm-gc:=
+ sys-libs/ncurses:0=
+ sys-libs/zlib
+ gdk-pixbuf? (
+ x11-libs/gdk-pixbuf
+ X? ( x11-libs/gdk-pixbuf-xlib )
+ )
+ !gdk-pixbuf? (
+ imlib? ( media-libs/imlib2[X?] )
+ )
+ gpm? ( sys-libs/gpm )
+ ssl? ( dev-libs/openssl:0= )
+ X? (
+ x11-base/xorg-proto
+ x11-libs/libXdmcp
+ x11-libs/libXext
+ )
+ xface? ( media-libs/compface )
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ virtual/pkgconfig
+"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-0.5.3_p20210102-restore-gettext-macro.patch
+ "${FILESDIR}"/${PN}-0.5.3_p20210102-fix-configure-gettext.patch
+)
+
+src_prepare() {
+ default
+
+ sed -i "/^AR=/s:ar:$(tc-getAR):" {.,${PN}img,libwc}/Makefile.in || die
+ hprefixify acinclude.m4
+
+ AT_NOEAUTOHEADER="yes" AT_M4DIR="m4" eautoreconf
+}
+
+src_configure() {
+ local myconf=()
+ local image imagelib
+
+ if use gdk-pixbuf ; then
+ imagelib="gtk3"
+ elif use imlib ; then
+ imagelib="imlib2"
+ fi
+ if [[ -n "${imagelib}" ]] ; then
+ use X && image="${image}${image:+,}x11"
+ use fbcon && image="${image}${image:+,}fb"
+ fi
+ # emacs-w3m doesn't like "--enable-m17n --disable-unicode,"
+ # so we better enable or disable both. Default to enable
+ # m17n and unicode, see bug #47046.
+ if use l10n_ja ; then
+ myconf+=( --enable-japanese=$(usex unicode U E) )
+ else
+ myconf+=( --with-charset=$(usex unicode UTF-8 US-ASCII) )
+ fi
+ # lynxkeymap IUSE flag. bug #49397
+ myconf+=( --enable-keymap=$(usex lynxkeymap lynx ${PN}) )
+
+ econf \
+ $(use_enable gpm mouse) \
+ $(use_enable nls) \
+ $(use_enable nntp) \
+ $(use_enable ssl digest-auth) \
+ $(use_enable xface) \
+ $(use_with ssl) \
+ --enable-image=${image:-no} \
+ --enable-m17n \
+ --enable-unicode \
+ --with-browser="${EPREFIX}/usr/bin/xdg-open" \
+ --with-editor="${EPREFIX}/usr/bin/vi" \
+ --with-imagelib="${imagelib:-no}" \
+ --with-mailer="${EPREFIX}/bin/mail" \
+ --without-migemo \
+ --with-termlib=yes \
+ "${myconf[@]}"
+}
+
+src_install() {
+ default
+
+ insinto /etc/${PN}
+ newins "${FILESDIR}"/${PN}.mailcap mailcap
+
+ insinto /usr/share/${PN}/Bonus
+ doins Bonus/{*.{cgi,rb},html*,makeref}
+
+ docinto en
+ dodoc doc/{HISTORY,README,keymap,menu}*
+ newdoc Bonus/README.eng README.Bonus
+ docinto html/en
+ dodoc doc/*.html
+
+ docinto de
+ dodoc doc-de/README*
+ docinto html/de
+ dodoc doc-de/*.html
+
+ docinto ja
+ dodoc doc-jp/{HISTORY,README,keymap,menu}*
+ newdoc Bonus/README README.Bonus
+ docinto html/ja
+ dodoc doc-jp/*.html
+}