summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /www-plugins/gecko-mediaplayer
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'www-plugins/gecko-mediaplayer')
-rw-r--r--www-plugins/gecko-mediaplayer/Manifest2
-rw-r--r--www-plugins/gecko-mediaplayer/gecko-mediaplayer-1.0.8.ebuild40
-rw-r--r--www-plugins/gecko-mediaplayer/gecko-mediaplayer-1.0.9.ebuild40
-rw-r--r--www-plugins/gecko-mediaplayer/metadata.xml11
4 files changed, 93 insertions, 0 deletions
diff --git a/www-plugins/gecko-mediaplayer/Manifest b/www-plugins/gecko-mediaplayer/Manifest
new file mode 100644
index 000000000000..19e1a48609af
--- /dev/null
+++ b/www-plugins/gecko-mediaplayer/Manifest
@@ -0,0 +1,2 @@
+DIST gecko-mediaplayer-1.0.8.tar.gz 269970 SHA256 25f02dbc1ece6e69ee4af60a4bf61b08b61997b5d4141eb289f3e5212dc85ecd SHA512 a66d286e668dbe1bbbbf42bbf68bd35bda68db73e7a30674f2cd87850e17a8c27ecf9ae3f32c3024fcca31174e3c5ef88da668b11a5cc3641824fae8c9367962 WHIRLPOOL 5c158521492e1534c48553a0ad06ad137c815ec2a867483a717af23d65ca00ad8c15e72cc02d99d0db6e4f73931718f096960f718b6a4c3078e4c3196aa971cb
+DIST gecko-mediaplayer-1.0.9.tar.gz 271917 SHA256 212a0a87e35da9ed944f5fb827552e9978fd3ea051da89554da5ef3934d4c2a5 SHA512 64624726e2c668085455a7eaaf82f4d7f4c962212789284b2c652fc93b3a9c9e8ad6c3f7f4c887487b68870e867678dd47201bb9495de863a05e0e1e9b7f2a74 WHIRLPOOL a09a85dda42668bb6adda60933b99aa8ee4d15ff8bf2c1d2141dd378c63c0ca2937316718d6abdbe3f6022419070a0f44c1f7f196d32f0784a8d127983bdf94b
diff --git a/www-plugins/gecko-mediaplayer/gecko-mediaplayer-1.0.8.ebuild b/www-plugins/gecko-mediaplayer/gecko-mediaplayer-1.0.8.ebuild
new file mode 100644
index 000000000000..303b193df20a
--- /dev/null
+++ b/www-plugins/gecko-mediaplayer/gecko-mediaplayer-1.0.8.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit multilib nsplugins
+
+DESCRIPTION="A browser plugin that uses GNOME MPlayer"
+HOMEPAGE="http://code.google.com/p/gecko-mediaplayer/"
+SRC_URI="http://${PN}.googlecode.com/files/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ~ppc ~ppc64 x86"
+IUSE="+curl"
+
+RDEPEND=">=dev-libs/dbus-glib-0.100
+ >=dev-libs/glib-2.30
+ dev-libs/nspr
+ >=media-libs/gmtk-${PV}
+ >=media-video/gnome-mplayer-${PV}[dbus]
+ curl? ( net-misc/curl )"
+DEPEND="${RDEPEND}
+ app-arch/xz-utils
+ >=net-misc/npapi-sdk-0.27
+ sys-devel/gettext
+ virtual/pkgconfig"
+
+DOCS="ChangeLog DOCS/tech/*.txt"
+
+src_configure() {
+ econf \
+ --with-plugin-dir=/usr/$(get_libdir)/${PLUGINS_DIR} \
+ $(use_with curl libcurl)
+}
+
+src_install() {
+ default
+ rm -rf "${ED}"/usr/share/doc/${PN}
+}
diff --git a/www-plugins/gecko-mediaplayer/gecko-mediaplayer-1.0.9.ebuild b/www-plugins/gecko-mediaplayer/gecko-mediaplayer-1.0.9.ebuild
new file mode 100644
index 000000000000..9e611f767f93
--- /dev/null
+++ b/www-plugins/gecko-mediaplayer/gecko-mediaplayer-1.0.9.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit multilib nsplugins
+
+DESCRIPTION="A browser plugin that uses GNOME MPlayer"
+HOMEPAGE="http://code.google.com/p/gecko-mediaplayer/"
+SRC_URI="http://${PN}.googlecode.com/svn/packages/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ~ppc ~ppc64 x86"
+IUSE="+curl"
+
+RDEPEND=">=dev-libs/dbus-glib-0.100
+ >=dev-libs/glib-2.30
+ dev-libs/nspr
+ >=media-libs/gmtk-${PV}
+ >=media-video/gnome-mplayer-${PV}[dbus]
+ curl? ( net-misc/curl )"
+DEPEND="${RDEPEND}
+ app-arch/xz-utils
+ >=net-misc/npapi-sdk-0.27
+ sys-devel/gettext
+ virtual/pkgconfig"
+
+DOCS="ChangeLog DOCS/tech/*.txt"
+
+src_configure() {
+ econf \
+ --with-plugin-dir=/usr/$(get_libdir)/${PLUGINS_DIR} \
+ $(use_with curl libcurl)
+}
+
+src_install() {
+ default
+ rm -rf "${ED}"/usr/share/doc/${PN}
+}
diff --git a/www-plugins/gecko-mediaplayer/metadata.xml b/www-plugins/gecko-mediaplayer/metadata.xml
new file mode 100644
index 000000000000..b9229a7c57b7
--- /dev/null
+++ b/www-plugins/gecko-mediaplayer/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>video</herd>
+ <maintainer>
+ <email>media-video@gentoo.org</email>
+ </maintainer>
+ <upstream>
+ <remote-id type="google-code">gecko-mediaplayer</remote-id>
+ </upstream>
+</pkgmetadata>