summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarco Scardovi <marco@scardovi.com>2021-05-12 06:42:45 +0200
committerJoonas Niilola <juippis@gentoo.org>2021-05-12 10:43:37 +0300
commitde8c0aabbe0f74a15532360925f69d4f2ffdb373 (patch)
tree2b83405e354c46b3b4a74ba2db99fb814ed20f99 /www-servers
parentdev-cpp/prometheus-cpp: Remove proxy maintainer (diff)
downloadgentoo-de8c0aabbe0f74a15532360925f69d4f2ffdb373.tar.gz
gentoo-de8c0aabbe0f74a15532360925f69d4f2ffdb373.tar.bz2
gentoo-de8c0aabbe0f74a15532360925f69d4f2ffdb373.zip
www-servers/pound: bump to 3.0, various changes
Bump to version 3.0 Unfortunately this release drop support for alpha, hppa, ppc and sparc because a required dep (dev-libs/nanomsg) is not supported for these architectures. Bug: https://bugs.gentoo.org/714084 Closes: https://bugs.gentoo.org/657942 Closes: https://bugs.gentoo.org/527278 Closes: https://bugs.gentoo.org/657946 Closes: https://bugs.gentoo.org/674064 Package-Manager: Portage-3.0.18, Repoman-3.0.3 Signed-off-by: Marco Scardovi <marco@scardovi.com> Closes: https://github.com/gentoo/gentoo/pull/20781 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'www-servers')
-rw-r--r--www-servers/pound/Manifest1
-rw-r--r--www-servers/pound/files/pound-2.2.cfg1
-rw-r--r--www-servers/pound/pound-3.0.ebuild55
3 files changed, 56 insertions, 1 deletions
diff --git a/www-servers/pound/Manifest b/www-servers/pound/Manifest
index 73c67241207a..db05fcced464 100644
--- a/www-servers/pound/Manifest
+++ b/www-servers/pound/Manifest
@@ -1 +1,2 @@
DIST Pound-2.7f.tgz 186719 BLAKE2B 39a31b43c5945db1b5ad008e2f43d3026728ea5bdc3de0fa8c0b68a743d0bea4b86dd61a527ea140e6b0546732f0c66c863e78131432af32ab5b0874a7c1f705 SHA512 292f4f7b4363365829f204b687080eae9e17b9a67ae7eb6021eb5a028321191d97abd9633d5664db5ebca6467795f73a787be4a0bd29360d737865930ff81830
+DIST Pound-3.0.tgz 75905 BLAKE2B 8834d2d57c81bf792d803bc2aef7ad5d17243539ea3fddab777ab3dbd7f903a2f771762ee8d4818c63b7c6380c253dc7c7465e10225f884c2bb968af3dfab831 SHA512 28426fa2d66efa310fce43fc57b87b6cd9d646573161ab880b139feec856710306002af623f023907bb77f8b37979cf2332dc3e16cde48c6d349d813c6ac47e2
diff --git a/www-servers/pound/files/pound-2.2.cfg b/www-servers/pound/files/pound-2.2.cfg
index 664ea53c9edd..473abc120e5f 100644
--- a/www-servers/pound/files/pound-2.2.cfg
+++ b/www-servers/pound/files/pound-2.2.cfg
@@ -51,4 +51,3 @@ End
## End listener
End
-
diff --git a/www-servers/pound/pound-3.0.ebuild b/www-servers/pound/pound-3.0.ebuild
new file mode 100644
index 000000000000..782a2ffdff12
--- /dev/null
+++ b/www-servers/pound/pound-3.0.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake
+
+MY_P="${P/p/P}"
+
+DESCRIPTION="A http/https reverse-proxy and load-balancer"
+HOMEPAGE="https://www.apsis.ch/pound.html"
+SRC_URI="https://www.apsis.ch/pound/${MY_P}.tgz"
+
+LICENSE="BSD GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~mips ~x86"
+
+DEPEND="
+ dev-libs/libpcre:=
+ dev-libs/libyaml:=
+ dev-libs/nanomsg:=
+ dev-libs/openssl:=
+ net-libs/mbedtls:=
+"
+
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${MY_P}"
+
+DOCS=( README.md )
+
+src_compile() {
+ cmake_src_compile
+}
+
+src_install() {
+ rm GPL.txt || die
+
+ dosbin "${BUILD_DIR}"/pound
+ doman "${S}"/man/pound.8
+ einstalldocs
+
+ dodir /etc/init.d
+ newinitd "${FILESDIR}"/pound.init-1.9 pound
+
+ insinto /etc
+ newins "${FILESDIR}"/pound-2.2.cfg pound.cfg
+}
+
+pkg_postinst() {
+ elog "No demo-/sample-configfile is included in the distribution;"
+ elog "read the man-page for more info."
+ elog "A sample (localhost:8888 -> localhost:80)"
+ elog "for gentoo is given in \"/etc/pound.cfg\"."
+}