summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2024-03-26 11:22:37 -0400
committerMatt Turner <mattst88@gentoo.org>2024-03-26 11:26:47 -0400
commita7c03ee047bc884c87cc5f68960a78c4b6c8c755 (patch)
treeac683b5bdb0e634cbbfb3e9af09f4aa74c8650ec /x11-base
parentx11-base/xorg-proto: Remove empty global assignments (diff)
downloadgentoo-a7c03ee047bc884c87cc5f68960a78c4b6c8c755.tar.gz
gentoo-a7c03ee047bc884c87cc5f68960a78c4b6c8c755.tar.bz2
gentoo-a7c03ee047bc884c87cc5f68960a78c4b6c8c755.zip
x11-base/xorg-proto: Version bump to 2024.1
Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'x11-base')
-rw-r--r--x11-base/xorg-proto/Manifest1
-rw-r--r--x11-base/xorg-proto/xorg-proto-2024.1.ebuild51
2 files changed, 52 insertions, 0 deletions
diff --git a/x11-base/xorg-proto/Manifest b/x11-base/xorg-proto/Manifest
index 7357be3c28c5..564e71193cf4 100644
--- a/x11-base/xorg-proto/Manifest
+++ b/x11-base/xorg-proto/Manifest
@@ -1 +1,2 @@
DIST xorgproto-2023.2.tar.xz 759040 BLAKE2B ff255b91770ad11cdcc48d12815317285d8d16d28011a86166f3e07af18b30fdf35c2eb7b6537504eb4c0e9ca65b3116493422b6faebe04ee80e6aee92387675 SHA512 af0a8c8094fc6a490a886a8c048175762b6334798f2e48b6f6e19a7bb39ddbef05fa1237c4e9d9f1d870d24f5ca7a7c463044c41ceebd108f8ab0816677a582d
+DIST xorgproto-2024.1.tar.xz 760500 BLAKE2B a3850f8594e8b4240f731dce696c3ab8310c3b2419117dea3141a093a690d9bc16652e64eb5516073145309c65327bd14be2eaa8843c04de25c8eff6c46d3c1d SHA512 63955cb604ff831575af2193548857c1b99e52d00206ea9421ce99e145094bcd907388c4574bc32174a01cbe2c940b0377bf75ae7d2c0f953157dc9c32e5a07f
diff --git a/x11-base/xorg-proto/xorg-proto-2024.1.ebuild b/x11-base/xorg-proto/xorg-proto-2024.1.ebuild
new file mode 100644
index 000000000000..980d24c44384
--- /dev/null
+++ b/x11-base/xorg-proto/xorg-proto-2024.1.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+PYTHON_COMPAT=( python3_{10..12} )
+
+MY_PN="${PN/xorg-/xorg}"
+MY_P="${MY_PN}-${PV}"
+
+EGIT_REPO_URI="https://gitlab.freedesktop.org/xorg/proto/${MY_PN}.git"
+
+if [[ ${PV} = 9999* ]]; then
+ GIT_ECLASS="git-r3"
+fi
+
+inherit ${GIT_ECLASS} meson python-any-r1
+
+DESCRIPTION="X.Org combined protocol headers"
+HOMEPAGE="https://gitlab.freedesktop.org/xorg/proto/xorgproto"
+if [[ ${PV} != 9999* ]]; then
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~x64-macos ~x64-solaris"
+ SRC_URI="https://xorg.freedesktop.org/archive/individual/proto/${MY_P}.tar.xz"
+ S="${WORKDIR}/${MY_P}"
+fi
+
+LICENSE="MIT"
+SLOT="0"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+BDEPEND="
+ test? (
+ $(python_gen_any_dep '
+ dev-python/libevdev[${PYTHON_USEDEP}]
+ ')
+ )
+"
+
+python_check_deps() {
+ python_has_version "dev-python/libevdev[${PYTHON_USEDEP}]"
+}
+
+pkg_setup() {
+ use test && python-any-r1_pkg_setup
+}
+
+src_install() {
+ meson_src_install
+
+ mv "${ED}"/usr/share/doc/{xorgproto,${P}} || die
+}