summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2024-10-17 22:33:01 -0400
committerMatt Turner <mattst88@gentoo.org>2024-10-17 22:40:13 -0400
commit0517f2c307abbf0dac3115fc55a4252dc2b874f1 (patch)
treedc8a255eda2ea634972c6b52e3c376e6bcd5096e /x11-drivers
parentx11-drivers/xf86-input-evdev: Version bump to 2.11.0 (diff)
downloadgentoo-0517f2c307abbf0dac3115fc55a4252dc2b874f1.tar.gz
gentoo-0517f2c307abbf0dac3115fc55a4252dc2b874f1.tar.bz2
gentoo-0517f2c307abbf0dac3115fc55a4252dc2b874f1.zip
x11-drivers/xf86-input-libinput: Version bump to 1.5.0
Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'x11-drivers')
-rw-r--r--x11-drivers/xf86-input-libinput/Manifest1
-rw-r--r--x11-drivers/xf86-input-libinput/xf86-input-libinput-1.5.0.ebuild22
2 files changed, 23 insertions, 0 deletions
diff --git a/x11-drivers/xf86-input-libinput/Manifest b/x11-drivers/xf86-input-libinput/Manifest
index c87657372372..61e332a27996 100644
--- a/x11-drivers/xf86-input-libinput/Manifest
+++ b/x11-drivers/xf86-input-libinput/Manifest
@@ -1 +1,2 @@
DIST xf86-input-libinput-1.4.0.tar.xz 326708 BLAKE2B 258c0c1584e3dd370044be9702d669b1036597d936af9b7bda6cbd19642a9188054beab85a18d5571020859b3046db916efe05d4691f468eae706bd78c33e2d6 SHA512 b286b5425aeda5cfecd1de7f59663d169b95ffc55474dfbf28c2e13e5221cbeecd472d40b6094c0a937f83db67bf58a7fe0e07d25b6a6945d3fd669e717fc0bf
+DIST xf86-input-libinput-1.5.0.tar.xz 330088 BLAKE2B 33c81de8bd621c6c838420747f140689c8937d7fae4c4a5beef7ede65a1ad24e1bb620f2798a002de063eef47a6e6a5a3e8bad405370b02f87aa63c2f7897afb SHA512 03090beb7c162fdf55e9bb9da41ffb8601b20047e4a53895bad27de47b3197fc920e710f26fa23e7322b367ab65fa56ba5f9a195ec69801529af3958632c2d6e
diff --git a/x11-drivers/xf86-input-libinput/xf86-input-libinput-1.5.0.ebuild b/x11-drivers/xf86-input-libinput/xf86-input-libinput-1.5.0.ebuild
new file mode 100644
index 000000000000..ecaa02a6523d
--- /dev/null
+++ b/x11-drivers/xf86-input-libinput/xf86-input-libinput-1.5.0.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+XORG_TARBALL_SUFFIX="xz"
+
+inherit linux-info xorg-3
+
+DESCRIPTION="X.org input driver based on libinput"
+
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND=">=dev-libs/libinput-1.23.0:0="
+DEPEND="${RDEPEND}
+ >=x11-base/xorg-proto-2021.5"
+
+DOCS=( "README.md" )
+
+pkg_pretend() {
+ CONFIG_CHECK="~TIMERFD"
+ check_extra_config
+}