summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2025-01-05 14:07:47 -0500
committerMatt Turner <mattst88@gentoo.org>2025-01-05 23:08:18 -0500
commit241bd97282b7e956121e6dc8a23657a15be8e2ec (patch)
treec02568011c9c40bc073730a683141f7c7990aece /x11-drivers
parentx11-apps/xinit: Version bump to 1.4.3 (diff)
downloadgentoo-241bd97282b7e956121e6dc8a23657a15be8e2ec.tar.gz
gentoo-241bd97282b7e956121e6dc8a23657a15be8e2ec.tar.bz2
gentoo-241bd97282b7e956121e6dc8a23657a15be8e2ec.zip
x11-drivers/xf86-input-synaptics: Version bump to 1.10.0
Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'x11-drivers')
-rw-r--r--x11-drivers/xf86-input-synaptics/Manifest1
-rw-r--r--x11-drivers/xf86-input-synaptics/xf86-input-synaptics-1.10.0.ebuild44
2 files changed, 45 insertions, 0 deletions
diff --git a/x11-drivers/xf86-input-synaptics/Manifest b/x11-drivers/xf86-input-synaptics/Manifest
index 054314735732..84ad682c6457 100644
--- a/x11-drivers/xf86-input-synaptics/Manifest
+++ b/x11-drivers/xf86-input-synaptics/Manifest
@@ -1 +1,2 @@
+DIST xf86-input-synaptics-1.10.0.tar.xz 431316 BLAKE2B 02b90fca8baba07323141efbca0cc039d52406cc0272de12f6c08ac90769ffb14a7725a5e25f47d6235661f69136b5a9d8edef76203c63a027d7b12b3368f540 SHA512 deb14ba039f423c4575825ecdeb74f31e30f044a4efc7dae9c1634f841dcf7066970cd470be7e63f68eccd4899e0434d602e59c297042cb2f38ff2a3a02d7e91
DIST xf86-input-synaptics-1.9.2.tar.xz 432380 BLAKE2B 7ba94565f454fff8ddaf33695a7a16526810bf2677ef01e9ae740fd00a95810b4d42fb0077fe93120ac72398ca18ade48c7b389ecbc37f2438beaa97a6a21db5 SHA512 6fd46505f22bba79f612fbd48dddd4818f7d874cc29caac71840744de27f1d224c68861e3a18d2a866b78178924d2f093f5260e27b221aa1fb17dbc09d66b649
diff --git a/x11-drivers/xf86-input-synaptics/xf86-input-synaptics-1.10.0.ebuild b/x11-drivers/xf86-input-synaptics/xf86-input-synaptics-1.10.0.ebuild
new file mode 100644
index 000000000000..fbafe8dc0c29
--- /dev/null
+++ b/x11-drivers/xf86-input-synaptics/xf86-input-synaptics-1.10.0.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2025 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit linux-info xorg-3
+
+DESCRIPTION="Driver for Synaptics touchpads"
+
+KEYWORDS="~amd64 ~arm ~arm64 ~loong ~mips ~ppc ~ppc64 ~x86"
+
+RDEPEND="
+ >=x11-base/xorg-server-1.14
+ x11-libs/libX11
+ >=x11-libs/libXi-1.2
+ >=x11-libs/libXtst-1.1.0
+ kernel_linux? ( >=dev-libs/libevdev-0.4 )"
+DEPEND="
+ ${RDEPEND}
+ >=sys-kernel/linux-headers-2.6.37
+ x11-base/xorg-proto"
+
+check_reqs() {
+ linux-info_pkg_setup
+
+ # Just a friendly warning
+ if ! linux_config_exists \
+ || ! linux_chkconfig_present INPUT_EVDEV; then
+ ewarn
+ ewarn "This driver requires event interface support in your kernel"
+ ewarn " Device Drivers --->"
+ ewarn " Input device support --->"
+ ewarn " <*> Event interface"
+ ewarn
+ fi
+}
+
+pkg_pretend() {
+ check_reqs
+}
+
+pkg_setup() {
+ check_reqs
+}