summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <sudinave@gmail.com>2021-04-17 16:44:10 +0200
committerDavid Seifert <soap@gentoo.org>2021-04-17 16:44:10 +0200
commit54827cc7051bafd5ecab89306286804d8d3c8eb8 (patch)
tree092e74acd3157cd558ebeab939e558f612feae29 /x11-drivers
parentsys-devel/automake: defer python_setup to src_configure (diff)
downloadgentoo-54827cc7051bafd5ecab89306286804d8d3c8eb8.tar.gz
gentoo-54827cc7051bafd5ecab89306286804d8d3c8eb8.tar.bz2
gentoo-54827cc7051bafd5ecab89306286804d8d3c8eb8.zip
x11-drivers/nvidia-drivers: remove egl-wayland support for 390.141
Current egl-wayland does not work as expected with legacy drivers, and old versions are lacking some features that will make it difficult to support in the future. Remove optfeature and add a warning just-in-case (unlikely was used). Signed-off-by: Ionen Wolkens <sudinave@gmail.com> Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'x11-drivers')
-rw-r--r--x11-drivers/nvidia-drivers/nvidia-drivers-390.141-r1.ebuild11
1 files changed, 8 insertions, 3 deletions
diff --git a/x11-drivers/nvidia-drivers/nvidia-drivers-390.141-r1.ebuild b/x11-drivers/nvidia-drivers/nvidia-drivers-390.141-r1.ebuild
index baff134c6954..d86ba28da9ec 100644
--- a/x11-drivers/nvidia-drivers/nvidia-drivers-390.141-r1.ebuild
+++ b/x11-drivers/nvidia-drivers/nvidia-drivers-390.141-r1.ebuild
@@ -4,7 +4,7 @@
EAPI=7
MODULES_OPTIONAL_USE="driver"
-inherit desktop linux-info linux-mod multilib-build optfeature \
+inherit desktop linux-info linux-mod multilib-build \
readme.gentoo-r1 systemd toolchain-funcs unpacker
NV_KERNEL_MAX="5.10"
@@ -345,6 +345,8 @@ src_install() {
}
pkg_preinst() {
+ has_version "x11-drivers/nvidia-drivers[wayland]" && NV_HAD_WAYLAND=1
+
use driver || return
linux-mod_pkg_preinst
@@ -360,8 +362,6 @@ pkg_postinst() {
readme.gentoo_print_elog
- optfeature "wayland EGLStream with nvidia-drm.modeset=1" gui-libs/egl-wayland
-
if [[ -r /proc/driver/nvidia/version &&
$(grep -o ' [0-9.]* ' /proc/driver/nvidia/version) != " ${PV} " ]]; then
ewarn "Currently loaded NVIDIA modules do not match the newly installed"
@@ -375,4 +375,9 @@ pkg_postinst() {
elog "This means OpenCL/CUDA (and related, like nvenc) cannot be used."
elog "Other functions, like OpenGL, will continue to work."
fi
+
+ if [[ ${NV_HAD_WAYLAND} ]]; then
+ elog "Support for EGLStream (egl-wayland) is no longer offered with legacy"
+ elog "nvidia-drivers. It is recommended to use nouveau drivers for wayland."
+ fi
}