summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /x11-libs/libXdmcp
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'x11-libs/libXdmcp')
-rw-r--r--x11-libs/libXdmcp/Manifest2
-rw-r--r--x11-libs/libXdmcp/libXdmcp-1.1.1-r1.ebuild27
-rw-r--r--x11-libs/libXdmcp/libXdmcp-1.1.2.ebuild27
-rw-r--r--x11-libs/libXdmcp/metadata.xml5
4 files changed, 61 insertions, 0 deletions
diff --git a/x11-libs/libXdmcp/Manifest b/x11-libs/libXdmcp/Manifest
new file mode 100644
index 000000000000..4826cadaa1cb
--- /dev/null
+++ b/x11-libs/libXdmcp/Manifest
@@ -0,0 +1,2 @@
+DIST libXdmcp-1.1.1.tar.bz2 310878 SHA256 9ace6d4230f9dce4ed090692f82f613253ada8f887b23b3d8ff3dd4e3a7c118e SHA512 b17ad4bf01443cb78b440a33a89f2b98babf02402d7bdf68161a08429fd1964ac8112b0bb1519dd2138db0a5ff295c7b7581f56ff602ccca1a9baac26bc62e08 WHIRLPOOL 54bc7ebdbdced210a0e2c82eb63fdb884a3e9869127b5489f11e0e6f8f1c0b55d825f0b5e10b30f52db4d35bec2b1bf91d32eb326c7e6ce5a3cba8fff9abb606
+DIST libXdmcp-1.1.2.tar.bz2 331518 SHA256 81fe09867918fff258296e1e1e159f0dc639cb30d201c53519f25ab73af4e4e2 SHA512 f96005934b8bc752059106f8caf7df0574f5ef3c7a83bd797497b56ca556a7ff4dc1d28195e421259e82ea027b5c738094add3ec107a22544c9070725d8d46bb WHIRLPOOL ad5a3c86463d4ae582f1ffaf2ae85f5d118f7789b18f9cafd08dcc43b6fe03d9797430e0a686a7d422e09342f4a2c01f0e83a9eb9563dd6a66bf94722b81f2e0
diff --git a/x11-libs/libXdmcp/libXdmcp-1.1.1-r1.ebuild b/x11-libs/libXdmcp/libXdmcp-1.1.1-r1.ebuild
new file mode 100644
index 000000000000..f70f8a883425
--- /dev/null
+++ b/x11-libs/libXdmcp/libXdmcp-1.1.1-r1.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+XORG_DOC=doc
+XORG_MULTILIB=yes
+inherit xorg-2
+
+DESCRIPTION="X.Org X Display Manager Control Protocol library"
+
+KEYWORDS="alpha amd64 arm arm64 hppa ia64 ~mips ppc ppc64 ~s390 ~sh sparc x86 ~ppc-aix ~amd64-fbsd ~x86-fbsd ~x64-freebsd ~x86-freebsd ~ia64-hpux ~x86-interix ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris ~x86-winnt"
+IUSE=""
+
+RDEPEND="x11-proto/xproto"
+DEPEND="${RDEPEND}"
+
+pkg_setup() {
+ xorg-2_pkg_setup
+
+ XORG_CONFIGURE_OPTIONS=(
+ $(use_enable doc docs)
+ $(use_with doc xmlto)
+ --without-fop
+ )
+}
diff --git a/x11-libs/libXdmcp/libXdmcp-1.1.2.ebuild b/x11-libs/libXdmcp/libXdmcp-1.1.2.ebuild
new file mode 100644
index 000000000000..b4b98a26383d
--- /dev/null
+++ b/x11-libs/libXdmcp/libXdmcp-1.1.2.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+XORG_DOC=doc
+XORG_MULTILIB=yes
+inherit xorg-2
+
+DESCRIPTION="X.Org X Display Manager Control Protocol library"
+
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~amd64-fbsd ~x86-fbsd ~x64-freebsd ~x86-freebsd ~ia64-hpux ~x86-interix ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris ~x86-winnt"
+IUSE=""
+
+RDEPEND="x11-proto/xproto"
+DEPEND="${RDEPEND}"
+
+pkg_setup() {
+ xorg-2_pkg_setup
+
+ XORG_CONFIGURE_OPTIONS=(
+ $(use_enable doc docs)
+ $(use_with doc xmlto)
+ --without-fop
+ )
+}
diff --git a/x11-libs/libXdmcp/metadata.xml b/x11-libs/libXdmcp/metadata.xml
new file mode 100644
index 000000000000..01c4c004e735
--- /dev/null
+++ b/x11-libs/libXdmcp/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>x11</herd>
+</pkgmetadata>