summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2019-07-05 10:40:53 +0200
committerLars Wendler <polynomial-c@gentoo.org>2019-07-05 10:41:18 +0200
commit74780d6a86763c496ff6ceba415fcc448f91d937 (patch)
tree74350a841e9a7b9a061ed334277743708edea0c7 /x11-libs/libva/libva-9999.ebuild
parentx11-libs/libva: Bump to version 2.4.1 (diff)
downloadgentoo-74780d6a86763c496ff6ceba415fcc448f91d937.tar.gz
gentoo-74780d6a86763c496ff6ceba415fcc448f91d937.tar.bz2
gentoo-74780d6a86763c496ff6ceba415fcc448f91d937.zip
x11-libs/libva: Synced live ebuild.
Package-Manager: Portage-2.3.68, Repoman-2.3.16 Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
Diffstat (limited to 'x11-libs/libva/libva-9999.ebuild')
-rw-r--r--x11-libs/libva/libva-9999.ebuild27
1 files changed, 16 insertions, 11 deletions
diff --git a/x11-libs/libva/libva-9999.ebuild b/x11-libs/libva/libva-9999.ebuild
index 7de898cf6aa1..3a85df58500e 100644
--- a/x11-libs/libva/libva-9999.ebuild
+++ b/x11-libs/libva/libva-9999.ebuild
@@ -1,20 +1,19 @@
# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=7
-if [[ ${PV} = *9999* ]] ; then # Live ebuild
- inherit git-r3
- EGIT_BRANCH=master
- EGIT_REPO_URI="https://github.com/intel/libva"
- AUTOTOOLS_AUTORECONF="yes"
-fi
-inherit autotools-multilib eapi7-ver multilib
+inherit multilib-minimal
DESCRIPTION="Video Acceleration (VA) API for Linux"
HOMEPAGE="https://01.org/linuxmedia/vaapi"
-if [[ ${PV} != *9999* ]] ; then
+if [[ ${PV} = *9999* ]] ; then # Live ebuild
+ inherit autotools git-r3
+ EGIT_BRANCH=master
+ EGIT_REPO_URI="https://github.com/intel/libva"
+ AUTOTOOLS_AUTORECONF="yes"
+else
SRC_URI="https://github.com/intel/libva/releases/download/${PV}/${P}.tar.bz2"
KEYWORDS="~amd64 ~arm64 ~x86 ~amd64-linux ~x86-linux"
fi
@@ -38,7 +37,8 @@ RDEPEND="
>=x11-libs/libXfixes-5.0.1[${MULTILIB_USEDEP}]
)
"
-DEPEND="${RDEPEND}
+DEPEND="${RDEPEND}"
+BDEPEND="
virtual/pkgconfig
"
PDEPEND="video_cards_nvidia? ( >=x11-libs/libva-vdpau-driver-0.7.4-r1[${MULTILIB_USEDEP}] )
@@ -62,6 +62,11 @@ MULTILIB_WRAPPED_HEADERS=(
/usr/include/va/va_glx.h
)
+src_prepare() {
+ default
+ [[ "${PV}" == *9999* ]] && eautoreconf
+}
+
multilib_src_configure() {
local myeconfargs=(
--with-drivers-path="${EPREFIX}/usr/$(get_libdir)/va/drivers"
@@ -70,5 +75,5 @@ multilib_src_configure() {
$(use_enable wayland)
$(use_enable drm)
)
- autotools-utils_src_configure
+ ECONF_SOURCE="${S}" econf "${myeconfargs[@]}"
}