summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2023-02-20 21:51:39 +0100
committerDavid Seifert <soap@gentoo.org>2023-02-20 21:51:39 +0100
commit20a0e4ae866da76aa366b14d4fdd36b0fe6f052a (patch)
treebcdda4a1b39ef75cb2046a23dc47a668e85e8375 /x11-libs
parentx11-libs/libtinynotify-systemwide: drop 9999 (diff)
downloadgentoo-20a0e4ae866da76aa366b14d4fdd36b0fe6f052a.tar.gz
gentoo-20a0e4ae866da76aa366b14d4fdd36b0fe6f052a.tar.bz2
gentoo-20a0e4ae866da76aa366b14d4fdd36b0fe6f052a.zip
x11-libs/libtinynotify-systemwide: update EAPI 6 -> 8
Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'x11-libs')
-rw-r--r--x11-libs/libtinynotify-systemwide/libtinynotify-systemwide-0.1-r1.ebuild (renamed from x11-libs/libtinynotify-systemwide/libtinynotify-systemwide-0.1.ebuild)23
1 files changed, 10 insertions, 13 deletions
diff --git a/x11-libs/libtinynotify-systemwide/libtinynotify-systemwide-0.1.ebuild b/x11-libs/libtinynotify-systemwide/libtinynotify-systemwide-0.1-r1.ebuild
index 4543af991c3e..3fd392196e9c 100644
--- a/x11-libs/libtinynotify-systemwide/libtinynotify-systemwide-0.1.ebuild
+++ b/x11-libs/libtinynotify-systemwide/libtinynotify-systemwide-0.1-r1.ebuild
@@ -1,7 +1,7 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=8
DESCRIPTION="A system-wide notifications module for libtinynotify"
HOMEPAGE="https://github.com/mgorny/libtinynotify-systemwide/"
@@ -10,24 +10,21 @@ SRC_URI="https://github.com/mgorny/libtinynotify-systemwide/releases/download/${
LICENSE="BSD"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-IUSE="doc static-libs"
+IUSE="doc"
-RDEPEND="sys-process/procps:0=
- x11-libs/libtinynotify:0="
-DEPEND="${RDEPEND}
+RDEPEND="
+ sys-process/procps:=
+ x11-libs/libtinynotify:="
+DEPEND="${RDEPEND}"
+BDEPEND="
virtual/pkgconfig
doc? ( dev-util/gtk-doc )"
src_configure() {
- local myconf=(
- $(use_enable doc gtk-doc)
- $(use_enable static-libs static)
- )
-
- econf "${myconf[@]}"
+ econf $(use_enable doc gtk-doc)
}
src_install() {
default
- find "${D}" -name '*.la' -delete || die
+ find "${ED}" -name '*.la' -delete || die
}