summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas K. Hüttel <dilfridge@gentoo.org>2018-03-03 23:55:59 +0100
committerAndreas K. Hüttel <dilfridge@gentoo.org>2018-03-03 23:55:59 +0100
commitab25aaad6dbd69d70986a7ded58e3d690cf9c2a1 (patch)
tree8fdf70abfc0efefa36b37e4e97169589086fcc2b /x11-libs
parentpackage.mask: mask app-pda/p3nfs for removal (diff)
downloadgentoo-ab25aaad6dbd69d70986a7ded58e3d690cf9c2a1.tar.gz
gentoo-ab25aaad6dbd69d70986a7ded58e3d690cf9c2a1.tar.bz2
gentoo-ab25aaad6dbd69d70986a7ded58e3d690cf9c2a1.zip
x11-libs/libyui-qt: Fix build with glibc-2.26, bug 631056
Closes: https://bugs.gentoo.org/631056 Package-Manager: Portage-2.3.24, Repoman-2.3.6
Diffstat (limited to 'x11-libs')
-rw-r--r--x11-libs/libyui-qt/files/libyui-qt-2.46.21-norpc.patch24
-rw-r--r--x11-libs/libyui-qt/libyui-qt-2.46.21.ebuild4
2 files changed, 27 insertions, 1 deletions
diff --git a/x11-libs/libyui-qt/files/libyui-qt-2.46.21-norpc.patch b/x11-libs/libyui-qt/files/libyui-qt-2.46.21-norpc.patch
new file mode 100644
index 000000000000..8258fe7b1910
--- /dev/null
+++ b/x11-libs/libyui-qt/files/libyui-qt-2.46.21-norpc.patch
@@ -0,0 +1,24 @@
+From a6e599e79bd15f6a97ff6d8f2e3109759ff37aaf Mon Sep 17 00:00:00 2001
+From: Thorsten Kukuk <kukuk@thkukuk.de>
+Date: Mon, 13 Nov 2017 11:15:21 +0100
+Subject: [PATCH] Include sys/param.h instead of rpc/types.h for
+ MAXHOSTNAMELEN, we are not using RPC functions and sunrpc is deprecated in
+ glibc.
+
+---
+ src/YQUI.cc | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/src/YQUI.cc b/src/YQUI.cc
+index 7c82468..f949979 100644
+--- a/src/YQUI.cc
++++ b/src/YQUI.cc
+@@ -22,7 +22,7 @@
+
+ /-*/
+
+-#include <rpc/types.h> // MAXHOSTNAMELEN
++#include <sys/param.h> // MAXHOSTNAMELEN
+ #include <dlfcn.h>
+ #include <libintl.h>
+ #include <algorithm>
diff --git a/x11-libs/libyui-qt/libyui-qt-2.46.21.ebuild b/x11-libs/libyui-qt/libyui-qt-2.46.21.ebuild
index 885e3886395d..dbd9945ad3a7 100644
--- a/x11-libs/libyui-qt/libyui-qt-2.46.21.ebuild
+++ b/x11-libs/libyui-qt/libyui-qt-2.46.21.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=5
@@ -30,6 +30,8 @@ DEPEND="${RDEPEND}
S="${WORKDIR}/${PN}-${PN}-master-${PV}"
+PATCHES=( "${FILESDIR}/${P}-norpc.patch" )
+
src_prepare() {
cp "${EPREFIX}/usr/share/libyui/buildtools/CMakeLists.common" CMakeLists.txt || die