summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJay Faulkner <jay@jvf.cc>2022-05-01 16:59:46 -0700
committerSam James <sam@gentoo.org>2022-05-02 01:56:52 +0100
commit35891ce3b0970a37ac5ae46297717fb92ab92331 (patch)
tree3d7230d6ed74b65a606f55800f376d8b51e61c18 /x11-misc/revelation
parentdev-libs/flatbuffers: use EAPI 8 (diff)
downloadgentoo-35891ce3b0970a37ac5ae46297717fb92ab92331.tar.gz
gentoo-35891ce3b0970a37ac5ae46297717fb92ab92331.tar.bz2
gentoo-35891ce3b0970a37ac5ae46297717fb92ab92331.zip
x11-misc/revelation: version bump to 0.55
- Updated to EAPI 8 - New version includes meson fix, no need for patch - New dependency: defusedxml, per https://github.com/mikelolasagasti/revelation/commit/edb67aa58d42a2075d2d8c132817eacfdb39a916 Package-Manager: Portage-3.0.30, Repoman-3.0.3 Signed-off-by: Jay Faulkner <jay@jvf.cc> Closes: https://github.com/gentoo/gentoo/pull/25185 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'x11-misc/revelation')
-rw-r--r--x11-misc/revelation/Manifest1
-rw-r--r--x11-misc/revelation/revelation-0.5.5.ebuild56
2 files changed, 57 insertions, 0 deletions
diff --git a/x11-misc/revelation/Manifest b/x11-misc/revelation/Manifest
index 9780704989a4..62230acdf449 100644
--- a/x11-misc/revelation/Manifest
+++ b/x11-misc/revelation/Manifest
@@ -1 +1,2 @@
DIST revelation-0.5.4.tar.xz 282600 BLAKE2B 519b01252b82acf0e927a9d19783792f83822cc1f1a4c3be4af3678d5446f8012d993e12397f44aae616aca88257970de7391a1269e24cc1ebc08275d0c962ed SHA512 bd536f6c03e443d91a20606765b661dc54f3e4c1f45d060d3829a894a31e553a61785bb31d7508267abd66e057fc1d93f1716ed1b553566d92a2580ad696606f
+DIST revelation-0.5.5.tar.xz 282252 BLAKE2B 7c4c430d24d79b820139dd2b4989dc2d78c967b16c864149d2aafa9e91ddc26a3351f42b5782812202f77a36529c46d9515cc1aea73346c7e8e017079b810a7d SHA512 17bfeda87e27c00f12bc068446d053cee394282e5eabea6d075ac262b5f400f31520d2f9b29f99097d1d6ad72bbcf5d2d9d4da2a0eba2806ff0adbf1bb47bb0f
diff --git a/x11-misc/revelation/revelation-0.5.5.ebuild b/x11-misc/revelation/revelation-0.5.5.ebuild
new file mode 100644
index 000000000000..372a596dec9d
--- /dev/null
+++ b/x11-misc/revelation/revelation-0.5.5.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..9} )
+
+inherit gnome2-utils python-single-r1 meson xdg
+
+DESCRIPTION="A password manager for GNOME"
+HOMEPAGE="https://revelation.olasagasti.info/ https://github.com/mikelolasagasti/revelation"
+SRC_URI="https://github.com/mikelolasagasti/revelation/releases/download/${P}/${P}.tar.xz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+# Upstream does not provide any test suite.
+RESTRICT="test"
+
+RDEPEND="${PYTHON_DEPS}
+ $(python_gen_cond_dep '
+ dev-python/pycryptodome[${PYTHON_USEDEP}]
+ dev-python/pygobject[${PYTHON_USEDEP}]
+ dev-libs/libpwquality[python,${PYTHON_USEDEP}]
+ ')
+ x11-libs/gtk+:3
+ dev-libs/glib
+ dev-libs/gobject-introspection
+"
+
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+ find -name '*.py' -exec \
+ sed -i -e 's:Cryptodome:Crypto:' meson.build {} + || die
+ default
+}
+
+src_install() {
+ meson_src_install
+ python_fix_shebang "${ED}"
+ python_optimize
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ gnome2_schemas_update
+}
+
+pkg_postrm() {
+ xdg_pkg_postrm
+ gnome2_schemas_update
+}