summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexey Sokolov <alexey+gentoo@asokolov.org>2021-10-26 02:32:31 +0100
committerIonen Wolkens <ionen@gentoo.org>2021-10-27 09:40:28 -0400
commit8d9285485858c2fb3a9389cb33d1e9a33a990c35 (patch)
tree1cd764bce7546377b47daa8840f373340a0c8a91 /x11-misc/shutter
parentgames-strategy/wesnoth: add missing dep on boost[bzip2,context] (diff)
downloadgentoo-8d9285485858c2fb3a9389cb33d1e9a33a990c35.tar.gz
gentoo-8d9285485858c2fb3a9389cb33d1e9a33a990c35.tar.bz2
gentoo-8d9285485858c2fb3a9389cb33d1e9a33a990c35.zip
x11-misc/shutter: version 0.99.2
Package-Manager: Portage-3.0.20, Repoman-3.0.3 Signed-off-by: Alexey Sokolov <alexey+gentoo@asokolov.org> Closes: https://github.com/gentoo/gentoo/pull/22704 Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Diffstat (limited to 'x11-misc/shutter')
-rw-r--r--x11-misc/shutter/Manifest1
-rw-r--r--x11-misc/shutter/shutter-0.99.2.ebuild82
2 files changed, 83 insertions, 0 deletions
diff --git a/x11-misc/shutter/Manifest b/x11-misc/shutter/Manifest
index 48da9932990f..26da2254c57e 100644
--- a/x11-misc/shutter/Manifest
+++ b/x11-misc/shutter/Manifest
@@ -1,2 +1,3 @@
DIST shutter-0.99.1.tar.gz 1733952 BLAKE2B fcf5f9a34ce54f674a4b0f9bba2493917bf27141ea7f7e1d8528ae439eabfb33e4e6805bd3cb96131b297748046c9797747520952ad57cc033cf7f7362c4606c SHA512 4d6ee699d3b31194c6685019a9493968d7a4988ee86f9348cf5aaa15c573b0a5f515ba6e5d786faf8054762ae134fea5ca2add10dbb3e14905247daf1303c751
+DIST shutter-0.99.2.tar.gz 1733886 BLAKE2B 19596b5385a11f179c9fbbf81a97f2a5d9661d52d14f33be72595c26c096548095aa6cdbbc4932413f0a3103b30a78e2e870d2e7e904fb9cf0fd17ee43ad45fb SHA512 5fcb094f0e6f732da3648e58ef62aa1e5537132ffb0bff80972e1891f58fe5e63ec63bc7bec63e84268c095e3cd43d60d358be61e2d050dfcc49ffb042d34cfb
DIST shutter-0.99.tar.gz 1734356 BLAKE2B c261d7792a2a7508fb8e73b968e1e07edbea0338b857132674caee5ec1bb7a3d58eb2e35645c581af652027007a27df6120b035218c41d8671bc53293b6548e7 SHA512 335c85730f49978d4b69ee2d5bbaa5d660d652d386a70618fdeb46c639bd209cee99743b44a8ef1019404f52328692de91bfbe47b14bea202efd089f80d36f82
diff --git a/x11-misc/shutter/shutter-0.99.2.ebuild b/x11-misc/shutter/shutter-0.99.2.ebuild
new file mode 100644
index 000000000000..8a35f2c4fbd4
--- /dev/null
+++ b/x11-misc/shutter/shutter-0.99.2.ebuild
@@ -0,0 +1,82 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit desktop optfeature prefix xdg
+
+DESCRIPTION="Feature-rich screenshot program"
+HOMEPAGE="https://shutter-project.org/"
+SRC_URI="https://github.com/shutter-project/shutter/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ dev-lang/perl
+ dev-perl/Carp-Always
+ dev-perl/libxml-perl
+ dev-perl/libwww-perl
+ dev-perl/Glib-Object-Introspection
+ dev-perl/GooCanvas2
+ dev-perl/GooCanvas2-CairoTypes
+ dev-perl/Gtk3
+ >=dev-perl/Gtk3-ImageView-10
+ dev-perl/File-DesktopEntry
+ dev-perl/File-HomeDir
+ dev-perl/File-Which
+ dev-perl/JSON
+ dev-perl/File-Copy-Recursive
+ dev-perl/File-MimeInfo
+ dev-perl/Locale-gettext
+ dev-perl/Net-DBus
+ dev-perl/Number-Bytes-Human
+ dev-perl/Pango
+ dev-perl/Proc-Simple
+ dev-perl/Proc-ProcessTable
+ dev-perl/Sort-Naturally
+ dev-perl/WWW-Mechanize
+ dev-perl/X11-Protocol
+ dev-perl/XML-Simple
+ virtual/imagemagick-tools[perl]
+ x11-libs/libwnck:3[introspection]
+"
+BDEPEND="sys-devel/gettext"
+
+src_prepare() {
+ hprefixify bin/shutter
+ default
+}
+
+src_install() {
+ dobin bin/shutter
+ dodoc README
+ domenu share/applications/shutter.desktop
+ doicon share/pixmaps/shutter.png
+ doman share/man/man1/shutter.1
+
+ insinto /usr/share
+ doins -r share/shutter
+ doins -r share/locale
+ doins -r share/icons
+
+ insinto /usr/share/metainfo
+ doins share/appdata/shutter.appdata.xml
+
+ # .po doesn't belong to installed system, only .mo
+ rm -r "${ED}"/usr/share/shutter/resources/po || die
+
+ # shutter executes perl scripts as standalone scripts, and after that "require"s them.
+ find "${ED}"/usr/share/shutter/resources/system/plugins/ -type f ! -name '*.*' -exec chmod +x {} + \
+ || die "failed to make plugins executables"
+ find "${ED}"/usr/share/shutter/resources/system/upload_plugins/upload -type f \
+ -name "*.pm" -exec chmod +x {} + || die "failed to make upload plugins executables"
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+
+ optfeature "writing Exif information" media-libs/exiftool
+ optfeature "image hostings uploading" "dev-perl/JSON-MaybeXS dev-perl/Net-OAuth dev-perl/Path-Class"
+}