summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPiotr Karbowski <slashbeast@gentoo.org>2023-03-05 11:36:21 +0100
committerPiotr Karbowski <slashbeast@gentoo.org>2023-03-05 11:37:27 +0100
commita6a400ea7497cb44e1db55a581ce322866479f9a (patch)
tree857c23af3846b01c55d0b4a365ee6e1b1baec1b5 /x11-misc/sunflower
parentdev-ml/zed: support only >=dune-3 (diff)
downloadgentoo-a6a400ea7497cb44e1db55a581ce322866479f9a.tar.gz
gentoo-a6a400ea7497cb44e1db55a581ce322866479f9a.tar.bz2
gentoo-a6a400ea7497cb44e1db55a581ce322866479f9a.zip
x11-misc/sunflower: 0.5-r2 revbump; py3.11; pep517.
Closes: https://bugs.gentoo.org/897352 Signed-off-by: Piotr Karbowski <slashbeast@gentoo.org>
Diffstat (limited to 'x11-misc/sunflower')
-rw-r--r--x11-misc/sunflower/sunflower-0.5-r2.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/x11-misc/sunflower/sunflower-0.5-r2.ebuild b/x11-misc/sunflower/sunflower-0.5-r2.ebuild
new file mode 100644
index 000000000000..e1ad6bd9575d
--- /dev/null
+++ b/x11-misc/sunflower/sunflower-0.5-r2.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{9..11} )
+PYTHON_REQ_USE="sqlite"
+DISTUTILS_USE_PEP517="setuptools"
+inherit distutils-r1 xdg
+
+MY_PN="Sunflower"
+MY_PV="${PV}-63"
+
+DESCRIPTION="Small and highly customizable twin-panel file manager with plugin-support"
+HOMEPAGE="https://github.com/MeanEYE/Sunflower
+ https://sunflower-fm.org/"
+SRC_URI="https://github.com/MeanEYE/${MY_PN}/archive/refs/tags/${MY_PV}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND="
+ ${PYTHON_DEPS}
+ dev-python/pygobject:3[${PYTHON_USEDEP}]
+ dev-python/chardet[${PYTHON_USEDEP}]
+"
+
+RDEPEND="${DEPEND}
+ dev-python/pycairo[${PYTHON_USEDEP}]
+ x11-libs/vte
+"
+
+S="${WORKDIR}/${MY_PN}-${MY_PV}"
+
+src_prepare() {
+ default
+
+ # Upstream's get_version requires a lot of BDEPENDS we do not want.
+ sed 's%version=get_version()%version="0.5"%g' -i setup.py
+}