summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas K. Hüttel <dilfridge@gentoo.org>2023-05-05 22:19:55 +0200
committerAndreas K. Hüttel <dilfridge@gentoo.org>2023-05-05 22:20:16 +0200
commit190862253a9293810df3854be41acc7d95a2f39d (patch)
tree9773737b164d9f2e68b79c34d618fabd74d29ae2 /x11-misc/xosview
parentdev-libs/apache-arrow: add 12.0.0 (diff)
downloadgentoo-190862253a9293810df3854be41acc7d95a2f39d.tar.gz
gentoo-190862253a9293810df3854be41acc7d95a2f39d.tar.bz2
gentoo-190862253a9293810df3854be41acc7d95a2f39d.zip
x11-misc/xosview: fix build with musl
Signed-off-by: Andreas K. Hüttel <dilfridge@gentoo.org>
Diffstat (limited to 'x11-misc/xosview')
-rw-r--r--x11-misc/xosview/files/xosview-1.23-musl.patch14
-rw-r--r--x11-misc/xosview/xosview-1.23.ebuild6
2 files changed, 19 insertions, 1 deletions
diff --git a/x11-misc/xosview/files/xosview-1.23-musl.patch b/x11-misc/xosview/files/xosview-1.23-musl.patch
new file mode 100644
index 000000000000..a2879f0b957f
--- /dev/null
+++ b/x11-misc/xosview/files/xosview-1.23-musl.patch
@@ -0,0 +1,14 @@
+Musl does not have sys/perm.h. Luckily, sys/io.h has the required
+definitions both for musl and glibc.
+
+diff -ruN xosview-1.23.orig/linux/serialmeter.cc xosview-1.23/linux/serialmeter.cc
+--- xosview-1.23.orig/linux/serialmeter.cc 2020-07-11 14:10:34.000000000 +0200
++++ xosview-1.23/linux/serialmeter.cc 2023-05-05 22:13:19.863489393 +0200
+@@ -25,7 +25,6 @@
+ */
+ #if defined(__i386__) || defined(__ia64__) || defined(__amd64__)
+ #include <sys/io.h>
+-#include <sys/perm.h>
+ #define HAVE_IOPERM
+ #endif
+
diff --git a/x11-misc/xosview/xosview-1.23.ebuild b/x11-misc/xosview/xosview-1.23.ebuild
index e47a5770c69b..0de8636ff4a8 100644
--- a/x11-misc/xosview/xosview-1.23.ebuild
+++ b/x11-misc/xosview/xosview-1.23.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -24,6 +24,10 @@ DEPEND="${COMMON_DEPS}
DOCS=( CHANGES README.linux TODO )
+PATCHES=(
+ "${FILESDIR}/${P}-musl.patch"
+)
+
src_prepare() {
default