summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2021-06-02 16:52:12 -0700
committerMatt Turner <mattst88@gentoo.org>2021-06-02 16:52:43 -0700
commit259e59857fff9ef9a26ea7a702f1b50bbb2de3a7 (patch)
tree0c07cebb5476cece2917922d1156a5e3b86cc053 /x11-misc
parentgnome-base/gnome-shell: Add patches from upstream (diff)
downloadgentoo-259e59857fff9ef9a26ea7a702f1b50bbb2de3a7.tar.gz
gentoo-259e59857fff9ef9a26ea7a702f1b50bbb2de3a7.tar.bz2
gentoo-259e59857fff9ef9a26ea7a702f1b50bbb2de3a7.zip
Revert "x11-misc/colord: Drop old versions"
dm0 requested that this version be restored until the new version cross compiles successfully. This reverts commit 07fda8151b11d904d0b90b82fb87904ab547256f. Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'x11-misc')
-rw-r--r--x11-misc/colord/Manifest1
-rw-r--r--x11-misc/colord/colord-1.3.5.ebuild185
-rw-r--r--x11-misc/colord/metadata.xml2
3 files changed, 188 insertions, 0 deletions
diff --git a/x11-misc/colord/Manifest b/x11-misc/colord/Manifest
index 82082149fc57..b954e9b2b184 100644
--- a/x11-misc/colord/Manifest
+++ b/x11-misc/colord/Manifest
@@ -1 +1,2 @@
+DIST colord-1.3.5.tar.xz 1263488 BLAKE2B de70f3f76e81d3cec826f444e4c6a1603c03b7d97fedcd04a0b9e1977d1e487d7e1327c8b2738b3cf74e9717fb6803d543786c749d3a244faa1a6480e77e3436 SHA512 a0084ad2c08ae88c8023b8bade68f6cf25e13c77a6a37ef127b2914e86b06e6a7a783f9ab3585243d975dbbe1120d5daae13bdb586aefe519bf675458683025f
DIST colord-1.4.5.tar.xz 1869084 BLAKE2B 34c886bade6f71b0b81bbed216695d839873fba46423f6422b80ef2f62e88a403edd1686bb705ef78bcaeb352477e0581d784ccd388961cd42d880661b4b31ab SHA512 b6cc8087ceff4a99b7d764087208cc72e1219d9f6bb52bd3e3eb13bb62e3c1e99aefef36237dceff46925ab7680c76795f59057b7a4d1c8a123de6270708e03c
diff --git a/x11-misc/colord/colord-1.3.5.ebuild b/x11-misc/colord/colord-1.3.5.ebuild
new file mode 100644
index 000000000000..e8a2b5c59e3d
--- /dev/null
+++ b/x11-misc/colord/colord-1.3.5.ebuild
@@ -0,0 +1,185 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+GNOME2_EAUTORECONF="yes"
+VALA_USE_DEPEND="vapigen"
+
+inherit bash-completion-r1 check-reqs gnome2 systemd udev vala multilib-minimal toolchain-funcs
+
+DESCRIPTION="System service to accurately color manage input and output devices"
+HOMEPAGE="https://www.freedesktop.org/software/colord/"
+SRC_URI="https://www.freedesktop.org/software/colord/releases/${P}.tar.xz"
+
+LICENSE="GPL-2+"
+SLOT="0/2" # subslot = libcolord soname version
+KEYWORDS="~alpha amd64 arm arm64 ~hppa ~ia64 ~mips ppc ppc64 ~sparc x86"
+
+# We prefer policykit enabled by default, bug #448058
+IUSE="argyllcms examples extra-print-profiles +gusb +introspection +policykit scanner systemd +udev vala"
+REQUIRED_USE="
+ gusb? ( udev )
+ scanner? ( udev )
+ vala? ( introspection )
+"
+
+DEPEND="
+ dev-db/sqlite:3=[${MULTILIB_USEDEP}]
+ >=dev-libs/glib-2.44.0:2[${MULTILIB_USEDEP}]
+ >=media-libs/lcms-2.6:2=[${MULTILIB_USEDEP}]
+ argyllcms? ( media-gfx/argyllcms )
+ gusb? ( >=dev-libs/libgusb-0.2.7[introspection?,${MULTILIB_USEDEP}] )
+ introspection? ( >=dev-libs/gobject-introspection-0.9.8:= )
+ policykit? ( >=sys-auth/polkit-0.104 )
+ scanner? (
+ media-gfx/sane-backends
+ sys-apps/dbus
+ )
+ systemd? ( >=sys-apps/systemd-44:0= )
+ udev? (
+ dev-libs/libgudev:=[${MULTILIB_USEDEP}]
+ virtual/libudev:=[${MULTILIB_USEDEP}]
+ virtual/udev
+ )
+"
+RDEPEND="${DEPEND}
+ acct-group/colord
+ acct-user/colord
+ !<=media-gfx/colorhug-client-0.1.13
+ !media-gfx/shared-color-profiles
+"
+BDEPEND="
+ acct-group/colord
+ acct-user/colord
+ dev-libs/libxslt
+ >=dev-util/gtk-doc-am-1.9
+ >=dev-util/intltool-0.35
+ >=sys-devel/gettext-0.17
+ virtual/pkgconfig
+ extra-print-profiles? ( media-gfx/argyllcms )
+ vala? ( $(vala_depend) )
+"
+# These dependencies are required to build native build-time programs.
+BDEPEND="${BDEPEND}
+ dev-libs/glib:2
+ media-libs/lcms
+"
+
+# FIXME: needs pre-installed dbus service files
+RESTRICT="test"
+
+# According to upstream comment in colord.spec.in, building the extra print
+# profiles requires >=4G of memory
+CHECKREQS_MEMORY="4G"
+
+pkg_pretend() {
+ use extra-print-profiles && check-reqs_pkg_pretend
+}
+
+pkg_setup() {
+ use extra-print-profiles && check-reqs_pkg_setup
+}
+
+src_prepare() {
+ # Adapt to Gentoo paths
+ sed -i -e 's/spotread/argyll-spotread/' \
+ src/sensors/cd-sensor-argyll.c \
+ configure.ac || die
+
+ use vala && vala_src_prepare
+ gnome2_src_prepare
+ multilib_copy_sources
+}
+
+multilib_src_configure() {
+ if multilib_is_native_abi && tc-is-cross-compiler; then
+ mkdir -p "${S}-native"
+ pushd "${S}-native" >/dev/null 2>&1 || die
+ ECONF_SOURCE="${S}" econf_build --enable-static \
+ --disable-{argyllcms-sensor,print-profiles,shared,udev} \
+ {BASH_COMPLETION,GUDEV,GUSB,POLKIT,SQLITE,UDEV}_{CFLAG,LIB}S=-DSKIP
+ popd >/dev/null 2>&1 || die
+ fi
+
+ # Reverse tools require gusb
+ # bash-completion test does not work on gentoo
+ local myconf=(
+ --disable-bash-completion
+ --disable-examples
+ --disable-static
+ --enable-libcolordcompat
+ --with-daemon-user=colord
+ --localstatedir="${EPREFIX}"/var
+ $(multilib_native_use_enable argyllcms argyllcms-sensor)
+ $(multilib_native_use_enable extra-print-profiles print-profiles)
+ $(multilib_native_usex extra-print-profiles COLPROF="$(type -P argyll-colprof)" "")
+ $(use_enable gusb)
+ $(multilib_native_use_enable gusb reverse)
+ $(multilib_native_use_enable introspection)
+ $(multilib_native_use_enable policykit polkit)
+ $(multilib_native_use_enable scanner sane)
+ $(multilib_native_use_enable systemd systemd-login)
+ $(use_enable udev)
+ --with-udevrulesdir="$(get_udevdir)"/rules.d
+ $(multilib_native_use_enable vala)
+ --with-systemdsystemunitdir="$(systemd_get_systemunitdir)"
+ )
+
+ ECONF_SOURCE=${S} \
+ gnome2_src_configure "${myconf[@]}"
+}
+
+multilib_src_compile() {
+ if multilib_is_native_abi; then
+ if tc-is-cross-compiler; then
+ emake -C "${S}-native/lib/colord" libcolord.la
+ emake -C "${S}-native/client" cd-create-profile cd-it8
+ emake \
+ CD_CREATE_PROFILE="${S}-native/client/cd-create-profile" \
+ CD_IT8="${S}-native/client/cd-it8"
+ else
+ emake
+ fi
+ else
+ emake -C lib/colord
+ use gusb && emake -C lib/colorhug
+ emake -C lib/compat
+ fi
+}
+
+multilib_src_test() {
+ if multilib_is_native_abi; then
+ default
+ else
+ emake -C lib/colord check
+ use gusb && emake -C lib/colorhug check
+ emake -C lib/compat check
+ fi
+}
+
+multilib_src_install() {
+ if multilib_is_native_abi; then
+ gnome2_src_install
+ else
+ gnome2_src_install -j1 -C lib/colord
+ use gusb && gnome2_src_install -j1 -C lib/colorhug
+ gnome2_src_install -j1 -C lib/compat
+ gnome2_src_install -j1 -C contrib/session-helper install-libcolord_includeHEADERS
+ fi
+}
+
+multilib_src_install_all() {
+ einstalldocs
+
+ newbashcomp data/colormgr colormgr
+
+ # Ensure config and profile directories exist and /var/lib/colord/*
+ # is writable by colord user
+ keepdir /var/lib/color{,d}/icc
+ fowners colord:colord /var/lib/colord{,/icc}
+
+ if use examples; then
+ docinto examples
+ dodoc examples/*.c
+ fi
+}
diff --git a/x11-misc/colord/metadata.xml b/x11-misc/colord/metadata.xml
index 5a2462430db0..2ca10f47e351 100644
--- a/x11-misc/colord/metadata.xml
+++ b/x11-misc/colord/metadata.xml
@@ -9,5 +9,7 @@
<flag name="argyllcms">Enable ArgyllCMS sensor</flag>
<flag name="extra-print-profiles">Generate extra print profiles.
Warning: significant build time and memory requirements.</flag>
+ <flag name="gusb">Enable <pkg>dev-libs/libgusb</pkg> support, needed for
+ colorimeter drivers</flag>
</use>
</pkgmetadata>