summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRonny (tastytea) Gutbrod <gentoo@tastytea.de>2021-05-14 22:59:53 +0200
committerJoonas Niilola <juippis@gentoo.org>2021-06-03 15:32:59 +0300
commitce82ceefca4853b9b31284bd331fc6affe9c49e6 (patch)
tree40ebc602e261c33c22d2c2d9561ebd6e62ddca51 /x11-misc
parentkde-apps/konqueror: Fix broken address bar w/ >=KF-5.82 (diff)
downloadgentoo-ce82ceefca4853b9b31284bd331fc6affe9c49e6.tar.gz
gentoo-ce82ceefca4853b9b31284bd331fc6affe9c49e6.tar.bz2
gentoo-ce82ceefca4853b9b31284bd331fc6affe9c49e6.zip
x11-misc/fbpager: Set C++ standard to 14.
Reported upstream: https://sourceforge.net/p/fluxbox/bugs/1188/ Closes: https://bugs.gentoo.org/786690 Signed-off-by: Ronny (tastytea) Gutbrod <gentoo@tastytea.de> Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'x11-misc')
-rw-r--r--x11-misc/fbpager/fbpager-20090221-r1.ebuild10
1 files changed, 9 insertions, 1 deletions
diff --git a/x11-misc/fbpager/fbpager-20090221-r1.ebuild b/x11-misc/fbpager/fbpager-20090221-r1.ebuild
index 9a43ae1ded1a..f8cd87157bf5 100644
--- a/x11-misc/fbpager/fbpager-20090221-r1.ebuild
+++ b/x11-misc/fbpager/fbpager-20090221-r1.ebuild
@@ -1,8 +1,10 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
+inherit flag-o-matic
+
DESCRIPTION="A Pager for fluxbox"
HOMEPAGE="http://git.fluxbox.org/fbpager.git/"
SRC_URI="mirror://gentoo/${P}.tar.bz2"
@@ -16,6 +18,12 @@ DEPEND="x11-libs/libX11
xrender? ( x11-libs/libXrender )"
RDEPEND="${DEPEND}"
+src_prepare() {
+ append-cxxflags "-std=c++14"
+
+ default
+}
+
src_configure() {
econf $(use_enable xrender)
}