summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFederico Angelilli <code@fedang.net>2024-12-09 00:54:22 +0100
committerConrad Kostecki <conikost@gentoo.org>2024-12-15 15:52:01 +0100
commitda3dd2b86b0a1e73cefd019b8e49442a09f82cc2 (patch)
tree9df36f1b487f44f43227cb7666402e957ccfafa0 /x11-misc
parentnet-analyzer/zabbix: bump to 7.2.0 (diff)
downloadgentoo-da3dd2b86b0a1e73cefd019b8e49442a09f82cc2.tar.gz
gentoo-da3dd2b86b0a1e73cefd019b8e49442a09f82cc2.tar.bz2
gentoo-da3dd2b86b0a1e73cefd019b8e49442a09f82cc2.zip
x11-misc/dunst: Update to 1.12.0
Added version 1.12.0 with a message to warn users about a breaking change in dunstrc. Both dunst-9999.ebuild and dunst-1.12.0.ebuild include additional USE flags to control conditional compilation of certain features, like the X backend. Signed-off-by: Federico Angelilli <code@fedang.net> Closes: https://github.com/gentoo/gentoo/pull/39308 Signed-off-by: Conrad Kostecki <conikost@gentoo.org>
Diffstat (limited to 'x11-misc')
-rw-r--r--x11-misc/dunst/Manifest1
-rw-r--r--x11-misc/dunst/dunst-1.12.0.ebuild107
-rw-r--r--x11-misc/dunst/dunst-9999.ebuild32
-rw-r--r--x11-misc/dunst/metadata.xml5
4 files changed, 134 insertions, 11 deletions
diff --git a/x11-misc/dunst/Manifest b/x11-misc/dunst/Manifest
index 5a6de40dc4fe..4a6d6e35e109 100644
--- a/x11-misc/dunst/Manifest
+++ b/x11-misc/dunst/Manifest
@@ -1 +1,2 @@
DIST dunst-1.11.0.tar.gz 4645279 BLAKE2B 0daa8d098f032a0e3b16872bc2e33c8411e8eed543fc13533e649935d2d0796ad74b3fb27769f839972b335b7a2f7ae6b5efd9f324a8bb807ac2f82fa8611a5d SHA512 84c9edccddd183fb867233cb5377115d96735f4c1be84007194ac39dd48d913e5bb021d2952057aecdb978564c2471a8974c4ee4eeccfb188e5345527007a5c4
+DIST dunst-1.12.0.tar.gz 4653739 BLAKE2B ee537ae10333e41d478f8707d88ff892fad8277038efa7c0180fcbea070ef256060aff8bf2d5c9ac9ebe13e69d3d31066007a8eaf2ca3e1c33f5c922abe22714 SHA512 c969d1bc669cd4b56ebb24ac5ad915aea2776746caf06a941630faff662ed08a05d4652946102428d66e5a89c9144e5d0bfcf7113f8fba3e7c28f0777b490052
diff --git a/x11-misc/dunst/dunst-1.12.0.ebuild b/x11-misc/dunst/dunst-1.12.0.ebuild
new file mode 100644
index 000000000000..4a9665d4576b
--- /dev/null
+++ b/x11-misc/dunst/dunst-1.12.0.ebuild
@@ -0,0 +1,107 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit systemd toolchain-funcs
+
+DESCRIPTION="Lightweight replacement for common notification daemons"
+HOMEPAGE="https://dunst-project.org/ https://github.com/dunst-project/dunst"
+SRC_URI="https://github.com/dunst-project/dunst/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv x86"
+IUSE="+completions +dunstify wayland +X +xdg"
+
+DEPEND="
+ dev-libs/glib:2
+ sys-apps/dbus
+ x11-libs/cairo[X?,glib]
+ x11-libs/gdk-pixbuf:2
+ x11-libs/pango[X?]
+ dunstify? ( x11-libs/libnotify )
+ wayland? ( dev-libs/wayland )
+ X? (
+ x11-libs/libX11
+ x11-libs/libXext
+ x11-libs/libXScrnSaver
+ x11-libs/libXinerama
+ x11-libs/libXrandr
+ )
+ xdg? ( x11-misc/xdg-utils )
+"
+
+RDEPEND="${DEPEND}"
+
+BDEPEND="
+ dev-lang/perl
+ virtual/pkgconfig
+ wayland? ( dev-libs/wayland-protocols )
+"
+
+REQUIRED_USE="|| ( wayland X )"
+
+src_prepare() {
+ default
+
+ # Respect users CFLAGS
+ sed -e 's/-Os//' -i config.mk || die
+
+ # Use correct path for dbus and system unit
+ sed -e "s|##PREFIX##|${EPREFIX}/usr|" -i dunst.systemd.service.in || die
+ sed -e "s|##PREFIX##|${EPREFIX}/usr|" -i org.knopwob.dunst.service.in || die
+}
+
+src_configure() {
+ tc-export CC PKG_CONFIG
+
+ default
+}
+
+src_compile() {
+ local myemakeargs=(
+ DUNSTIFY="$(usex dunstify 1 0)"
+ SYSCONFDIR="${EPREFIX}/etc/xdg"
+ SYSTEMD="0"
+ WAYLAND="$(usex wayland 1 0)"
+ X11="$(usex X 1 0)"
+ )
+
+ emake "${myemakeargs[@]}"
+}
+
+src_install() {
+ local myemakeargs=(
+ COMPLETIONS="$(usex completions 1 0)"
+ DUNSTIFY="$(usex dunstify 1 0)"
+ PREFIX="${ED}/usr"
+ SYSCONFDIR="${ED}/etc/xdg"
+ SYSTEMD="0"
+ WAYLAND="$(usex wayland 1 0)"
+ X11="$(usex X 1 0)"
+ )
+
+ emake "${myemakeargs[@]}" install
+
+ systemd_newuserunit dunst.systemd.service.in dunst.service
+}
+
+pkg_postinst() {
+ if [[ ${REPLACING_VERSIONS} ]]; then
+ for v in ${REPLACING_VERSIONS}; do
+ if ver_test "${v}" -ge 1.12.0; then
+ return
+ fi
+ done
+ fi
+
+ einfo "The behaviour of the setting 'height' has been changed in a breaking way."
+ einfo "The way of specifying a maximum height before was:"
+ einfo " height = 300"
+ einfo "The equivalent way now is:"
+ einfo " height = (0, 300)"
+ einfo "For more information read the official RELEASE_NOTES [1]."
+ einfo ""
+ einfo "[1] https://dunst-project.org/release/#v1.12.0"
+}
diff --git a/x11-misc/dunst/dunst-9999.ebuild b/x11-misc/dunst/dunst-9999.ebuild
index 901f3e6a33b9..38f2b2385cea 100644
--- a/x11-misc/dunst/dunst-9999.ebuild
+++ b/x11-misc/dunst/dunst-9999.ebuild
@@ -12,22 +12,24 @@ HOMEPAGE="https://dunst-project.org/ https://github.com/dunst-project/dunst"
LICENSE="BSD"
SLOT="0"
-IUSE="wayland"
+IUSE="+completions +dunstify wayland +X +xdg"
DEPEND="
dev-libs/glib:2
sys-apps/dbus
- x11-libs/cairo[X,glib]
+ x11-libs/cairo[X?,glib]
x11-libs/gdk-pixbuf:2
- x11-libs/libX11
- x11-libs/libXext
- x11-libs/libXScrnSaver
- x11-libs/libXinerama
- x11-libs/libXrandr
- x11-libs/libnotify
- x11-libs/pango[X]
- x11-misc/xdg-utils
+ x11-libs/pango[X?]
+ dunstify? ( x11-libs/libnotify )
wayland? ( dev-libs/wayland )
+ X? (
+ x11-libs/libX11
+ x11-libs/libXext
+ x11-libs/libXScrnSaver
+ x11-libs/libXinerama
+ x11-libs/libXrandr
+ )
+ xdg? ( x11-misc/xdg-utils )
"
RDEPEND="${DEPEND}"
@@ -38,14 +40,17 @@ BDEPEND="
wayland? ( dev-libs/wayland-protocols )
"
+REQUIRED_USE="|| ( wayland X )"
+
src_prepare() {
default
# Respect users CFLAGS
sed -e 's/-Os//' -i config.mk || die
- # Use correct path for system unit
+ # Use correct path for dbus and system unit
sed -e "s|##PREFIX##|${EPREFIX}/usr|" -i dunst.systemd.service.in || die
+ sed -e "s|##PREFIX##|${EPREFIX}/usr|" -i org.knopwob.dunst.service.in || die
}
src_configure() {
@@ -56,9 +61,11 @@ src_configure() {
src_compile() {
local myemakeargs=(
+ DUNSTIFY="$(usex dunstify 1 0)"
SYSCONFDIR="${EPREFIX}/etc/xdg"
SYSTEMD="0"
WAYLAND="$(usex wayland 1 0)"
+ X11="$(usex X 1 0)"
)
emake "${myemakeargs[@]}"
@@ -66,10 +73,13 @@ src_compile() {
src_install() {
local myemakeargs=(
+ COMPLETIONS="$(usex completions 1 0)"
+ DUNSTIFY="$(usex dunstify 1 0)"
PREFIX="${ED}/usr"
SYSCONFDIR="${ED}/etc/xdg"
SYSTEMD="0"
WAYLAND="$(usex wayland 1 0)"
+ X11="$(usex X 1 0)"
)
emake "${myemakeargs[@]}" install
diff --git a/x11-misc/dunst/metadata.xml b/x11-misc/dunst/metadata.xml
index 47e53e6187f7..856034fe4775 100644
--- a/x11-misc/dunst/metadata.xml
+++ b/x11-misc/dunst/metadata.xml
@@ -5,6 +5,11 @@
<email>conikost@gentoo.org</email>
<name>Conrad Kostecki</name>
</maintainer>
+ <use>
+ <flag name="completions">Install shell completions (for bash, fish and zsh)</flag>
+ <flag name="dunstify">Build dunstify (notify-send alternative)</flag>
+ <flag name="xdg">Install xdg-utils for opening links with xdg-open</flag>
+ </use>
<upstream>
<remote-id type="github">dunst-project/dunst</remote-id>
</upstream>