summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBernard Cafarelli <voyageur@gentoo.org>2016-01-04 13:54:16 +0100
committerBernard Cafarelli <voyageur@gentoo.org>2016-01-04 13:56:48 +0100
commit8257db5a530efd327e25324952fb6f746be148bb (patch)
tree5e6cca089c2118519b328f7f42c7c98ae01ffd7a /x11-plugins/asmon/asmon-0.71-r1.ebuild
parentx11-plugins/wmtz: fix compilation with gcc 5, bug #569712 (diff)
downloadgentoo-8257db5a530efd327e25324952fb6f746be148bb.tar.gz
gentoo-8257db5a530efd327e25324952fb6f746be148bb.tar.bz2
gentoo-8257db5a530efd327e25324952fb6f746be148bb.zip
x11-plugins/asmon: fix compilation with gcc 5, bug #569756
Cleaned ebuild with EAPI bump Package-Manager: portage-2.2.26
Diffstat (limited to 'x11-plugins/asmon/asmon-0.71-r1.ebuild')
-rw-r--r--x11-plugins/asmon/asmon-0.71-r1.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/x11-plugins/asmon/asmon-0.71-r1.ebuild b/x11-plugins/asmon/asmon-0.71-r1.ebuild
new file mode 100644
index 000000000000..c4235061514b
--- /dev/null
+++ b/x11-plugins/asmon/asmon-0.71-r1.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit eutils toolchain-funcs
+
+DESCRIPTION="WindowMaker/AfterStep system monitor dockapp"
+HOMEPAGE="http://rio.vg/asmon"
+SRC_URI="http://rio.vg/${PN}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ppc ~sparc ~x86"
+IUSE=""
+
+RDEPEND="x11-libs/libXext
+ x11-libs/libXpm
+ x11-libs/libX11"
+DEPEND="${RDEPEND}
+ x11-proto/xextproto"
+
+S=${WORKDIR}/${P}/${PN}
+
+src_prepare() {
+ sed -i -e "s:gcc:$(tc-getCC):g" Makefile || die
+
+ cd "${WORKDIR}"/${P} || die
+ epatch "${FILESDIR}"/${P}-list.patch
+}
+
+src_compile() {
+ emake clean
+ emake SOLARIS="${CFLAGS}" LIBDIR="${LDFLAGS}"
+}
+
+src_install() {
+ dobin ${PN}
+ dodoc ../Changelog
+}