summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Orlitzky <mjo@gentoo.org>2016-08-29 19:55:10 -0400
committerMichael Orlitzky <mjo@gentoo.org>2016-08-29 20:08:46 -0400
commit93581e09c196fd78eaeb9b01e0d45c2c00ff60bf (patch)
tree107a0832be48e1185b98694711917b05237cb84b /x11-plugins/astime/files
parentwww-plugins/freshplayerplugin: Version bump wrt bug 581228 (diff)
downloadgentoo-93581e09c196fd78eaeb9b01e0d45c2c00ff60bf.tar.gz
gentoo-93581e09c196fd78eaeb9b01e0d45c2c00ff60bf.tar.bz2
gentoo-93581e09c196fd78eaeb9b01e0d45c2c00ff60bf.zip
x11-plugins/astime: new EAPI=6 revision that respects LDFLAGS.
This new revision is based on the ebuild submitted by Michael Mair-Keimberger, with additional updates for EAPI=6. I have also simplified the patch that we apply; now it contains only the addition of LDFLAGS to the linker command. By side-stepping upstream's "make install" target, we avoid having to patch in DESTDIR and all of that. Doing so actually simplifies src_install() a bit, as it can be reduced to a dobin, newman, and dodoc. Gentoo-Bug: 337428 Package-Manager: portage-2.2.28
Diffstat (limited to 'x11-plugins/astime/files')
-rw-r--r--x11-plugins/astime/files/respect-ldflags.patch11
1 files changed, 11 insertions, 0 deletions
diff --git a/x11-plugins/astime/files/respect-ldflags.patch b/x11-plugins/astime/files/respect-ldflags.patch
new file mode 100644
index 000000000000..09325594f242
--- /dev/null
+++ b/x11-plugins/astime/files/respect-ldflags.patch
@@ -0,0 +1,11 @@
+--- a/autoconf/Makefile.common.in 1999-05-02 17:12:39.000000000 +0200
++++ b/autoconf/Makefile.common.in 2013-03-24 16:16:27.494987496 +0100
+@@ -34,7 +33,7 @@
+ done
+
+ $(PROG): $(OBJS)
+- $(CC) $(OBJS) $(LIBRARIES) $(EXTRA_LIBRARIES) -o $(@)
++ $(CC) $(OBJS) $(LIBRARIES) $(EXTRA_LIBRARIES) -o $(@) $(LDFLAGS)
+
+ .c.o:
+ $(CC) $(CCFLAGS) $(EXTRA_DEFINES) $(INCLUDES) $(EXTRA_INCLUDES) -c $*.c