summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Mair-Keimberger <mmk@levelnine.at>2023-09-18 18:45:28 +0200
committerBernard Cafarelli <voyageur@gentoo.org>2023-09-19 22:37:29 +0200
commit1528308e1b3bdb03b4a9f0e239cae1b73bb334f8 (patch)
treeacbb58ab127e364f1860be5790daccce7cee088b /x11-plugins
parentx11-plugins/wmdrawer: EAPI8 bump (diff)
downloadgentoo-1528308e1b3bdb03b4a9f0e239cae1b73bb334f8.tar.gz
gentoo-1528308e1b3bdb03b4a9f0e239cae1b73bb334f8.tar.bz2
gentoo-1528308e1b3bdb03b4a9f0e239cae1b73bb334f8.zip
x11-plugins/wmget: EAPI8 bump
Signed-off-by: Michael Mair-Keimberger <mmk@levelnine.at> Signed-off-by: Bernard Cafarelli <voyageur@gentoo.org>
Diffstat (limited to 'x11-plugins')
-rw-r--r--x11-plugins/wmget/wmget-0.6.1-r1.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/x11-plugins/wmget/wmget-0.6.1-r1.ebuild b/x11-plugins/wmget/wmget-0.6.1-r1.ebuild
new file mode 100644
index 000000000000..abd1153b213f
--- /dev/null
+++ b/x11-plugins/wmget/wmget-0.6.1-r1.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools
+
+DESCRIPTION="Libcurl based dockapp for automated downloads"
+HOMEPAGE="https://www.dockapps.net/wmget"
+SRC_URI="https://www.dockapps.net/download/${P}.tar.gz"
+# Specific to this tarball
+S="${WORKDIR}/dockapps-5aaf842"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+
+RDEPEND="x11-libs/libX11
+ x11-libs/libXext
+ x11-libs/libXpm
+ >=net-misc/curl-7.9.7"
+DEPEND="${RDEPEND}
+ x11-base/xorg-proto"
+
+src_prepare() {
+ default
+ eautoreconf
+}