summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2018-04-05 22:17:21 +0200
committerLars Wendler <polynomial-c@gentoo.org>2018-04-05 22:17:35 +0200
commitbd11fea4532a9b639283a550de7dfe46e221ae7f (patch)
treeb51ccee1fe069c505b7170836029d1fa060255f9 /x11-plugins
parentwww-client/falkon: Set VIRTUALX_REQUIRED="test" (diff)
downloadgentoo-bd11fea4532a9b639283a550de7dfe46e221ae7f.tar.gz
gentoo-bd11fea4532a9b639283a550de7dfe46e221ae7f.tar.bz2
gentoo-bd11fea4532a9b639283a550de7dfe46e221ae7f.zip
x11-plugins/enigmail: Bump to version 2.0.1
Package-Manager: Portage-2.3.28, Repoman-2.3.9
Diffstat (limited to 'x11-plugins')
-rw-r--r--x11-plugins/enigmail/Manifest1
-rw-r--r--x11-plugins/enigmail/enigmail-2.0.1.ebuild83
2 files changed, 84 insertions, 0 deletions
diff --git a/x11-plugins/enigmail/Manifest b/x11-plugins/enigmail/Manifest
index 5e1771810091..ceb90af83427 100644
--- a/x11-plugins/enigmail/Manifest
+++ b/x11-plugins/enigmail/Manifest
@@ -1,2 +1,3 @@
DIST enigmail-1.9.9.tar.gz 1787556 BLAKE2B 729cf7e404b4cc5d964df476e627b476916cd6c834ce5f220a26738bc32eabbd9fd2c4c3cbaccef6e1d8c4b5b7313b54278a4170808f8b722443b338fda87b55 SHA512 39b37305362c88527d897ed95aa9d8457137d5f026359d19b838ab9df531c14099e157afdc8fefae78a6fa2ddded8dbfbeaf84eb91ac6cfbb05ae808731da2cb
+DIST enigmail-2.0.1.tar.gz 2527950 BLAKE2B 4abb734b23cd6ae2be149d017d3ccc36881b7cc82e3551ca5506cb25f22c1023f7329a4d7e1139b9e1a4e2eed5f3b12e444e0e88801dfd4aff547d5f6bc7bab3 SHA512 1795e7e15d8388990fbe1c8aed1747e190c319e8d30dc8d08110714f3fa64dd86aadddcfc1d0644e1f1f915396fe85237e976796a7089b24b7644cc049f8ac80
DIST enigmail-2.0.tar.gz 2526788 BLAKE2B ee41681bba5874b0e8dac5362f49304101567a8dd5da4a8d31c7db353ca61adbe09a5e622a1d69e77a61e82f060266a8644a8c05a241a0f332e4955aed72fff0 SHA512 bbf7c743d51d6010e8dcca575e1530561944b552dd940119cda874c4b70109eedaaee437c108b1ead17a8414935f48083e2bde8020f3504f927bf9e01fb7b4ae
diff --git a/x11-plugins/enigmail/enigmail-2.0.1.ebuild b/x11-plugins/enigmail/enigmail-2.0.1.ebuild
new file mode 100644
index 000000000000..9e8d0cbb3958
--- /dev/null
+++ b/x11-plugins/enigmail/enigmail-2.0.1.ebuild
@@ -0,0 +1,83 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python2_7 )
+
+inherit python-any-r1
+
+DESCRIPTION="Mozilla extension to provide GPG support in mail clients"
+HOMEPAGE="http://www.enigmail.net/"
+
+SLOT="0"
+LICENSE="MPL-2.0 GPL-3"
+IUSE=""
+if [[ ${PV} == *9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://git.code.sf.net/p/enigmail/source"
+ S="${WORKDIR}/${P}"
+else
+ if [[ ${PV} = *_beta* ]] ; then
+ SRC_URI="http://www.enigmail.net/download/beta/${P/_/-}.tar.gz"
+ else
+ SRC_URI="http://www.enigmail.net/download/source/${P}.tar.gz"
+ KEYWORDS="~alpha ~amd64 ~arm ~ppc ~ppc64 ~x86 ~x86-fbsd ~amd64-linux ~x86-linux"
+ fi
+ S="${WORKDIR}/${PN}"
+fi
+
+RDEPEND="|| (
+ ( >=app-crypt/gnupg-2.0
+ || (
+ app-crypt/pinentry[gtk(-)]
+ app-crypt/pinentry[qt4(-)]
+ app-crypt/pinentry[qt5(-)]
+ )
+ )
+ =app-crypt/gnupg-1.4*
+ )
+ !<mail-client/thunderbird-52.5.0
+ !<www-client/seamonkey-2.49.5.0_p0
+"
+DEPEND="${RDEPEND}
+ ${PYTHON_DEPS}
+ app-arch/zip
+ dev-lang/perl
+ "
+
+src_compile() {
+ emake ipc public ui package lang stdlib
+ emake xpi
+
+}
+
+src_install() {
+ local emid=$(sed -n '/<em:id>/!d; s/.*\({.*}\).*/\1/; p; q' build/dist/install.rdf)
+ [[ -n ${emid} ]] || die "Could not scrape EM:ID from install.rdf"
+
+ mv build/enigmail*.xpi build/"${emid}.xpi" || die 'Could not rename XPI to match EM:ID'
+
+ # thunderbird
+ insinto "/usr/share/mozilla/extensions/{3550f703-e582-4d05-9a08-453d09bdfdc6}"
+ doins build/"${emid}.xpi"
+
+ # seamonkey
+ insinto "/usr/share/mozilla/extensions/{92650c4d-4b8e-4d2a-b7eb-24ecf4f6b63a}"
+ doins build/"${emid}.xpi"
+}
+
+pkg_postinst() {
+ local peimpl=$(eselect --brief --colour=no pinentry show)
+ case "${peimpl}" in
+ *gtk*|*qt*) ;;
+ *) ewarn "The pinentry front-end currently selected is not one supported by thunderbird."
+ ewarn "You may be prompted for your password in an inaccessible shell!!"
+ ewarn "Please use 'eselect pinentry' to select either the gtk or qt front-end"
+ ;;
+ esac
+ if [[ -n ${REPLACING_VERSIONS} ]]; then
+ elog
+ elog "Please restart thunderbird and/or seamonkey in order for them to use"
+ elog "the newly installed version of enigmail."
+ fi
+}