summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /x11-terms/evilvte
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'x11-terms/evilvte')
-rw-r--r--x11-terms/evilvte/Manifest2
-rw-r--r--x11-terms/evilvte/evilvte-0.5.1.ebuild44
-rw-r--r--x11-terms/evilvte/evilvte-0.5.2_pre1.ebuild59
-rw-r--r--x11-terms/evilvte/metadata.xml5
4 files changed, 110 insertions, 0 deletions
diff --git a/x11-terms/evilvte/Manifest b/x11-terms/evilvte/Manifest
new file mode 100644
index 000000000000..51f2dde93e14
--- /dev/null
+++ b/x11-terms/evilvte/Manifest
@@ -0,0 +1,2 @@
+DIST evilvte-0.5.1.tar.xz 59732 SHA256 d48166677410e6cb577ee46014a138620bbc95b3425e0ee3f9b7e95ae3ba30cd SHA512 a0381378e42ed7dcae59268c705cc70281756139967a505455d51dca0980b4f768bd96342bc5a26369aa37f616b2680c5c803d0bdf3a6335c788442918741c04 WHIRLPOOL 5fb67705537ce65f565d79f4244eb1d7dceecc973d5eaef165ab48e0d61ffd2ceaf4ef03357c286b018572dd291de4acf53af6eba66d5dc9323094fa3256c122
+DIST evilvte-0.5.2~pre1.tar.xz 60804 SHA256 d51e75f7e1daad12fa55289c17cb2cfb35bcfdbd61b0dfce3b16a966f64e81ec SHA512 db6b08e7c2670f986c454203c24d5fc65663e23b3d2839a84b610f9630047a79daaaeb833834c011dcb6dca3747657b37ac22e6746af9662e2568103fb7c4398 WHIRLPOOL 5bff0681285751a88e5c379ed3036f413c320f56c442b87791c2d16d934d2300b6bf60ffc021f719514272dc21dfd346abceb9f467944c17a391035f0b12bd69
diff --git a/x11-terms/evilvte/evilvte-0.5.1.ebuild b/x11-terms/evilvte/evilvte-0.5.1.ebuild
new file mode 100644
index 000000000000..2d18c4cfb544
--- /dev/null
+++ b/x11-terms/evilvte/evilvte-0.5.1.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+MY_P=${P/_/\~}
+inherit toolchain-funcs savedconfig
+
+DESCRIPTION="VTE based, super lightweight terminal emulator"
+HOMEPAGE="http://www.calno.com/evilvte"
+SRC_URI="http://www.calno.com/${PN}/${MY_P}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+RDEPEND=">=dev-libs/glib-2
+ x11-libs/gtk+:3
+ x11-libs/vte:2.90"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+S=${WORKDIR}/${MY_P}
+
+DOCS=( ChangeLog )
+
+src_prepare() {
+ restore_config src/config.h
+}
+
+src_configure() {
+ tc-export CC
+ ./configure --prefix=/usr --with-gtk=3.0 || die
+}
+
+src_compile() {
+ emake -j1
+}
+
+src_install() {
+ default
+ save_config src/config.h
+}
diff --git a/x11-terms/evilvte/evilvte-0.5.2_pre1.ebuild b/x11-terms/evilvte/evilvte-0.5.2_pre1.ebuild
new file mode 100644
index 000000000000..7c9967a3b03c
--- /dev/null
+++ b/x11-terms/evilvte/evilvte-0.5.2_pre1.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+inherit gnome2-utils toolchain-funcs savedconfig
+
+MY_P=${P/_/\~}
+
+DESCRIPTION="VTE based, super lightweight terminal emulator"
+HOMEPAGE="http://www.calno.com/evilvte"
+SRC_URI="http://www.calno.com/${PN}/${MY_P}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=dev-libs/glib-2
+ x11-libs/gtk+:3
+ x11-libs/vte:2.90"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+S=${WORKDIR}/${MY_P}
+
+DOCS=ChangeLog
+
+src_prepare() {
+ restore_config src/config.h
+}
+
+src_configure() {
+ tc-export CC
+ ./configure --prefix=/usr --with-gtk=3.0 || die
+}
+
+src_compile() {
+ emake -j1
+}
+
+src_install() {
+ default
+ save_config src/config.h
+}
+
+pkg_preinst() {
+ gnome2_icon_savelist
+}
+
+pkg_postinst() {
+ savedconfig_pkg_postinst
+ gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+}
diff --git a/x11-terms/evilvte/metadata.xml b/x11-terms/evilvte/metadata.xml
new file mode 100644
index 000000000000..540f810e069d
--- /dev/null
+++ b/x11-terms/evilvte/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>desktop-misc</herd>
+</pkgmetadata>