summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /x11-terms/st
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'x11-terms/st')
-rw-r--r--x11-terms/st/Manifest2
-rw-r--r--x11-terms/st/metadata.xml8
-rw-r--r--x11-terms/st/st-0.5.ebuild59
-rw-r--r--x11-terms/st/st-0.6.ebuild59
-rw-r--r--x11-terms/st/st-9999.ebuild60
5 files changed, 188 insertions, 0 deletions
diff --git a/x11-terms/st/Manifest b/x11-terms/st/Manifest
new file mode 100644
index 000000000000..4861996828fb
--- /dev/null
+++ b/x11-terms/st/Manifest
@@ -0,0 +1,2 @@
+DIST st-0.5.tar.gz 36710 SHA256 ae80ddfaf8146f7665772efc9b85e05e08be5087682a689ecdf71aa4d4bfdd4e SHA512 fb5d3b6dfb56f35c60a83164d0da2aef67d9fc23b81fdd7c26b9a618c92524a601db5fc4149a3a5054ca3306ecc80e104fa629ecb1516c047a726012237c83d5 WHIRLPOOL 90083bfaca02f7507e706c4d251736b300553e95c12640d948a8a5c273c5339b2080e34d54113a69e7cd0d083207634c645a55744c443efe77a2f7b40a82f9ad
+DIST st-0.6.tar.gz 40271 SHA256 85310c08c3814e099b5e45888f8ac7548640e69e9973e934d4fba38b03737a2b SHA512 31e4b6d2b27d6cea79d6a31dabd7ff4e08a8ab376f06c113123810c05eab25e3964482a6429eecd65c369983cc8ee3694f367e3894ed2cc740c67738c1898d29 WHIRLPOOL 94b526dffa7cb2446160acf4d2bb5e78d25f300c3f2ff4549bbe39ad5fae7ea80428ccdaa61a3603c1a3e6f4b98040983f5d468f218542204c62cb88fb776917
diff --git a/x11-terms/st/metadata.xml b/x11-terms/st/metadata.xml
new file mode 100644
index 000000000000..5b80fb94c393
--- /dev/null
+++ b/x11-terms/st/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer>
+<email>xmw@gentoo.org</email>
+<name>Michael Weber</name>
+</maintainer>
+</pkgmetadata>
diff --git a/x11-terms/st/st-0.5.ebuild b/x11-terms/st/st-0.5.ebuild
new file mode 100644
index 000000000000..0ac64c4c77ac
--- /dev/null
+++ b/x11-terms/st/st-0.5.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit eutils multilib savedconfig toolchain-funcs
+
+DESCRIPTION="simple terminal implementation for X"
+HOMEPAGE="http://st.suckless.org/"
+SRC_URI="http://dl.suckless.org/st/${P}.tar.gz"
+
+LICENSE="MIT-with-advertising"
+SLOT="0"
+KEYWORDS="amd64 ~hppa ~x86"
+IUSE="savedconfig"
+
+RDEPEND="media-libs/fontconfig
+ x11-libs/libX11
+ x11-libs/libXext
+ x11-libs/libXft"
+DEPEND="${RDEPEND}
+ sys-libs/ncurses
+ virtual/pkgconfig
+ x11-proto/xextproto
+ x11-proto/xproto"
+
+src_prepare() {
+ epatch_user
+
+ sed -e '/^CFLAGS/s:[[:space:]]-O[^[:space:]]*[[:space:]]: :' \
+ -e '/^X11INC/{s:/usr/X11R6/include:/usr/include/X11:}' \
+ -e "/^X11LIB/{s:/usr/X11R6/lib:/usr/$(get_libdir)/X11:}" \
+ -i config.mk || die
+ sed -e '/@echo/!s:@::' \
+ -i Makefile || die
+ tc-export CC
+
+ restore_config config.h
+}
+
+src_install() {
+ emake DESTDIR="${D}" PREFIX="${EPREFIX}"/usr install
+ tic -s -o "${ED}"/usr/share/terminfo st.info || die
+ dodoc TODO
+
+ make_desktop_entry ${PN} simpleterm utilities-terminal 'System;TerminalEmulator;' ''
+
+ save_config config.h
+}
+
+pkg_postinst() {
+ if ! [[ "${REPLACING_VERSIONS}" ]]; then
+ elog "Please ensure a usable font is installed, like"
+ elog " media-fonts/corefonts"
+ elog " media-fonts/dejavu"
+ elog " media-fonts/urw-fonts"
+ fi
+}
diff --git a/x11-terms/st/st-0.6.ebuild b/x11-terms/st/st-0.6.ebuild
new file mode 100644
index 000000000000..0190c0183f44
--- /dev/null
+++ b/x11-terms/st/st-0.6.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit eutils multilib savedconfig toolchain-funcs
+
+DESCRIPTION="simple terminal implementation for X"
+HOMEPAGE="http://st.suckless.org/"
+SRC_URI="http://dl.suckless.org/st/${P}.tar.gz"
+
+LICENSE="MIT-with-advertising"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~x86"
+IUSE="savedconfig"
+
+RDEPEND="media-libs/fontconfig
+ x11-libs/libX11
+ x11-libs/libXext
+ x11-libs/libXft"
+DEPEND="${RDEPEND}
+ sys-libs/ncurses
+ virtual/pkgconfig
+ x11-proto/xextproto
+ x11-proto/xproto"
+
+src_prepare() {
+ epatch_user
+
+ sed -e '/^CFLAGS/s:[[:space:]]-O[^[:space:]]*[[:space:]]: :' \
+ -e '/^X11INC/{s:/usr/X11R6/include:/usr/include/X11:}' \
+ -e "/^X11LIB/{s:/usr/X11R6/lib:/usr/$(get_libdir)/X11:}" \
+ -i config.mk || die
+ sed -e '/@echo/!s:@::' \
+ -i Makefile || die
+ tc-export CC
+
+ restore_config config.h
+}
+
+src_install() {
+ emake DESTDIR="${D}" PREFIX="${EPREFIX}"/usr install
+ tic -s -o "${ED}"/usr/share/terminfo st.info || die
+ dodoc TODO
+
+ make_desktop_entry ${PN} simpleterm utilities-terminal 'System;TerminalEmulator;' ''
+
+ save_config config.h
+}
+
+pkg_postinst() {
+ if ! [[ "${REPLACING_VERSIONS}" ]]; then
+ elog "Please ensure a usable font is installed, like"
+ elog " media-fonts/corefonts"
+ elog " media-fonts/dejavu"
+ elog " media-fonts/urw-fonts"
+ fi
+}
diff --git a/x11-terms/st/st-9999.ebuild b/x11-terms/st/st-9999.ebuild
new file mode 100644
index 000000000000..7cde185fdd85
--- /dev/null
+++ b/x11-terms/st/st-9999.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit eutils git-r3 multilib savedconfig toolchain-funcs
+
+DESCRIPTION="simple terminal implementation for X"
+HOMEPAGE="http://st.suckless.org/"
+EGIT_REPO_URI="git://git.suckless.org/st"
+
+LICENSE="MIT-with-advertising"
+SLOT="0"
+KEYWORDS=""
+IUSE="savedconfig"
+
+RDEPEND="media-libs/fontconfig
+ x11-libs/libX11
+ x11-libs/libXext
+ x11-libs/libXft"
+DEPEND="${RDEPEND}
+ sys-libs/ncurses
+ virtual/pkgconfig
+ x11-proto/xextproto
+ x11-proto/xproto"
+
+src_prepare() {
+ epatch_user
+
+ sed -e '/^CFLAGS/s:[[:space:]]-Wall[[:space:]]: :' \
+ -e '/^CFLAGS/s:[[:space:]]-O[^[:space:]]*[[:space:]]: :' \
+ -e '/^LDFLAGS/{s:[[:space:]]-s[[:space:]]: :}' \
+ -e '/^X11INC/{s:/usr/X11R6/include:/usr/include/X11:}' \
+ -e "/^X11LIB/{s:/usr/X11R6/lib:/usr/$(get_libdir)/X11:}" \
+ -i config.mk || die
+ sed -e '/@echo/!s:@::' \
+ -i Makefile || die
+ tc-export CC
+
+ restore_config config.h
+}
+
+src_install() {
+ emake DESTDIR="${D}" PREFIX="${EPREFIX}"/usr install
+ tic -s -o "${ED}"/usr/share/terminfo st.info || die
+ dodoc TODO
+
+ make_desktop_entry ${PN} simpleterm utilities-terminal 'System;TerminalEmulator;' ''
+
+ save_config config.h
+}
+
+pkg_postinst() {
+ if ! [[ "${REPLACING_VERSIONS}" ]]; then
+ elog "Please ensure a usable font is installed, like"
+ elog " media-fonts/corefonts"
+ elog " media-fonts/dejavu"
+ elog " media-fonts/urw-fonts"
+ fi
+}