summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /x11-terms/yeahconsole
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'x11-terms/yeahconsole')
-rw-r--r--x11-terms/yeahconsole/Manifest1
-rw-r--r--x11-terms/yeahconsole/files/yeahconsole-0.3.4-make.patch30
-rw-r--r--x11-terms/yeahconsole/metadata.xml8
-rw-r--r--x11-terms/yeahconsole/yeahconsole-0.3.4-r1.ebuild41
4 files changed, 80 insertions, 0 deletions
diff --git a/x11-terms/yeahconsole/Manifest b/x11-terms/yeahconsole/Manifest
new file mode 100644
index 000000000000..0715a23e673b
--- /dev/null
+++ b/x11-terms/yeahconsole/Manifest
@@ -0,0 +1 @@
+DIST yeahconsole-0.3.4.tar.gz 12281 RMD160 0503254c8ff4f124ca7ec122b3a204826e03a43a SHA1 78b589c21dc16d5b570ceade1d6c9bf337a51eef SHA256 fcf3481f78a263a70f1cb5163630fc22e78bb0915013eb05689c6f4aeb0583ef
diff --git a/x11-terms/yeahconsole/files/yeahconsole-0.3.4-make.patch b/x11-terms/yeahconsole/files/yeahconsole-0.3.4-make.patch
new file mode 100644
index 000000000000..0075c433292b
--- /dev/null
+++ b/x11-terms/yeahconsole/files/yeahconsole-0.3.4-make.patch
@@ -0,0 +1,30 @@
+--- a/Makefile 2006-01-14 16:54:05.000000000 +0100
++++ b/Makefile 2009-02-26 16:18:25.000000000 +0100
+@@ -1,6 +1,4 @@
+ TARGET = yeahconsole
+-CC = gcc
+-#CC = cc
+ INSTALL = install
+
+ PREFIX = /usr/local
+@@ -8,17 +6,16 @@
+ LIBS = -lX11
+ INCLUDES = -I/usr/X11R6/include
+ LIB_DIRS = -L/usr/X11R6/lib
+-FLAGS = -Os -Wall
++FLAGS = -Wall $(CFLAGS)
+
+ OBJECTS := yeahconsole.o
+ SOURCES := yeahconsole.c
+
+ $(TARGET): $(OBJECTS)
+- $(CC) $(DEFINES) $(INCLUDES) $(LIB_DIRS) $(LIBS) -o $@ $<
+- strip $@
++ $(CC) $(FLAGS) $(LDFLAGS) $(DEFINES) $(INCLUDES) $(LIB_DIRS) -o $@ $< $(LIBS)
+
+ $(OBJECTS): $(SOURCES)
+- $(CC) $(FLAGS) $(DEFINES) $(INCLUDES) $(LIB_DIRS) -c -o $@ $<
++ $(CC) $(FLAGS) $(DEFINES) $(INCLUDES) $(LIB_DIRS) -c -o $@ $<
+
+ clean:
+ rm -rf $(TARGET) $(OBJECTS)
diff --git a/x11-terms/yeahconsole/metadata.xml b/x11-terms/yeahconsole/metadata.xml
new file mode 100644
index 000000000000..c3a21340a392
--- /dev/null
+++ b/x11-terms/yeahconsole/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer>
+ <email>jer@gentoo.org</email>
+ <name>Jeroen Roovers</name>
+</maintainer>
+</pkgmetadata>
diff --git a/x11-terms/yeahconsole/yeahconsole-0.3.4-r1.ebuild b/x11-terms/yeahconsole/yeahconsole-0.3.4-r1.ebuild
new file mode 100644
index 000000000000..453d56374682
--- /dev/null
+++ b/x11-terms/yeahconsole/yeahconsole-0.3.4-r1.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="2"
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="yeahconsole turns an xterm or rxvt-unicode into a game-like console"
+HOMEPAGE="http://phrat.de/yeahtools.html"
+SRC_URI="http://phrat.de/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 hppa x86"
+
+IUSE=""
+RDEPEND="x11-libs/libX11"
+DEPEND="${RDEPEND}
+ x11-proto/xproto"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-make.patch
+}
+
+src_compile() {
+ tc-export CC
+ emake || die "make failed"
+}
+
+src_install() {
+ dodir /usr/bin
+ emake PREFIX="${D}"/usr install || die "emake install failed"
+ dodoc README
+}
+
+pkg_postinst() {
+ elog "Do not forget to emerge an xterm compatible terminal emulator"
+ elog "(perhaps x11-terms/xterm or x11-terms/rxvt-unicode), or"
+ elog "${PN} will not work ;-)."
+}