summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2022-12-02 10:37:35 -0500
committerMatt Turner <mattst88@gentoo.org>2022-12-02 10:42:09 -0500
commit3dc56528a1e0c84893d96c1ecd31473625bc238d (patch)
treea8f2a7cb9b380f373738d22ee9e1e461c6e518b6 /x11-terms
parentdev-python/jsonpickle: Add missing gmpy test-dep (diff)
downloadgentoo-3dc56528a1e0c84893d96c1ecd31473625bc238d.tar.gz
gentoo-3dc56528a1e0c84893d96c1ecd31473625bc238d.tar.bz2
gentoo-3dc56528a1e0c84893d96c1ecd31473625bc238d.zip
x11-terms/gnome-terminal: Version bump to 3.46.6
And force on USE=vanilla because Fedora's patch no longer applies. Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'x11-terms')
-rw-r--r--x11-terms/gnome-terminal/Manifest1
-rw-r--r--x11-terms/gnome-terminal/gnome-terminal-3.46.6.ebuild96
2 files changed, 97 insertions, 0 deletions
diff --git a/x11-terms/gnome-terminal/Manifest b/x11-terms/gnome-terminal/Manifest
index 335ea73e1514..c78a4bc239e6 100644
--- a/x11-terms/gnome-terminal/Manifest
+++ b/x11-terms/gnome-terminal/Manifest
@@ -3,3 +3,4 @@ DIST gnome-terminal-3.44.1.tar.xz 1813032 BLAKE2B 3e001139aa0516bd27f7215c692c04
DIST gnome-terminal-3.46.2-cntr-ntfy-autottl-ts.patch.xz 34980 BLAKE2B 97a634da8f586fe03770540a00480f04de5d3210bb45e9af216ac876a85a8199d2d9ed651cae6631a0b432c96d28b5a07202baf79765a2b3767160c1df5cb84a SHA512 96591f7e1f4febfce9d8b10a0fc8aebc09ad07cb2fb36876affaa47f19360944c37e63c173af6f07807247c6f60f34e4e39590ccb1632a64d6e5dbf3912bea74
DIST gnome-terminal-3.46.2.tar.gz 2881209 BLAKE2B 191e9f2f074e2965e85708e92608903173228e9c8df8df3f67eea33a95ab0726f5a0e10c80839d735c57f47ee5388fe70b2eedff21c1d73019ede95d6a00fd78 SHA512 b5a6507f9e908d9bdd4659d961e9618ff75ed5c6e02c6818d8399d4ea355dff7ea1b8bafb4304501d5a46e83e5f8633524c7851d42a39b1bdea5a1545ca1d31d
DIST gnome-terminal-3.46.3.tar.gz 2881211 BLAKE2B a5c0aea858692bbab3ed20d4daa54dc97c98d4b920b09fa0aa52963658f6a327e90398c45ae5ed4dd3a40823ba84eff208f6df5e5e0731a1b1e7d8e531ad7b73 SHA512 d1408bfaf0a7c0b090f140c5ac12fe406fcfb18ddda5745616f209e196cc0b29887a312afa29a8ce319cbc7a0093908305a0fc95c357f8c714084cc696c8e79c
+DIST gnome-terminal-3.46.6.tar.bz2 1680801 BLAKE2B 1abb2f7c0ead350904be19b5de8dd53524430a9702ad1d3268849cc3b05a64c06e4e9e03a01a0780d31cc088a9565c88c5a0c26dc0c14bd1552f93c58a6b2159 SHA512 c16238cf7891eb4ca61aa3bf9c951dd8bce0e6cc45e0ee23e24dc04a23cf7378eebe79cd6f4d7e70a8be5364c8f1e66e5f43b7d96e6f9e8e7b3ef023b5dfa51f
diff --git a/x11-terms/gnome-terminal/gnome-terminal-3.46.6.ebuild b/x11-terms/gnome-terminal/gnome-terminal-3.46.6.ebuild
new file mode 100644
index 000000000000..f8d7ad79a616
--- /dev/null
+++ b/x11-terms/gnome-terminal/gnome-terminal-3.46.6.ebuild
@@ -0,0 +1,96 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+PYTHON_COMPAT=( python3_{8..11} )
+inherit gnome.org gnome2-utils meson python-any-r1 readme.gentoo-r1 xdg
+
+DESCRIPTION="A terminal emulator for GNOME"
+HOMEPAGE="https://wiki.gnome.org/Apps/Terminal/ https://gitlab.gnome.org/GNOME/gnome-terminal"
+
+LICENSE="GPL-3+"
+SLOT="0"
+IUSE="debug +gnome-shell +nautilus vanilla"
+
+# Upstream is hostile and refuses to upload tarballs.
+SRC_URI="https://gitlab.gnome.org/GNOME/${PN}/-/archive/${PV}/${P}.tar.bz2"
+SRC_URI+=" !vanilla? ( https://dev.gentoo.org/~mattst88/distfiles/${PN}-3.46.2-cntr-ntfy-autottl-ts.patch.xz )"
+
+KEYWORDS="~amd64 ~arm ~arm64 ~ia64 ~loong ~ppc ~ppc64 ~riscv ~sparc ~x86"
+
+# FIXME: automagic dependency on gtk+[X], just transitive but needs proper control, bug 624960
+RDEPEND="
+ >=dev-libs/glib-2.52:2
+ >=x11-libs/gtk+-3.22.27:3
+ >=x11-libs/vte-0.70.0:2.91[!vanilla?]
+ >=dev-libs/libpcre2-10
+ >=gnome-base/gsettings-desktop-schemas-0.1.0
+ sys-apps/util-linux
+ gnome-shell? ( gnome-base/gnome-shell )
+ nautilus? ( >=gnome-base/nautilus-43.0 )
+"
+DEPEND="${RDEPEND}"
+# itstool required for help/* with non-en LINGUAS, see bug #549358
+# xmllint required for glib-compile-resources, see bug #549304
+BDEPEND="
+ ${PYTHON_DEPS}
+ dev-libs/libxml2:2
+ dev-libs/libxslt
+ dev-util/gdbus-codegen
+ dev-util/glib-utils
+ dev-util/itstool
+ >=sys-devel/gettext-0.19.8
+ virtual/pkgconfig
+"
+
+DOC_CONTENTS="To get previous working directory inherited in new opened tab, or
+ notifications of long-running commands finishing, you will need
+ to add the following line to your ~/.bashrc:\n
+ . /etc/profile.d/vte-2.91.sh"
+
+src_prepare() {
+ eapply "${FILESDIR}"/${PN}-3.44.1-fix-missing-wexitcode.patch
+ if ! use vanilla; then
+ # https://bugzilla.gnome.org/show_bug.cgi?id=695371
+ # Fedora patches:
+ # Restore transparency support (with compositing WMs only)
+ # OSC 777 desktop notification support (notifications on tabs for long-running commands completing)
+ # Restore "Set title" support
+ # Automatic title updating based on currently running foreground process
+ # https://src.fedoraproject.org/rpms/gnome-terminal/raw/f31/f/gnome-terminal-cntr-ntfy-autottl-ts.patch
+ # Depends on vte[-vanilla] for OSC 777 and the preexec/precmd/etc patches in VTE
+ eapply "${WORKDIR}"/${PN}-3.46.2-cntr-ntfy-autottl-ts.patch
+ fi
+ default
+}
+
+src_configure() {
+ local emesonargs=(
+ $(meson_use debug dbg)
+ -Ddocs=false
+ $(meson_use nautilus nautilus_extension)
+ $(meson_use gnome-shell search_provider)
+ )
+ meson_src_configure
+}
+
+src_install() {
+ meson_src_install
+ if ! use vanilla; then
+ # Separate "New Window/Tab" menu entries by default, instead of unified "New Terminal"
+ insinto /usr/share/glib-2.0/schemas
+ newins "${FILESDIR}"/separate-new-tab-window.gschema.override org.gnome.Terminal.gschema.override
+ fi
+ readme.gentoo_create_doc
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ gnome2_schemas_update
+ readme.gentoo_print_elog
+}
+
+pkg_postrm() {
+ xdg_pkg_postrm
+ gnome2_schemas_update
+}