summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2024-08-24 04:31:51 -0400
committerIonen Wolkens <ionen@gentoo.org>2024-08-24 04:54:00 -0400
commit62e0eeeb3121bd77a3b96a48a3abd3e1731cdf39 (patch)
treeeda1546d2c118e91117dbe79abdff126f7f56b1d /x11-terms
parentdev-qt/qtbase: backport fix for QWindowPrivate plasma crashes (diff)
downloadgentoo-62e0eeeb3121bd77a3b96a48a3abd3e1731cdf39.tar.gz
gentoo-62e0eeeb3121bd77a3b96a48a3abd3e1731cdf39.tar.bz2
gentoo-62e0eeeb3121bd77a3b96a48a3abd3e1731cdf39.zip
x11-terms/kitty-shell-integration: add 0.36.1
Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Diffstat (limited to 'x11-terms')
-rw-r--r--x11-terms/kitty-shell-integration/Manifest1
-rw-r--r--x11-terms/kitty-shell-integration/kitty-shell-integration-0.36.1.ebuild37
2 files changed, 38 insertions, 0 deletions
diff --git a/x11-terms/kitty-shell-integration/Manifest b/x11-terms/kitty-shell-integration/Manifest
index 78b8cad50f6e..5f639214f672 100644
--- a/x11-terms/kitty-shell-integration/Manifest
+++ b/x11-terms/kitty-shell-integration/Manifest
@@ -1,3 +1,4 @@
DIST kitty-0.34.1.tar.xz 8176176 BLAKE2B c39709a065a04b04bf15e6decb9a96c1699c1082de44690c36e4e05a288f6835fa3c5dd059c363a272c98934b5c66cf5d79078b6403c7f15a9e94f3f72aa680c SHA512 1b361823741c8c2a6ce3c5d56d0cbbd51bd0a0d2574312ef5c05f359c70862e0889a9636e4b95865750cbd239b517763315ed0cf4ec46e1feaffc27cf20e0e66
DIST kitty-0.35.2.tar.xz 8220608 BLAKE2B 277803c7036890af34f2e0497ab1d33cb578cba4bfba425d6699e02e2106cde4e10f7dcc6859ce7eea1b4f34795a2f5180328665450ccb49d8a6da4183fa4f50 SHA512 edc78046f942965c823a1202a6d7c85cc2d2acb376824a0f5224d4ba6f48ed0978a00eb7a3e1e6053622a7d5fdcf80009ecfb61a63272cf407dd30f828f47b56
DIST kitty-0.36.0.tar.xz 8850304 BLAKE2B 7070f1cd1f0dbdd11a91771c124d7278a4918f320b3f2bbc299cd1d5cab05e617761d97f2531736757788b130453de73951ee75a4d604ee99b8ef819080e58ac SHA512 910864d9f7d1015f42a641200a3bd3f8b682c108c6732a189098072e83bc263d53589e2dfb6e3383abc635f19d4476f3ab22bd24914c316416a8c9fd89d48b2f
+DIST kitty-0.36.1.tar.xz 8850472 BLAKE2B e03c192d1d523ccc6d20db450fa4f7c4ec741df846152e8363090ed28880aaab40fd5a8c832e5285b6834568730f422353e0bb7e02388e254410ce714f29aa57 SHA512 503ecfc83e367b3f2aacc1bf7849345ef4a50cae69e496325b573660d1fe592cc778d0f9d0d06d5e46210659f4b65b3a7be7dfe1e219565b7371c1848643e111
diff --git a/x11-terms/kitty-shell-integration/kitty-shell-integration-0.36.1.ebuild b/x11-terms/kitty-shell-integration/kitty-shell-integration-0.36.1.ebuild
new file mode 100644
index 000000000000..a50a1338ca92
--- /dev/null
+++ b/x11-terms/kitty-shell-integration/kitty-shell-integration-0.36.1.ebuild
@@ -0,0 +1,37 @@
+# Copyright 2022-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="Shell integration scripts for kitty, a GPU-based terminal emulator"
+HOMEPAGE="https://sw.kovidgoyal.net/kitty/"
+SRC_URI="https://github.com/kovidgoyal/kitty/releases/download/v${PV}/kitty-${PV}.tar.xz"
+S="${WORKDIR}/kitty-${PV}"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~ppc64 ~riscv ~x86"
+RESTRICT="test" # intended to be ran on the full kitty package
+
+src_compile() { :; }
+
+src_install() {
+ # install the whole directory in the upstream suggested location
+ # for consistency (i.e. less variation between distros if someone
+ # ssh into Gentoo), then set symlinks to autoload where possible
+ # (these exit immediately if KITTY_SHELL_INTEGRATION is unset)
+ insinto /usr/share/kitty
+ doins -r shell-integration
+
+ dosym -r {/usr/share/kitty/shell-integration/bash/,/etc/bash/bashrc.d/90-}kitty.bash
+
+ dosym -r /usr/share/{kitty/shell-integration/fish,fish}/vendor_completions.d/kitty.fish
+ dosym -r /usr/share/{kitty/shell-integration/fish,fish}/vendor_conf.d/kitty-shell-integration.fish
+
+ dosym -r /usr/share/{kitty/shell-integration/zsh/completions,zsh/site-functions}/_kitty
+ # zsh integration is handled automatically without needing to modify rc files,
+ # but may require user intervention depending on zsh invocation or if remote
+
+ # this is used internally by the ssh kitten and is not useful there
+ rm -r "${ED}"/usr/share/kitty/shell-integration/ssh || die
+}