summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2024-05-31 07:29:03 -0400
committerIonen Wolkens <ionen@gentoo.org>2024-05-31 08:14:53 -0400
commit8dfd72b654792862caca98bab65d60e3f9d89a9a (patch)
tree51dafd4a7ba6fbd8f3496c16d3f6a912300ce1c5 /x11-terms
parentx11-terms/kitty-terminfo: add 0.35.1 (diff)
downloadgentoo-8dfd72b654792862caca98bab65d60e3f9d89a9a.tar.gz
gentoo-8dfd72b654792862caca98bab65d60e3f9d89a9a.tar.bz2
gentoo-8dfd72b654792862caca98bab65d60e3f9d89a9a.zip
x11-terms/kitty: add 0.35.1
Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Diffstat (limited to 'x11-terms')
-rw-r--r--x11-terms/kitty/Manifest3
-rw-r--r--x11-terms/kitty/kitty-0.35.1.ebuild192
2 files changed, 195 insertions, 0 deletions
diff --git a/x11-terms/kitty/Manifest b/x11-terms/kitty/Manifest
index 3680ad223a09..a7825e441b41 100644
--- a/x11-terms/kitty/Manifest
+++ b/x11-terms/kitty/Manifest
@@ -7,3 +7,6 @@ DIST kitty-0.34.1.tar.xz.sig 566 BLAKE2B fb01069e33f958bfc1aee3e42ab5d8d775d79cf
DIST kitty-0.35.0-vendor.tar.xz 1556648 BLAKE2B 58a6844782db908a721f3617ff8ad456eb436d8e589aeba866b5178fdbe7e94cd40453f949f7960f8e3adb3d6f03fae77708b5979114da7b9b69bedee2778d31 SHA512 7cbe76d2ced4e23c63a47cc05306b315456c7ee0ed5cbe7d21eedb56a364ffc2412c798a3f46c7897f90a457899251fae62ac6da471c99c2166bcacb348778dd
DIST kitty-0.35.0.tar.xz 8206476 BLAKE2B 1c03ed7f3bde0c67790cc47da8afc14d31d21513456004042c48451f4b5fc0891de85e467a16029a1f49b90ba6652f4e356d5101c8d773852b614da3f153692d SHA512 b8c310237b1f0e48c1490f1bcfa009490d1592557bd81d6593a2a3ce71696ab03b3d91bb1dc32212adea70a4e6b5491ea6604d43517e679151df49e11b8de604
DIST kitty-0.35.0.tar.xz.sig 566 BLAKE2B c2fe36945f799c66315da8f11103602981ee4e87ab101e554fa232818cb30745e26d1aed5398f2aa3961134029fbf13f7cd19f6ff3adbc636cee9f64f3e63783 SHA512 b94bb69d66e3e149d8c7a56773f75e3a74136e26569a5864cd6102c2c7764ed662f1b6f0c0e4daa49bd928d3182d7bd6f364802142436bf34544a656957fd615
+DIST kitty-0.35.1-vendor.tar.xz 1556700 BLAKE2B 5ddd5dfee2d443ba74cabe86c2681e957f18533a55f0d2ee8937218fd147c31c661b6ab6f4b66cecf8c1f24fbd515684ac7d89d38d3b4c09753ff787274a64b2 SHA512 12f924a9c1ae7458cdc252295c01ca722e325f28e2f918655fa996a10e5b619b9d21b31218a86fe23674df99bab7d5eb1560fd4f4e19eed26b5a836b0e0a2e43
+DIST kitty-0.35.1.tar.xz 8206388 BLAKE2B cb50b1d6011cf5eac61175c07a8365004c22505363a0a43114f010e6d47388959b308343124b427422797836d6b0e1954ec278301d98ff33acd103d611052727 SHA512 aecda31410b8d52ec7df5a9947f29be04249fadb6af24ee7e0cbb649f09a9e510d9fe6913d24d10c36ef7227187c96a1e3f25a8da840a16ed0bcb8cb46f1f089
+DIST kitty-0.35.1.tar.xz.sig 566 BLAKE2B 2df73c05b410daf39ee03f7f330ef18e13f5457022e081c2fda9992a8b143b8364a0d407abb2e5262419e2924a40009e40f7128c60b9459d34bcf1b309cf1af4 SHA512 3de27d82d48eac0a46c9431b52e857acf5d33407e4b5559aa8c09935fecd88199b0e0be4919cff3892900c43ce0ca28681674525622eeeed285ba9081329b55a
diff --git a/x11-terms/kitty/kitty-0.35.1.ebuild b/x11-terms/kitty/kitty-0.35.1.ebuild
new file mode 100644
index 000000000000..a0231858ba9b
--- /dev/null
+++ b/x11-terms/kitty/kitty-0.35.1.ebuild
@@ -0,0 +1,192 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{10..13} )
+inherit edo flag-o-matic go-env optfeature multiprocessing
+inherit python-single-r1 toolchain-funcs xdg
+
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/kovidgoyal/kitty.git"
+else
+ inherit verify-sig
+ SRC_URI="
+ https://github.com/kovidgoyal/kitty/releases/download/v${PV}/${P}.tar.xz
+ https://dev.gentoo.org/~ionen/distfiles/${P}-vendor.tar.xz
+ verify-sig? ( https://github.com/kovidgoyal/kitty/releases/download/v${PV}/${P}.tar.xz.sig )
+ "
+ VERIFY_SIG_OPENPGP_KEY_PATH=/usr/share/openpgp-keys/kovidgoyal.gpg
+ # x86 currently still works but note that upstream has dropped support and
+ # may ignore issues: https://github.com/kovidgoyal/kitty/commit/29cb128fd
+ KEYWORDS="~amd64 ~arm64 ~ppc64 ~riscv ~x86"
+fi
+
+DESCRIPTION="Fast, feature-rich, GPU-based terminal"
+HOMEPAGE="https://sw.kovidgoyal.net/kitty/"
+
+LICENSE="GPL-3 ZLIB"
+LICENSE+=" Apache-2.0 BSD BSD-2 MIT MPL-2.0" # go
+SLOT="0"
+IUSE="+X test wayland"
+REQUIRED_USE="
+ ${PYTHON_REQUIRED_USE}
+ || ( X wayland )
+ test? ( X wayland )
+"
+RESTRICT="!test? ( test )"
+
+# dlopen: fontconfig,libglvnd
+RDEPEND="
+ ${PYTHON_DEPS}
+ dev-libs/openssl:=
+ dev-libs/xxhash
+ media-libs/fontconfig
+ media-libs/harfbuzz:=[truetype]
+ media-libs/lcms:2
+ media-libs/libglvnd[X?]
+ media-libs/libpng:=
+ sys-apps/dbus
+ sys-libs/zlib:=
+ x11-libs/libxkbcommon[X?]
+ x11-misc/xkeyboard-config
+ ~x11-terms/kitty-shell-integration-${PV}
+ ~x11-terms/kitty-terminfo-${PV}
+ X? (
+ x11-libs/libX11
+ x11-libs/libXcursor
+ )
+ wayland? ( dev-libs/wayland )
+ !sci-mathematics/kissat
+"
+DEPEND="
+ ${RDEPEND}
+ amd64? ( >=dev-libs/simde-0.8.0-r1 )
+ arm64? ( dev-libs/simde )
+ x86? ( dev-libs/simde )
+ X? (
+ x11-base/xorg-proto
+ x11-libs/libXi
+ x11-libs/libXinerama
+ x11-libs/libXrandr
+ )
+ wayland? ( dev-libs/wayland-protocols )
+"
+# bug #919751 wrt go subslot
+BDEPEND="
+ ${PYTHON_DEPS}
+ >=dev-lang/go-1.22:=
+ sys-libs/ncurses
+ virtual/pkgconfig
+ test? ( $(python_gen_cond_dep 'dev-python/pillow[${PYTHON_USEDEP}]') )
+ wayland? ( dev-util/wayland-scanner )
+"
+[[ ${PV} == 9999 ]] || BDEPEND+=" verify-sig? ( sec-keys/openpgp-keys-kovidgoyal )"
+
+QA_FLAGS_IGNORED="usr/bin/kitten" # written in Go
+
+src_unpack() {
+ if [[ ${PV} == 9999 ]]; then
+ git-r3_src_unpack
+ cd "${S}" || die
+ edo go mod vendor
+ else
+ use verify-sig &&
+ verify-sig_verify_detached "${DISTDIR}"/${P}.tar.xz{,.sig}
+ default
+ fi
+}
+
+src_prepare() {
+ default
+
+ # sed unfortunately feels easier on maintenance than patches here
+ local sedargs=(
+ -e "/num_workers =/s/=.*/= $(makeopts_jobs)/"
+ -e "s/cflags.append.*-O3.*/pass/" -e 's/-O3//'
+ -e "s/cflags.append(fortify_source)/pass/" # use toolchain's _f_s
+ -e "s/ld_flags.append('-[sw]')/pass/"
+ )
+
+ # kitty is often popular on wayland-only setups, try to allow this
+ use !X && sedargs+=( -e '/gl_libs =/s/=.*/= []/' ) #857918
+ use !X || use !wayland &&
+ sedargs+=( -e "s/'x11 wayland'/'$(usex X x11 wayland)'/" )
+
+ # skip docs for live version, missing dependencies
+ [[ ${PV} == 9999 ]] && sedargs+=( -e '/exists.*_build/,/docs(ddir)/d' )
+
+ sed -i setup.py "${sedargs[@]}" || die
+
+ local skiptests=(
+ # relies on 'who' command which doesn't detect users with pid-sandbox
+ kitty_tests/utmp.py
+ # may fail/hang depending on environment and shell initialization
+ kitty_tests/{shell_integration,ssh}.py
+ # relies on /proc/self/fd and gets confused when ran from here
+ tools/utils/tpmfile_test.go
+ )
+ use !test || rm "${skiptests[@]}" || die
+}
+
+src_compile() {
+ tc-export CC
+ local -x PKGCONFIG_EXE=$(tc-getPKG_CONFIG)
+
+ go-env_set_compile_environment
+ local -x GOFLAGS="-p=$(makeopts_jobs) -v -x -buildvcs=false"
+ use ppc64 && [[ $(tc-endian) == big ]] || GOFLAGS+=" -buildmode=pie"
+
+ # workaround link errors with Go + gcc + -g3 (bug #924436),
+ # retry now and then to see if can be dropped
+ tc-is-gcc &&
+ CGO_CFLAGS=$(
+ CFLAGS=${CGO_CFLAGS}
+ replace-flags -g3 -g
+ replace-flags -ggdb3 -ggdb
+ printf %s "${CFLAGS}"
+ )
+
+ local conf=(
+ --disable-link-time-optimization
+ --ignore-compiler-warnings
+ --libdir-name=$(get_libdir)
+ --shell-integration="enabled no-rc no-sudo"
+ --update-check-interval=0
+ --verbose
+ )
+
+ edo "${EPYTHON}" setup.py linux-package "${conf[@]}"
+ use test && edo "${EPYTHON}" setup.py build-launcher "${conf[@]}"
+
+ rm -r linux-package/share/terminfo || die # provided by kitty-terminfo
+
+ if [[ ${PV} == 9999 ]]; then
+ mkdir -p linux-package/share/doc/${PF} || die
+ else
+ mv linux-package/share/doc/{${PN},${PF}} || die
+ fi
+
+ # generate default config as reference, command taken from docs/conf.rst
+ if ! tc-is-cross-compiler; then
+ linux-package/bin/kitty +runpy \
+ 'from kitty.config import *; print(commented_out_default_config())' \
+ > linux-package/share/doc/${PF}/kitty.conf || die
+ fi
+}
+
+src_test() {
+ KITTY_CONFIG_DIRECTORY=${T} ./test.py || die # shebang is kitty
+}
+
+src_install() {
+ edo mv linux-package "${ED}"/usr
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+
+ optfeature "audio-based terminal bell support" media-libs/libcanberra
+ optfeature "opening links from the terminal" x11-misc/xdg-utils
+}