summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2024-05-25 07:06:11 -0400
committerIonen Wolkens <ionen@gentoo.org>2024-05-25 07:12:31 -0400
commite3de849d3e63740bfb94b60ee2c1170ee764acf7 (patch)
treeb2afdaf5b9077274ad35668097d1bc4aece1cdf6 /x11-terms
parentx11-terms/kitty-terminfo: add 0.35.0 (diff)
downloadgentoo-e3de849d3e63740bfb94b60ee2c1170ee764acf7.tar.gz
gentoo-e3de849d3e63740bfb94b60ee2c1170ee764acf7.tar.bz2
gentoo-e3de849d3e63740bfb94b60ee2c1170ee764acf7.zip
x11-terms/kitty: add 0.35.0
On non-systemd systems, it now gives a warning that it could not load libsystemd at runtime and there is no switch to disable support. It is however harmless and does not need it at build time, just noisy (albeit most will not notice unless starting kitty from another terminal). Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Diffstat (limited to 'x11-terms')
-rw-r--r--x11-terms/kitty/Manifest3
-rw-r--r--x11-terms/kitty/kitty-0.35.0.ebuild192
2 files changed, 195 insertions, 0 deletions
diff --git a/x11-terms/kitty/Manifest b/x11-terms/kitty/Manifest
index 5226ee83c89e..3680ad223a09 100644
--- a/x11-terms/kitty/Manifest
+++ b/x11-terms/kitty/Manifest
@@ -4,3 +4,6 @@ DIST kitty-0.33.1.tar.xz.sig 566 BLAKE2B 568d54993d6c66670279364c317fa0778594852
DIST kitty-0.34.1-vendor.tar.xz 1528400 BLAKE2B fde7ba3a9713e10e1b6f3d4e3a35bb1edf0ed50004862e2f367df30b416a1b8e34c03c38c47ec4f7363bc10eace0dd03215875c1b5121151671c0b22ac47e189 SHA512 875ca8c324b80e3be8fead1c56710f7f9ca7f5aa0f8e4e8f1e825005cbe85837d9b58a2b271ead201637f9b10fd5e61b7e8e52276e950f30fe326546c6ee33ee
DIST kitty-0.34.1.tar.xz 8176176 BLAKE2B c39709a065a04b04bf15e6decb9a96c1699c1082de44690c36e4e05a288f6835fa3c5dd059c363a272c98934b5c66cf5d79078b6403c7f15a9e94f3f72aa680c SHA512 1b361823741c8c2a6ce3c5d56d0cbbd51bd0a0d2574312ef5c05f359c70862e0889a9636e4b95865750cbd239b517763315ed0cf4ec46e1feaffc27cf20e0e66
DIST kitty-0.34.1.tar.xz.sig 566 BLAKE2B fb01069e33f958bfc1aee3e42ab5d8d775d79cf0c54b427690f4455c524d9baff3789823a6a8dce6494a8006715bc17530f1569c540b30f423c41f8833ae08f8 SHA512 cf60f1044661a62e73191526680ce862ae02e0dd89e017c139261cff8667b20be6aca0fb3b56f06c8ddb0e08a3c55eb428358a9db0b59ef65f2bd246fcf9cd01
+DIST kitty-0.35.0-vendor.tar.xz 1556648 BLAKE2B 58a6844782db908a721f3617ff8ad456eb436d8e589aeba866b5178fdbe7e94cd40453f949f7960f8e3adb3d6f03fae77708b5979114da7b9b69bedee2778d31 SHA512 7cbe76d2ced4e23c63a47cc05306b315456c7ee0ed5cbe7d21eedb56a364ffc2412c798a3f46c7897f90a457899251fae62ac6da471c99c2166bcacb348778dd
+DIST kitty-0.35.0.tar.xz 8206476 BLAKE2B 1c03ed7f3bde0c67790cc47da8afc14d31d21513456004042c48451f4b5fc0891de85e467a16029a1f49b90ba6652f4e356d5101c8d773852b614da3f153692d SHA512 b8c310237b1f0e48c1490f1bcfa009490d1592557bd81d6593a2a3ce71696ab03b3d91bb1dc32212adea70a4e6b5491ea6604d43517e679151df49e11b8de604
+DIST kitty-0.35.0.tar.xz.sig 566 BLAKE2B c2fe36945f799c66315da8f11103602981ee4e87ab101e554fa232818cb30745e26d1aed5398f2aa3961134029fbf13f7cd19f6ff3adbc636cee9f64f3e63783 SHA512 b94bb69d66e3e149d8c7a56773f75e3a74136e26569a5864cd6102c2c7764ed662f1b6f0c0e4daa49bd928d3182d7bd6f364802142436bf34544a656957fd615
diff --git a/x11-terms/kitty/kitty-0.35.0.ebuild b/x11-terms/kitty/kitty-0.35.0.ebuild
new file mode 100644
index 000000000000..a0231858ba9b
--- /dev/null
+++ b/x11-terms/kitty/kitty-0.35.0.ebuild
@@ -0,0 +1,192 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{10..13} )
+inherit edo flag-o-matic go-env optfeature multiprocessing
+inherit python-single-r1 toolchain-funcs xdg
+
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/kovidgoyal/kitty.git"
+else
+ inherit verify-sig
+ SRC_URI="
+ https://github.com/kovidgoyal/kitty/releases/download/v${PV}/${P}.tar.xz
+ https://dev.gentoo.org/~ionen/distfiles/${P}-vendor.tar.xz
+ verify-sig? ( https://github.com/kovidgoyal/kitty/releases/download/v${PV}/${P}.tar.xz.sig )
+ "
+ VERIFY_SIG_OPENPGP_KEY_PATH=/usr/share/openpgp-keys/kovidgoyal.gpg
+ # x86 currently still works but note that upstream has dropped support and
+ # may ignore issues: https://github.com/kovidgoyal/kitty/commit/29cb128fd
+ KEYWORDS="~amd64 ~arm64 ~ppc64 ~riscv ~x86"
+fi
+
+DESCRIPTION="Fast, feature-rich, GPU-based terminal"
+HOMEPAGE="https://sw.kovidgoyal.net/kitty/"
+
+LICENSE="GPL-3 ZLIB"
+LICENSE+=" Apache-2.0 BSD BSD-2 MIT MPL-2.0" # go
+SLOT="0"
+IUSE="+X test wayland"
+REQUIRED_USE="
+ ${PYTHON_REQUIRED_USE}
+ || ( X wayland )
+ test? ( X wayland )
+"
+RESTRICT="!test? ( test )"
+
+# dlopen: fontconfig,libglvnd
+RDEPEND="
+ ${PYTHON_DEPS}
+ dev-libs/openssl:=
+ dev-libs/xxhash
+ media-libs/fontconfig
+ media-libs/harfbuzz:=[truetype]
+ media-libs/lcms:2
+ media-libs/libglvnd[X?]
+ media-libs/libpng:=
+ sys-apps/dbus
+ sys-libs/zlib:=
+ x11-libs/libxkbcommon[X?]
+ x11-misc/xkeyboard-config
+ ~x11-terms/kitty-shell-integration-${PV}
+ ~x11-terms/kitty-terminfo-${PV}
+ X? (
+ x11-libs/libX11
+ x11-libs/libXcursor
+ )
+ wayland? ( dev-libs/wayland )
+ !sci-mathematics/kissat
+"
+DEPEND="
+ ${RDEPEND}
+ amd64? ( >=dev-libs/simde-0.8.0-r1 )
+ arm64? ( dev-libs/simde )
+ x86? ( dev-libs/simde )
+ X? (
+ x11-base/xorg-proto
+ x11-libs/libXi
+ x11-libs/libXinerama
+ x11-libs/libXrandr
+ )
+ wayland? ( dev-libs/wayland-protocols )
+"
+# bug #919751 wrt go subslot
+BDEPEND="
+ ${PYTHON_DEPS}
+ >=dev-lang/go-1.22:=
+ sys-libs/ncurses
+ virtual/pkgconfig
+ test? ( $(python_gen_cond_dep 'dev-python/pillow[${PYTHON_USEDEP}]') )
+ wayland? ( dev-util/wayland-scanner )
+"
+[[ ${PV} == 9999 ]] || BDEPEND+=" verify-sig? ( sec-keys/openpgp-keys-kovidgoyal )"
+
+QA_FLAGS_IGNORED="usr/bin/kitten" # written in Go
+
+src_unpack() {
+ if [[ ${PV} == 9999 ]]; then
+ git-r3_src_unpack
+ cd "${S}" || die
+ edo go mod vendor
+ else
+ use verify-sig &&
+ verify-sig_verify_detached "${DISTDIR}"/${P}.tar.xz{,.sig}
+ default
+ fi
+}
+
+src_prepare() {
+ default
+
+ # sed unfortunately feels easier on maintenance than patches here
+ local sedargs=(
+ -e "/num_workers =/s/=.*/= $(makeopts_jobs)/"
+ -e "s/cflags.append.*-O3.*/pass/" -e 's/-O3//'
+ -e "s/cflags.append(fortify_source)/pass/" # use toolchain's _f_s
+ -e "s/ld_flags.append('-[sw]')/pass/"
+ )
+
+ # kitty is often popular on wayland-only setups, try to allow this
+ use !X && sedargs+=( -e '/gl_libs =/s/=.*/= []/' ) #857918
+ use !X || use !wayland &&
+ sedargs+=( -e "s/'x11 wayland'/'$(usex X x11 wayland)'/" )
+
+ # skip docs for live version, missing dependencies
+ [[ ${PV} == 9999 ]] && sedargs+=( -e '/exists.*_build/,/docs(ddir)/d' )
+
+ sed -i setup.py "${sedargs[@]}" || die
+
+ local skiptests=(
+ # relies on 'who' command which doesn't detect users with pid-sandbox
+ kitty_tests/utmp.py
+ # may fail/hang depending on environment and shell initialization
+ kitty_tests/{shell_integration,ssh}.py
+ # relies on /proc/self/fd and gets confused when ran from here
+ tools/utils/tpmfile_test.go
+ )
+ use !test || rm "${skiptests[@]}" || die
+}
+
+src_compile() {
+ tc-export CC
+ local -x PKGCONFIG_EXE=$(tc-getPKG_CONFIG)
+
+ go-env_set_compile_environment
+ local -x GOFLAGS="-p=$(makeopts_jobs) -v -x -buildvcs=false"
+ use ppc64 && [[ $(tc-endian) == big ]] || GOFLAGS+=" -buildmode=pie"
+
+ # workaround link errors with Go + gcc + -g3 (bug #924436),
+ # retry now and then to see if can be dropped
+ tc-is-gcc &&
+ CGO_CFLAGS=$(
+ CFLAGS=${CGO_CFLAGS}
+ replace-flags -g3 -g
+ replace-flags -ggdb3 -ggdb
+ printf %s "${CFLAGS}"
+ )
+
+ local conf=(
+ --disable-link-time-optimization
+ --ignore-compiler-warnings
+ --libdir-name=$(get_libdir)
+ --shell-integration="enabled no-rc no-sudo"
+ --update-check-interval=0
+ --verbose
+ )
+
+ edo "${EPYTHON}" setup.py linux-package "${conf[@]}"
+ use test && edo "${EPYTHON}" setup.py build-launcher "${conf[@]}"
+
+ rm -r linux-package/share/terminfo || die # provided by kitty-terminfo
+
+ if [[ ${PV} == 9999 ]]; then
+ mkdir -p linux-package/share/doc/${PF} || die
+ else
+ mv linux-package/share/doc/{${PN},${PF}} || die
+ fi
+
+ # generate default config as reference, command taken from docs/conf.rst
+ if ! tc-is-cross-compiler; then
+ linux-package/bin/kitty +runpy \
+ 'from kitty.config import *; print(commented_out_default_config())' \
+ > linux-package/share/doc/${PF}/kitty.conf || die
+ fi
+}
+
+src_test() {
+ KITTY_CONFIG_DIRECTORY=${T} ./test.py || die # shebang is kitty
+}
+
+src_install() {
+ edo mv linux-package "${ED}"/usr
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+
+ optfeature "audio-based terminal bell support" media-libs/libcanberra
+ optfeature "opening links from the terminal" x11-misc/xdg-utils
+}