summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-06-22 15:50:12 +0200
committerMichał Górny <mgorny@gentoo.org>2020-06-22 17:35:37 +0200
commit47d7ca0cf621595fcf9bbc7d3b025a1cda4b740a (patch)
tree95976a9214c1cec7c06699d5e142cbf1ab3ea0d1 /x11-themes/elementary-xfce-icon-theme/elementary-xfce-icon-theme-0.15.1.ebuild
parentsci-libs/scipy: Bump to 1.5.0 (diff)
downloadgentoo-47d7ca0cf621595fcf9bbc7d3b025a1cda4b740a.tar.gz
gentoo-47d7ca0cf621595fcf9bbc7d3b025a1cda4b740a.tar.bz2
gentoo-47d7ca0cf621595fcf9bbc7d3b025a1cda4b740a.zip
x11-themes/elementary-xfce-icon-theme: Bump to 0.15.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'x11-themes/elementary-xfce-icon-theme/elementary-xfce-icon-theme-0.15.1.ebuild')
-rw-r--r--x11-themes/elementary-xfce-icon-theme/elementary-xfce-icon-theme-0.15.1.ebuild46
1 files changed, 46 insertions, 0 deletions
diff --git a/x11-themes/elementary-xfce-icon-theme/elementary-xfce-icon-theme-0.15.1.ebuild b/x11-themes/elementary-xfce-icon-theme/elementary-xfce-icon-theme-0.15.1.ebuild
new file mode 100644
index 000000000000..9d36aba20360
--- /dev/null
+++ b/x11-themes/elementary-xfce-icon-theme/elementary-xfce-icon-theme-0.15.1.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit xdg-utils toolchain-funcs
+
+MY_P="${PN%-icon-theme}-${PV}"
+DESCRIPTION="Elementary icons forked from upstream, extended and maintained for Xfce"
+HOMEPAGE="https://github.com/shimmerproject/elementary-xfce"
+SRC_URI="https://github.com/shimmerproject/elementary-xfce/archive/v${PV}.tar.gz -> ${MY_P}.tar.gz"
+
+LICENSE="public-domain GPL-1 GPL-2 GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=""
+DEPEND="media-gfx/optipng
+ sys-apps/findutils
+ x11-libs/gdk-pixbuf:2
+ x11-libs/gtk+:3"
+
+S="${WORKDIR}/${MY_P}"
+
+src_configure() {
+ # custom script
+ ./configure --prefix="${EPREFIX}/usr" || die
+}
+
+src_compile() {
+ emake CC="$(tc-getCC)"
+}
+
+src_install() {
+ default
+ # delete dangling doc links
+ find -L "${D}" -type l -delete || die
+}
+
+pkg_postinst() {
+ xdg_icon_cache_update
+}
+
+pkg_postrm() {
+ xdg_icon_cache_update
+}