summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMikle Kolyada <zlogene@gentoo.org>2018-09-15 23:13:10 +0300
committerMikle Kolyada <zlogene@gentoo.org>2018-09-15 23:13:58 +0300
commitc9a775a54beffecd6435b239d7f53bc709c94aaf (patch)
tree3e1b3c4835c72f2b2b3a40da444cff1f783bb7bd /x11-themes/gtk-theme-switch
parentdev-lang/python-exec: Clean old up (diff)
downloadgentoo-c9a775a54beffecd6435b239d7f53bc709c94aaf.tar.gz
gentoo-c9a775a54beffecd6435b239d7f53bc709c94aaf.tar.bz2
gentoo-c9a775a54beffecd6435b239d7f53bc709c94aaf.zip
x11-themes/gtk-theme-switch: revbump (EAPI=7)
Package-Manager: Portage-2.3.40, Repoman-2.3.9
Diffstat (limited to 'x11-themes/gtk-theme-switch')
-rw-r--r--x11-themes/gtk-theme-switch/gtk-theme-switch-2.1.0-r1.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/x11-themes/gtk-theme-switch/gtk-theme-switch-2.1.0-r1.ebuild b/x11-themes/gtk-theme-switch/gtk-theme-switch-2.1.0-r1.ebuild
new file mode 100644
index 000000000000..6d5394a73d22
--- /dev/null
+++ b/x11-themes/gtk-theme-switch/gtk-theme-switch-2.1.0-r1.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit toolchain-funcs
+
+DESCRIPTION="Utility to switch and preview GTK+ theme"
+HOMEPAGE="https://packages.qa.debian.org/g/gtk-theme-switch.html"
+SRC_URI="mirror://debian/pool/main/g/${PN}/${PN}_${PV}.orig.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="alpha amd64 hppa ia64 ~mips ppc ppc64 sparc x86 ~x86-fbsd ~amd64-linux ~x86-linux ~x86-macos"
+IUSE=""
+
+RDEPEND="x11-libs/gtk+:2"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+src_prepare() {
+ default
+ sed -i \
+ -e 's:${GCC}:$(CC) $(LDFLAGS):' \
+ Makefile || die
+}
+
+src_compile() {
+ tc-export CC
+ emake CFLAGS="${CFLAGS} -Wall"
+}
+
+src_install() {
+ newbin ${PN}2 ${PN}
+ newman ${PN}2.1 ${PN}.1
+ dodoc ChangeLog readme todo
+}