summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2017-05-10 15:00:35 +0200
committerJeroen Roovers <jer@gentoo.org>2017-05-10 15:00:35 +0200
commit63f60cc7e9d0433f233f8638ef390a554acb2b76 (patch)
treef4820dcb8e5d79e23c078a2bf41ff0542bae821f /x11-wm/lwm/lwm-1.2.4.ebuild
parentsci-mathematics/octave: Mark ~hppa (bug #600482). (diff)
downloadgentoo-63f60cc7e9d0433f233f8638ef390a554acb2b76.tar.gz
gentoo-63f60cc7e9d0433f233f8638ef390a554acb2b76.tar.bz2
gentoo-63f60cc7e9d0433f233f8638ef390a554acb2b76.zip
x11-wm/lwm: Version bump.
Package-Manager: Portage-2.3.5, Repoman-2.3.2
Diffstat (limited to 'x11-wm/lwm/lwm-1.2.4.ebuild')
-rw-r--r--x11-wm/lwm/lwm-1.2.4.ebuild50
1 files changed, 50 insertions, 0 deletions
diff --git a/x11-wm/lwm/lwm-1.2.4.ebuild b/x11-wm/lwm/lwm-1.2.4.ebuild
new file mode 100644
index 000000000000..e9c2c04cd628
--- /dev/null
+++ b/x11-wm/lwm/lwm-1.2.4.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit toolchain-funcs
+
+DESCRIPTION="The ultimate lightweight window manager"
+SRC_URI="http://www.jfc.org.uk/files/lwm/${P}.tar.gz"
+HOMEPAGE="http://www.jfc.org.uk/software/lwm.html"
+
+KEYWORDS="~amd64 ~ppc ~sparc ~x86 ~x86-fbsd"
+LICENSE="GPL-2"
+SLOT="0"
+
+RDEPEND="
+ x11-libs/libICE
+ x11-libs/libSM
+ x11-libs/libX11
+ x11-libs/libXext
+"
+
+DEPEND="
+ ${RDEPEND}
+ x11-misc/imake
+ x11-proto/xextproto
+ x11-proto/xproto
+"
+
+DOCS=( AUTHORS BUGS ChangeLog )
+
+src_prepare() {
+ default
+ sed -i -e "s#(SMLIB)#& -lICE#g" Imakefile || die #370127
+ xmkmf || die
+}
+
+src_compile() {
+ emake \
+ EXTRA_LDOPTIONS="${CFLAGS} ${LDFLAGS}" \
+ CFLAGS="${CFLAGS}" \
+ CC="$(tc-getCC)" \
+ "${PN}"
+}
+
+src_install() {
+ dobin "${PN}"
+ newman "${PN}.man" "${PN}.1"
+ einstalldocs
+}