summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMart Raudsepp <leio@gentoo.org>2019-03-01 00:33:24 +0200
committerMart Raudsepp <leio@gentoo.org>2019-03-01 00:37:50 +0200
commitf7cbaff73571787a03c54ceb8a7d1a2449ec341c (patch)
treebc5a3b0275fa71290f0abc27563f516aecaa0516 /x11-wm/mutter/files
parentgnome-base/gnome-shell: fix and re-enable USE=gtk-doc support (diff)
downloadgentoo-f7cbaff73571787a03c54ceb8a7d1a2449ec341c.tar.gz
gentoo-f7cbaff73571787a03c54ceb8a7d1a2449ec341c.tar.bz2
gentoo-f7cbaff73571787a03c54ceb8a7d1a2449ec341c.zip
x11-wm/mutter: require gles2 for wayland, try to fix non-gles2 builds
Native backend makes use of gles3 for some features, and I'm not sure if these gracefully degrade or not without gles3. So require gles2 with wayland (which is when we enable build of native backend), which also allows for a simpler hacky patch for fixing non-gles2 builds when system doesn't have USE=gles2 on mesa. I consider this quite ugly, but 1) this is ~arch 2) this will be better in the meson port in mutter-3.32 3) it hopefully works well enough anyways, sans potentially unnecessary mesa[gles2] dep and full gles2 cogl builds. People who mind the gles2 requirement are welcome to come up with something better. It should somehow express the feature dependency of this, even if just metadata.xml descriptions. Closes: https://bugs.gentoo.org/679074 Package-Manager: Portage-2.3.52, Repoman-2.3.12 Signed-off-by: Mart Raudsepp <leio@gentoo.org>
Diffstat (limited to 'x11-wm/mutter/files')
-rw-r--r--x11-wm/mutter/files/3.28.3-no-gles2-fix.patch43
1 files changed, 43 insertions, 0 deletions
diff --git a/x11-wm/mutter/files/3.28.3-no-gles2-fix.patch b/x11-wm/mutter/files/3.28.3-no-gles2-fix.patch
new file mode 100644
index 000000000000..43bb05f52458
--- /dev/null
+++ b/x11-wm/mutter/files/3.28.3-no-gles2-fix.patch
@@ -0,0 +1,43 @@
+From 259544c4f4b47418885075c9531ce593c600401c Mon Sep 17 00:00:00 2001
+From: Mart Raudsepp <leio@gentoo.org>
+Date: Fri, 1 Mar 2019 00:02:47 +0200
+Subject: [PATCH] build: Fix build without gles headers
+
+This is an ugly quick fix to hopefully fix non-wayland builds against
+mesa[-gles2].
+It assumes gnome-shell package USE=wayland requires USE=gles2, which it
+sort of does already at runtime already for hybrid graphics support, but
+we ensure with REQUIRED_USE.
+In meson upstream port for 3.32 this will be more properly conditional
+on the gles2 option instead.
+---
+ src/Makefile.am | 6 +++---
+ 1 file changed, 3 insertions(+), 3 deletions(-)
+
+diff --git a/src/Makefile.am b/src/Makefile.am
+index bcb3505c7..a68661b21 100644
+--- a/src/Makefile.am
++++ b/src/Makefile.am
+@@ -118,9 +118,6 @@ libmutter_@LIBMUTTER_API_VERSION@_la_SOURCES = \
+ backends/meta-egl.c \
+ backends/meta-egl.h \
+ backends/meta-egl-ext.h \
+- backends/meta-gles3.c \
+- backends/meta-gles3.h \
+- backends/meta-gles3-table.h \
+ backends/meta-gpu.c \
+ backends/meta-gpu.h \
+ backends/meta-display-config-shared.h \
+@@ -472,6 +469,9 @@ endif
+
+ if HAVE_NATIVE_BACKEND
+ libmutter_@LIBMUTTER_API_VERSION@_la_SOURCES += \
++ backends/meta-gles3.c \
++ backends/meta-gles3.h \
++ backends/meta-gles3-table.h \
+ backends/native/meta-backend-native.c \
+ backends/native/meta-backend-native.h \
+ backends/native/meta-backend-native-private.h \
+--
+2.17.0
+