summaryrefslogtreecommitdiff
path: root/x11-wm
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2024-08-09 13:41:32 +0200
committerPacho Ramos <pacho@gentoo.org>2024-08-09 14:04:09 +0200
commit4e51c2fe12ebfef2a4c2343be8535d9a97a3173e (patch)
treed8b8870f6ffa2af974156d49e5dac7c39918f707 /x11-wm
parentgnome-base/gnome-shell: Rebase favorites patch (diff)
downloadgentoo-4e51c2fe12ebfef2a4c2343be8535d9a97a3173e.tar.gz
gentoo-4e51c2fe12ebfef2a4c2343be8535d9a97a3173e.tar.bz2
gentoo-4e51c2fe12ebfef2a4c2343be8535d9a97a3173e.zip
x11-wm/mutter: sync live ebuild
Signed-off-by: Pacho Ramos <pacho@gentoo.org>
Diffstat (limited to 'x11-wm')
-rw-r--r--x11-wm/mutter/mutter-9999.ebuild22
1 files changed, 8 insertions, 14 deletions
diff --git a/x11-wm/mutter/mutter-9999.ebuild b/x11-wm/mutter/mutter-9999.ebuild
index 2ec64dde579a..69fca7491985 100644
--- a/x11-wm/mutter/mutter-9999.ebuild
+++ b/x11-wm/mutter/mutter-9999.ebuild
@@ -2,7 +2,7 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=8
-PYTHON_COMPAT=( python3_{10..12} )
+PYTHON_COMPAT=( python3_{10..13} )
inherit gnome.org gnome2-utils meson python-any-r1 udev xdg
DESCRIPTION="GNOME compositing window manager based on Clutter"
@@ -13,7 +13,7 @@ if [[ ${PV} == 9999 ]]; then
inherit git-r3
EGIT_REPO_URI="https://gitlab.gnome.org/GNOME/mutter.git"
SRC_URI=""
- SLOT="0/13" # This can get easily out of date, but better than 9967
+ SLOT="0/14" # This can get easily out of date, but better than 9967
else
KEYWORDS="~amd64 ~arm ~arm64 ~loong ~ppc64 ~riscv ~x86"
SLOT="0/$(($(ver_cut 1) - 32))" # 0/libmutter_api_version - ONLY gnome-shell (or anything using mutter-clutter-<api_version>.pc) should use the subslot
@@ -52,7 +52,6 @@ DEPEND="
>=media-libs/lcms-2.6:2
>=media-libs/harfbuzz-2.6.0:=
>=dev-libs/libei-1.0.901
- media-libs/libdisplay-info:=
gnome? ( gnome-base/gnome-desktop:4= )
@@ -62,9 +61,9 @@ DEPEND="
wayland? (
>=dev-libs/wayland-protocols-1.33
- >=dev-libs/wayland-1.22
+ >=dev-libs/wayland-1.22.0
- >=x11-libs/libdrm-2.4.95
+ >=x11-libs/libdrm-2.4.118
media-libs/mesa[gbm(+)]
>=dev-libs/libinput-1.19.0:=
@@ -82,6 +81,10 @@ DEPEND="
>=x11-libs/startup-notification-0.7
screencast? ( >=media-video/pipewire-0.3.33:= )
introspection? ( >=dev-libs/gobject-introspection-1.54:= )
+ test? (
+ >=x11-libs/gtk+-3.19.8:3[X,introspection?]
+ gnome-extra/zenity
+ )
sysprof? ( >=dev-util/sysprof-capture-3.40.1:4 >=dev-util/sysprof-3.46.0 )
"
# for now upstream has "have_x11 = true" in the meson.build, but sooner or later upstream is going to make X optional.
@@ -107,16 +110,9 @@ DEPEND+="
"
# )"
-RDEPEND="${DEPEND}
- !<gui-libs/gtk-4.6.4:4
-"
DEPEND="${DEPEND}
x11-base/xorg-proto
sysprof? ( >=dev-util/sysprof-common-3.38.0 )
- test? (
- >=x11-libs/gtk+-3.19.8:3[X,introspection?,wayland]
- gnome-extra/zenity
- )
"
BDEPEND="
dev-util/wayland-scanner
@@ -151,7 +147,6 @@ python_check_deps() {
src_configure() {
use debug && EMESON_BUILDTYPE=debug
-
local emesonargs=(
# Mutter X11 renderer only supports gles2 and GLX, thus do NOT pass
#
@@ -195,7 +190,6 @@ src_configure() {
-Dtty_tests=false
$(meson_use sysprof profiler)
-Dinstalled_tests=false
- -Dlibdisplay_info=enabled
#verbose # Let upstream choose default for verbose mode
#xwayland_path