summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2018-04-08 09:23:20 +0200
committerMichał Górny <mgorny@gentoo.org>2018-04-08 10:29:24 +0200
commit1c393568a0d0c3a9fde19f0fb2ff42864cde97eb (patch)
tree52456f0791be7f34231b3f451f3fd5646e2fdb19 /xfce-base
parentx11-themes/gtk-engines-xfce: Port to EAPI=6 (diff)
downloadgentoo-1c393568a0d0c3a9fde19f0fb2ff42864cde97eb.tar.gz
gentoo-1c393568a0d0c3a9fde19f0fb2ff42864cde97eb.tar.bz2
gentoo-1c393568a0d0c3a9fde19f0fb2ff42864cde97eb.zip
xfce-base/xfce4-appfinder: Port 4.12.0 to EAPI=6
Diffstat (limited to 'xfce-base')
-rw-r--r--xfce-base/xfce4-appfinder/xfce4-appfinder-4.12.0-r2.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/xfce-base/xfce4-appfinder/xfce4-appfinder-4.12.0-r2.ebuild b/xfce-base/xfce4-appfinder/xfce4-appfinder-4.12.0-r2.ebuild
new file mode 100644
index 000000000000..ab9caaa97bfc
--- /dev/null
+++ b/xfce-base/xfce4-appfinder/xfce4-appfinder-4.12.0-r2.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DESCRIPTION="A tool to find and launch installed applications for the Xfce desktop"
+HOMEPAGE="https://docs.xfce.org/xfce/xfce4-appfinder/start"
+SRC_URI="mirror://xfce/src/xfce/${PN}/${PV%.*}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~x86-solaris"
+IUSE=""
+
+RDEPEND=">=dev-libs/glib-2.30:=
+ >=x11-libs/gtk+-3.2:3=
+ >=xfce-base/garcon-0.3:=
+ >=xfce-base/libxfce4util-4.11:=
+ >=xfce-base/libxfce4ui-4.11:=[gtk3(+)]
+ >=xfce-base/xfconf-4.10:=
+ !xfce-base/xfce-utils"
+DEPEND="${RDEPEND}
+ dev-util/intltool
+ sys-devel/gettext
+ virtual/pkgconfig"
+
+src_configure() {
+ local myconf=(
+ --enable-gtk3
+ )
+ econf "${myconf[@]}"
+}