summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2018-01-25 09:11:05 +0100
committerMichał Górny <mgorny@gentoo.org>2018-01-25 09:39:21 +0100
commit5fb727851c635441e74f8e5c43e0f5c48a815f0d (patch)
tree4cc7256a4b50a50b98a6c1a1b3d9f4d0b4659f57 /xfce-extra/xfce4-timer-plugin/xfce4-timer-plugin-1.7.0.ebuild
parentx11-wm/mutter: fix build with USE=debug (diff)
downloadgentoo-5fb727851c635441e74f8e5c43e0f5c48a815f0d.tar.gz
gentoo-5fb727851c635441e74f8e5c43e0f5c48a815f0d.tar.bz2
gentoo-5fb727851c635441e74f8e5c43e0f5c48a815f0d.zip
xfce-extra/xfce4-timer-plugin: Bump to 1.7.0
Diffstat (limited to 'xfce-extra/xfce4-timer-plugin/xfce4-timer-plugin-1.7.0.ebuild')
-rw-r--r--xfce-extra/xfce4-timer-plugin/xfce4-timer-plugin-1.7.0.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/xfce-extra/xfce4-timer-plugin/xfce4-timer-plugin-1.7.0.ebuild b/xfce-extra/xfce4-timer-plugin/xfce4-timer-plugin-1.7.0.ebuild
new file mode 100644
index 000000000000..1c42fb81f8bf
--- /dev/null
+++ b/xfce-extra/xfce4-timer-plugin/xfce4-timer-plugin-1.7.0.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit gnome2-utils
+
+DESCRIPTION="A simple timer plug-in for the Xfce desktop environment"
+HOMEPAGE="https://goodies.xfce.org/projects/panel-plugins/xfce4-timer-plugin"
+SRC_URI="mirror://xfce/src/panel-plugins/${PN}/${PV%.*}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux"
+IUSE=""
+
+#libx11?
+RDEPEND=">=x11-libs/gtk+-3.20:3=
+ >=xfce-base/libxfce4ui-4.12:=
+ >=xfce-base/libxfce4util-4.12:=
+ >=xfce-base/xfce4-panel-4.10:="
+DEPEND="${RDEPEND}
+ dev-util/intltool
+ virtual/pkgconfig"
+
+src_install() {
+ default
+ find "${D}" -name '*.la' -delete || die
+}
+
+pkg_postinst() {
+ gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+}