summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-12-23 09:13:54 +0100
committerMichał Górny <mgorny@gentoo.org>2022-12-23 09:16:16 +0100
commit988bd1156d4e2c75ab39e8e0ef255891afabc877 (patch)
tree2439edd7361c2dde6ec878410d108fffc1859a83 /xfce-extra
parentdev-ruby/excon: stabilize 0.93.1 for amd64 (diff)
downloadgentoo-988bd1156d4e2c75ab39e8e0ef255891afabc877.tar.gz
gentoo-988bd1156d4e2c75ab39e8e0ef255891afabc877.tar.bz2
gentoo-988bd1156d4e2c75ab39e8e0ef255891afabc877.zip
xfce-extra/xfce4-cpugraph-plugin: Bump to 1.2.7
Closes: https://bugs.gentoo.org/880315 Closes: https://bugs.gentoo.org/888061 Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'xfce-extra')
-rw-r--r--xfce-extra/xfce4-cpugraph-plugin/Manifest1
-rw-r--r--xfce-extra/xfce4-cpugraph-plugin/xfce4-cpugraph-plugin-1.2.7.ebuild45
2 files changed, 46 insertions, 0 deletions
diff --git a/xfce-extra/xfce4-cpugraph-plugin/Manifest b/xfce-extra/xfce4-cpugraph-plugin/Manifest
index 6e82ae9feced..84c52f9c0edb 100644
--- a/xfce-extra/xfce4-cpugraph-plugin/Manifest
+++ b/xfce-extra/xfce4-cpugraph-plugin/Manifest
@@ -1 +1,2 @@
DIST xfce4-cpugraph-plugin-1.2.6.tar.bz2 458058 BLAKE2B 4cd7c9734a52b39d0606f25d5ae559230819e5672b6fe8fb4f19ed5afcf9a446790fe38753ef294ae99767bf06ae9ae08ebd85d66a83dcfb675d945ae2771d00 SHA512 6205a0a7616b0dc5de3cdeb79a5148ee775b426a16b52c491129f74104ab224ec3b29b042a3c8ee05b77cc8775c83d75a8312b96a71504cde50dc257e8354857
+DIST xfce4-cpugraph-plugin-1.2.7.tar.bz2 438674 BLAKE2B d4ca7c850410aeaad7d5eb0156c4feea4a01a0be0d77a62c0165ead9158d2c7e41220ca8ca38e82db69600991f5578f85c1793d1bc94954e9f9cb85cb147316a SHA512 a89f5d9f986717a78a2cbd31db378c1b220cabfc83bf1c85f2533ecccd17b4ed70a3de9321f2e06fcbca2b77d3b02e5a8541e2adf936567a426e1d7221faaa3b
diff --git a/xfce-extra/xfce4-cpugraph-plugin/xfce4-cpugraph-plugin-1.2.7.ebuild b/xfce-extra/xfce4-cpugraph-plugin/xfce4-cpugraph-plugin-1.2.7.ebuild
new file mode 100644
index 000000000000..84165a821e17
--- /dev/null
+++ b/xfce-extra/xfce4-cpugraph-plugin/xfce4-cpugraph-plugin-1.2.7.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit xdg-utils
+
+DESCRIPTION="A system load plug-in for the Xfce panel"
+HOMEPAGE="
+ https://goodies.xfce.org/projects/panel-plugins/xfce4-cpugraph-plugin
+ https://gitlab.xfce.org/panel-plugins/xfce4-cpugraph-plugin
+"
+SRC_URI="https://archive.xfce.org/src/panel-plugins/${PN}/${PV%.*}/${P}.tar.bz2"
+
+LICENSE="BSD-2 GPL-2+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+DEPEND="
+ >=x11-libs/gtk+-3.22:3
+ >=xfce-base/libxfce4ui-4.16.0:=
+ >=xfce-base/libxfce4util-4.17.2:=
+ >=xfce-base/xfce4-panel-4.16.0:=
+"
+RDEPEND="
+ ${DEPEND}
+"
+BDEPEND="
+ dev-util/intltool
+ sys-devel/gettext
+ virtual/pkgconfig
+"
+
+src_install() {
+ default
+ find "${ED}" -name '*.la' -delete || die
+}
+
+pkg_postinst() {
+ xdg_icon_cache_update
+}
+
+pkg_postrm() {
+ xdg_icon_cache_update
+}